Choppy playback on TiVo stream / Android tv

I’m seeing an issue with playback or watching live tv on my TiVo stream. It doesn’t happen on my Fire stick or on iOS but if I cast from iOS to the TiVo stream, then it does happen. The playback is choppy and it seems like it’s missing one or two frames a second so it feels like you’re watching stop-animation sort of. Any suggestions on how to solve?

I’m running Channels on a RPi using the latest updated version and the the specific RPi image build. Channels DVR is wired and everything else is wireless on 5G running on an Orbi mesh network. No other lag issues with streaming services on the TiVo stream, including 4K movies on Netflix.

How are you casting from iOS to the TiVo stream? I wasn’t aware that was possible. I imagine it increases the wifi traffic significantly so it’s possible that may be contributing.

This has happened with me too. A quick toggle of surround sound usually clears it up for me. Next time I planned on submitting diagnostics though.

I'm bumping this thread again. It happened to me just now & I'm unable to get it to stop. So essentially the Tivo client, which is the only one having this issue, is having super choppy playback. I click into a recording or live channel, the stream hangs for a second, audio comes in first, then video starts playing. Now the audio and video are out of sync and the video definitely appears to be missing frames, so the playback is really choppy.

Settings are as follows

  • Streaming Quality - Original (On home wifi)
  • Server & HDHomeRun are connected via Ethernet (It also happens on TVE streams & recordings)
  • Tuner Sharing On
  • Surround Sound - off
  • Video Decoder - Hardware

I've submitted diagnostics from the Tivo Channels app.

When I've hit this point at times, the only way to fix is to uninstall & reinstall. Which is annoying cuz I have to redo that apps preferences again.

Have you tried with software decoding enabled. TiVo messed up hardware decoding in a previous firmware update. In my personal experience, even though TiVo has stated they fixed the issue with the decoder, it is still not quite as good as it when with the initial firmware.

I have switched it to software & hybrid modes. Same issue. I've also switched to each of the modes, force closed the app, cleared cache and restarted. No dice on that either.

Huh. The logs show the audio driver is not reporting playback position back to us so the app thinks audio is not even playing.

Did you try rebooting the device?

I've tried clearing cache, clearing data, rebooting the Tivo Stream and nothing corrects the issue for me. I also tried rebooting the Channels DVR. I see it both on watching something streaming live (pluto or TVE) or watching something recorded.

What can I pull or grab to help you troubleshoot this?

If you submit diagnostics from the app on your TiVo I can compare the logs to @CodeMonkey13's diagnostics earlier.

I just submitted the video playback logs, if something else should get sent let me know.

Whenever I get the "old kung fu movie" sync, I usually have to reboot the HDHR.

Yes, Rebooting the Tivo has yielded no results. I do have surround sound turned off in the Tivo device settings. Do you think that would cause an issue? I'll turn it back on and see if that changes things. One thing to note, is other apps, hulu, Xfinity Stream, youtube, etc... all work when channels is having the issue.

Happens to my TS4K also. I have a Nvidia Shield & CCGTV and this doesn't happen to them. Only solution I found to fix this problem in TS4K is to uninstall the Channels app and re-install in. That usually fixes the problem but it's a pain to do it every time the choppy playback occurs.

this is an issue with the ts4k since the last tivo pushed totally screwed up the entire device for almost everyone. tons of threads on the tivo forums and reddit about it.

the procedure i've found to fix it:

  • go to settings, youtube, uninstall updates
  • go to play store, youtube, update

i have no clue why this fixes it, but it does. seems a little easier than uninstall/reinstall channels, at least in my mind. the downside is it'll happen again every time the damn thing reboots.

Nothing came through. Did it say submitted afterwards?

It did, but, I'm having an issue with my RPi Channels DVR hardware now. I'm going to need to rebuild it it looks like. I was frustrated and power cycled the RPi instead of doing a reboot/shutdown like I should've from the admin interface and it looks like something got corrupted in the exfat DVR partition and it won't mount properly. I followed some of the troubleshooting you had shared previously around this and it fails the fsck step. Me trying to fix it with other tools, made it worse because those tools didn't understand the squashfs partitions, so it looks like I'll have to start over. I'm going to rebuild everything and then get it back connected to the network, see if I can get the stuttering to happen again and then try resubmitting the logs.

Am I correct that the "video display" option is the correct one you need to see?

I've got everything rebuilt and still seeing the stuttering playback and I've submitted the diagnostics and I see the message that says "Diagnostics Uploaded, thank you if you need to follow up..."

realmad001:
I found to fix this problem in TS4K is to uninstall the Channels app and re-install

I just did this and that did clear it up, but like you say, what a pain to have to do that every time it starts being choppy. Hopefully the team has some better options fingers crossed. Thanks for the suggestion!

1 Like

I took the time the other day to set up client settings from the server. So now all my settings stay the same even with an uninstall/reinstall. It makes things more bearable, I'm hopeful that a fix will be found.

1 Like

@tmm1 any luck taking a look at the logs that I shared last week? I've had to uninstall and reinstall the channels app twice this week to "fix" the choppy playback. It would be really nice to not have to do that since the TiVo Stream is my primary device to watch Channels DVR on. Thanks!