Connection lost issues after DSM7 upgrade?

I have channels running on a synology nas and using apple tvs. the HDHR Prime and NAS are connected to the internet through the same switch and I have an eero mesh network providing solid internet throughout my house. Nothing else is buffering/providing any lag or reason for concern except for Channels live TV. Anywhere from 5-30 seconds into watching live TV, I get a connection lost error. I have rebooted the app. Rebooted the HDHR, deleted and reinstalled channels, tried the beta app, and anything else I can think of except for replacing hardware.

This is not a knock on the developers; I love channels, it is a fantastic and well worth it resource in my opinion. I submitted logs to support, they asked if the devices were on the same switch, and I haven't heard anything else. Really the only reason I'm posting is because of football season and watching games/red zone otherwise I'd be more patient.

Any assistance or ideas from the community are welcome!

Are your Apple TV's connected wirelessly? Mesh WiFi networks are poor for OTA broadcast streaming because their bandwidth is reduced by half by nature of the mesh, and OTA streams are high bandwidth.

I have a very similar setup, and am not experiencing this issue. Just curious - is your Apple TV hard wired or wirelessly connecting to your network? What kind of connection speeds are you getting?

If wireless, maybe restart your router. And after that, maybe restart your Apple TV? I have a mesh network and have found that on rare occasions my Apple TV will connect to the wrong satellite and have significantly lower speeds.

Actually, a mesh network usually keeps pretty close to 100% bandwidth because it has a dedicated backhaul channel. You may be thinking of a network extender, which will definitely cut your bandwidth in half.

1 Like

Both ATVs are connected wirelessly (old house, significant cost to run cat5 or 6 to where I need if even possible) and any speedtests provide feedback that the devices should have plenty of bandwidth.

Restarting the mesh network with the ATVs off and then restarting might be an option; certainly can't hurt.

1 Like

The connection lost issue sounded familiar to me, and I was trying to remember if/when it happened to me and how I fixed it. It finally came back to me. I used to have a few Apple Airport Extremes around the house. My ATV in the bedroom connects wirelessly, and it would drop connections periodically with that setup. When I trashed the Airports and get an Orbi mesh system, the problem was resolved. Good luck!

I’ve had problems with Live TV and ‘lost connection’ issues for a few weeks with my Apple TV. Similarly, I couldn’t find any network issues or other likely causes.

It turned out to be space issues on the Apple TV. I downloaded the TV Info app and found that Channels was using about 45 GB of storage but Apple was only reporting 113 MB.

I deleted Channels from the Apple TV and reinstalled it and everything was OK again. Maybe the upgrade to DSM7 is unrelated? Might be worth a try…

@BigCouch isn't that interesting. I will do the same and see if any issues resolve. I imagine you had to delete it on more than 1 device? I have 2 ATVs so wondering if deleting it off of only 1 the first time had any bearing on it.

BTW I do trust someone with the handle 'BigCouch' in this area for some reason.

Does your old house have cable drops? If so, MOCA will give you a much better experience. It’s a bit pricy, unfortunately.

Ive entertained it, but I get about 500mb down and 17mb up at the router and most of the time 50mbps down when i do tests on the ATV. the issue really only started about 4-6 weeks ago and I hadn't had issues before.

I’ve only got one Apple TV, so only one possible culprit! I guess delete it from any Apple TVs that are suffering the lost connection issue.

I’ve also got a ‘Trust Me’ badge that adds even more confidence to my advice! :grinning:

50 Mbps isn’t great, especially if it’s wifi. I understand it just started recently, but when dealing with wireless connections there are so many variables that can come into play. A neighbor’s AP moving onto the same channels you’re using could cause issues to appear seemingly out of nowhere, as an example.

1 Like

Let’s try to get out of the realm of speculation though. You mentioned this only happens when watching live TV via the HDHomeRun, correct? If so, do you have tuner sharing enabled on the clients?

Ok so I “lied.” On one of the ATVs I get 118 down; I imagine I get at least close to that or the same on the other. Chatter from others I admit “could” be an issue but I live in a rural area and my guess based on age of those around me at best they have a mesh system that covers their homes similar to mine. More likely they have a ISP installed router.

I do have tuner sharing turned on, it’s only me watching though when this happens. Could it still be an issue?

The good news about tuner sharing is that the DVR server might be logging something of value when this happens. Next time you encounter the issue paste any errors that appear in the server web ui log at the time. It might help narrow it down.

here's a copy of the error I get before the connection is lost. I also experience most if not all of my recordings telling me the recordings were interrupted when I go to play them back. The same error appears about not receiving data for 6 seconds. They're nearly perfect, maybe a hiccup here or there and commercial recordings aren't flawless but not as much of an issue as live tv being impossible at this point. The Apple TV HDHR app works although the guide is pretty terrible in comparison.

I get that internet interruption would be a likely culprit but I don't notice it on any other devices and it has not caused problems before DSM 7. I uninstalled and reinstalled channels on my NAS and even recreated all the series passes versus saving and reinstalling them as well.

I've reached out to the developers who reply and ask for my logs and then go silent. A simple 'we're not sure what's going on' or 'get a new cable card' would be at least something to work off of. I love channels and have told anyone who is curious about it and my setup, it passes the wife and kid test and is a great resource so this isn't a knock against them; I just want to fix it.

I can say a 3 to 4 days ago I was getting a lot of disconnects. But I would have summed that up to the tv provider or my internet connection. The last two I haven't noticed it.

I have a DS920+. But I also updated it with the latest release of 7.0.1. Notes on that date 9-28-2021 and updates are rolling out. Not sure if you are on the latest version. You can manually download from the synology website if you don't want to wait for the auto update.

I do know since the Apple TV 15 release I have had some weird disconnects with that. Where the internet connection totally dropped and had to restart the box. This happened on both 4k 2021 boxes at separate times.

1 Like

I’ve been running DSM 7 on my 218+ for months now with no connectivity issues.. have you checked to see if the NAS is under heavy load when this occurs? If it only happens with TVE sources I would recommend a continuous ping test from the NAS to see if you’re experiencing packet loss.

I checked for heavy load issues and my NAS doesn't do a ton, really only run it for channels and plex and usually one at a time. Thanks for chiming in, appreciate it.

I was impacted by flooding by hurricane Ida and I'm wondering if water reached where the connection enters my house. Going to contact my ISP today to see if they can ping my connection and get a clear signal.

  1. Update dvr to prerelease

  2. Make sure appletv is set to home streaming quality original

  3. Submit diagnostics from the app after it happens