DirecTV TVE lost 60 channels due to error 0066

Update to prerelease

You're the man @tmm1!!! That looks to be resolving the issue
Screen Shot 2022-03-03 at 4.14.13 PM

It's held since yesterday. I'll test again this evening.

Unfortunately, that doesn't fix error 0066 as mentioned in this thread by several people.

Any ideas to avoid having to keep reinstalling the source every single time?

1 Like

Sounds like your IP is changing? Are you using a VPN?

I don't use a VPN but I will check my router settings and watch my external IP address for changes.

I’m still seeing the same issue as well. It’s getting old tbh. Guess I’ll have to consider going back to the DirectTV DVR.


I'm having similar problems. Doing a daily remove source and add again.

Try the latest build:

1 Like

The update is pending for me now after a recording is finished.

Just curious, how often does the software check for error 0066?

1 Like

@tmm1, Any thoughts on why this seems to be happening for some DirecTV accounts and not others?

1 Like

Dunno I've never used DTV

This fixed mine finally! Back to 185 channels. I didn't remove the source and re-add either.

Took way longer to scan. Still have 0066 errors in the log but looks like it may try an alternate authentication method when the 0066 error comes? Not sure but glad it's back working.

Thank you!

1 Like

WHAT fixed yours?

I would like to try it.

@Skipper See the second post from tmm1 above:

In my case, this is strange (in a good way) because I don't see any occurrences of the 0066 error in the log that goes back as far as 2022/03/04 10:55:26.158003. Even before I updated to this latest version.

I might be crazy to say this but it just happens that I removed the Frndly TV source that was running from a docker container on the night of 2022-03-03. Coincidently, no new 0066 errors since. Truly a coincidence or related? That is the crazy question. :laughing:

Latest pre-release seems to have finally possibly fixed this. At least unlike before, rescanning of individual channels with the 0066 error seems to work. Removing the source was not necessary nor was a full rescan of all channels. :crossed_fingers:

Curious what was changed to fix it and why it only affected some DTV users & some channels.

Last night, I tried to view a DTV channel live and it took quite a little while to show up. So I checked the log after and sure enough, error 0066 occurred at that time. But the good news is that Channels retried and got through. :slightly_smiling_face::+1:

As far as I'm concerned, this issue is fixed.

Thank you, @tmm1, for implementing the retry. :slightly_smiling_face:

1 Like

My DirecTV channels stopped working so I was attempting to remove it and re-add it but I get the same error as gundy. TypeError: Illegal invocation at reactValueSet (tveloginhelper.js:253:28) at formLogin (tveloginhelper.js:19:7) at attComLogin (tveloginhelper.js:123:5) at tveloginhelper.js:380:5 I can login to the DirecTV site just fine but not on the TV Everywhere. My Synology server says it is using the latest version. Please help - Thanks

On the DVR web UI, click the down arrow next to Check for Update and select Prerelease