Dropping Frames on 1080i Channels

I have a couple of Fire Stick 4k devices on my network that I use with Channels. I also have an Apple TV 4k that is on my main television. I do not watch the Fire Sticks that often, but I have noticed the past few times I have watched any 1080i content from my HDHomeRun tuners it looked choppy. I turned on show stats and it is dropping a lot of frames. Several hundred in a very short period of time. I have tried switching from hardware to software decoding with the same results. This does not occur on 720p channels or on 480i content. Those channels play just fine. I can also view the channel in the native HDHomeRun app and it looks fine. This is something new that occurred after the latest update to the Fire TV interface. Before the last update, everything worked well. I was curious if anyone else has noticed this or if it is just me. I would appreciate any input.


1 Like

I use Firestick 4k Max devices and don't have any problems with dropped frames on any channels. I do have Playback, Advanced Settings, Video Decoder set to Hardware. I have checked this on the client released and current beta versions. Also, on the client beta version I generally set Aways use HLS to On in the Debug settings. This forces the server to stream the video and can increase the pause buffer to at least 4 hours.

I have not seen this behavior on the 1 Firestick4K I own. My main source is OTA/HDHomeRun plus TVE. My playback Advanced settings include:
Video Decoder = Hardware
Stretch Video to Fit = Off
Surround Sound = Off

Client is Channels DVR 4.5.1

Hope the above information is useful to you

That is the exact configuration that I have as well. My Firestick4K is not the new max but a couple of years old. I have tried the Hardware and Software settings in the video decoder and they both produce the same results. All of the other settings are identical to yours. The funny thing is the native HDHomeRun app plays the 1080i channels just fine. I have not tried deleting the Channels DVR app and re-installing. I will give that a try tonight. What is strange is that both of the Firestick4K's are exhibiting the same behavior. If it was just one, I would think it was an issue with the installation. The only other thing I can try is a full factory reset of the Firestick. I figured without any other posts, that it is something strange with my setup. If I get a resolution, I will post it.


1 Like

Did you check the web server to to use Hardware de-interlacing ?


I believe all Firesticks use WiFi instead of Ethernet connections. I'd be curious if moving the offending Firestick closer to the WAP it is using might help.

I believe the Cubes and TVs with Fire OS have Ethernet ports built-in. Also, Amazon offers a first-party USB-OTG Ethernet adapter for its Fire TV Stick devices.

1 Like

Yes, all true.

I have this same issue with a 4k Stick that I bought over the holidays. It gets so bad that the picture starts tearing and will eventually drop out. Will try to gather up some info to post

At least I know I’m not crazy now! When it was on version 4.4.1 everything worked fine. When it changed to version 4.5.0 that is when I started noticing the issue. It only does this on 1080i channels. If you are just watching news or a show without a lot of movement, you do not notice it so much, but if you are trying to watch a football game it's horrible. You are correct the picture is jittery and looks like it is "tearing" if you keep watching long enough on mine the screen will eventually go green with audio only. The only recourse at that point is to reset the firesitck. 480i, 720p and TVE channels do not exhibit this behavior. Recordings of 1080i channels will do the same thing. If you go up and enable show stats, you will see that it is dropping hundreds of frames in a very short time. What is interesting is that the native HDHomeRun app does not do this, so I know it is something with channels. I have a CBS and NBC affiliate that are both 1080i and I watch a fair amount or programming from those channels. If I record a show from either of these channels and put the recording in Handbrake and re-encode it as MP4 and strip the interlacing out, they play fine. Firestick was may main device when I first started with Chanels. I moved my main tv to Apple TV and it works flawlessly on that platform. I do not want to put that kind of money out for every tv that I own though. Right now my firesticks are on extra tv's that are not used a lot and it is not a huge issue at the moment, but I sure hope they figure this out in some future update. I am assuming this has something to do with how channels is accessing the hardware decoder. I have tried switching to software decoding and that is a little better, but the end result is still the same. Let me know if you figure anything out.

What is your Settings > Playback > Advanced > Video Driver

On my firestick I only have an options for Video Decoder and it is set to Hardware at the moment. The Video Driver setting is only on my Apple TV. I have tried Software decoding with not much different results. In the beta version of the app, I have had a little bit of luck enabling Legacy HDHomeRun streaming. That will stabilize things for a bit (like about 15 min.) then the picture will start to look choppy again and sure enough it is dropping frames on the output like crazy. Right now I am watching a motorcycle dirt race on NBC and at times it looks like it is in sow motion. I will submit my diagnostic logs if that will help.

I just submitted diagnostic logs from one of my firesticks.

You can try software setting for Video Decoder

Looks like there may be a few updates since the original version. I just checked mine. I am running the latest version NS6294/4239. I remember it working fine when I first got it and then did updates, this is when the problem started. Not sure what the last “working” version was though.

Change log from AZ:

I have tried the software decoding. The results are the same, maybe slightly better, but the same. This condition is present on two Firestick 4k’s and one of the new 2022 fire sticks. All three are doing the same thing.

So I have an interesting update to share about this issue. Up until yesterday. I was using a Pi3 as my server using Hdwe transcoding. I changed to an old dual-core Intel based Pentium that I had lying around and put w/10 on it. Used my 1TB SSD in it 50gig for boot and rest for storage.

I switched mainly because Philo would not play on an ARM CPU and was having problems with TVE on the Pi Kernal. I only have the software transcoding option as this is obviously old hardware.

Now to the Firestick 4k, no longer has any tearing/ripping/stuttering nor timeouts with 1080i video sources. Also my Philo plays fine as well.

I know that Intel vs Pi/ARM is an apple to oranges comparison, but just needed to find something that worked.

I'm seeing a lot of dropped frames on a 50U6HF and a Fire Stick Lite but not a Fire Stick 4K MAX. Server is Windows 10 on an 8265U soon to be upgraded to Windows 10 on a 9600T.

I just pinged them with the same issue last night on my 55 FTV Omni. I am running a WIN/10 on an i-5 4310U platform as my DVR. Double-check like I did and see if the problem goes away when watching on the native HDHR app. When I tested this, all was normal. Hopefully they can find a fix soon as this is also affecting the new 4k FireSticks as well.