DVR Access Failure Remote Access Problem

Hi,

Remote Access used to work. Don’t know what happened, neither iOS app nor web remote access works. I even tried my.channel.net:8089! I have not modified the port forwarding part, the 8089 port forwarding setting is still in the router. If I access my DVR locally using Safari or Chrome browsers, it works! Just the remote access is having problem. BTW, I have other port forwarding to the same server, those Apps are working fine. Just Channel DVR 8089 is not working.

Should I restart Channel DVR?

Thanks,
Roger

Please use the port checker to make sure your port-forwarding and firewall settings are correct: Accessing dvr remotely

Hmmm... Interesting. Some countries can access, some countries can't like US which is where I'm based. Please see photo.

This means your router or ISP is applying some sort of firewall

I have been trying to troubleshoot this remote access problem with no luck. This is a QNAP NAS server, I have all sorts of TCP ports opened and forwarded by the routers. SFTP/HTTPS/SSH/Plex/VNC, all of them are working remotely except Channels DVR. I restarted the QNAP, I restarted the router, disabled firewall, double checked the port forwarding, I don’t have Virtual station running, and I can connect locally using port 8089. And, I still have not had any luck. Any other suggestion? I cannot imagine my ISP (Charter) would specifically block port 8089. Is it possible I use other ports for Channels DVR?

It might be worth rebooting your router

I rebooted the router, still doesn't work. I think it's something to do with the SSL. Please see photo for the error. Do you want me to unicast you with the log?

Another point, if I use cellular LTE (no wifi), I can access the DVR web page via http and my public IP address using Safari. But if I enter “https” in safari, then safari would get stuck.

Is SSL not working on my end?

This is to show using cellular LTE accessing http:

Does the port checker work now?

I used 4 different port checkers sites, they all confirmed 8089 is accessible from outside. My cellphone can also access DVR web page via port 8089 using “http”, but not with “https”. Is it something to do with the SSL certificate?

Could be… I am traveling so I can’t check until this weekend.

Got it! Please let me know what info I can provide once you return.

Thanks much.

Please send me a private message with your IP and I will run some tests.

I enabled REMOTE DVR to test while on vacation. It appears I can get the menu system fine. But when I click on a show from ON NOW then I click Watch the Channels App just closes without starting. I have only tested on iPhone and iPad with the same results. I am testing using a Hot Spot (not on my phone) in my home which works fine for normal stuff. I do have Internet access set to default instead of ORIGINAL.

You need to be using v2.2.4 for remote streaming to work correctly.

How about for tvOS (Apple TV). I noticed you replied to someone else that v2.2.4 was just approved for release in the App Store.

v3.2.4 for Apple TV is also out. You can probably go to the App Store and see the Update button there.

Re: The iOS app: The app store said it was 2.2.4, but the About says it’s 2.2.3

The app should say 2.2.4 inside or its not updated. Sometimes it can take a while for the new build to propagate completely- the metadata will update on the app store but the download link is still pointing to the old build.