DVR suddenly stopping on Raspberry PI

I updated to a pre-release a few days ago and since then I have twice found the DVR has stopped working. The Pi is still on but no DVR to be found. Restarting the Pi causes it to reappear.

I am not smart enough to read the logs, but I took a quick look and this is where it went south.

2021/04/27 16:08:57.422030 [DVR] Running commercial detection on file 3334 (Movies/The Valley of Light (2007) 2021-04-27-1400.mpg)
2021/04/27 16:32:59.878661 [SYS] Starting Channels DVR v2021.04.22.1948 (linux-arm64 pid:307) in /mnt/data/channels-dvr/data
2021/04/27 16:33:00.189462 [SYS] Started HTTP Server
2021/04/27 16:33:00.230256 [SYS] Waiting on dependencies
2021/04/27 16:33:04.411958 [SYS] Waiting on dependencies
2021/04/27 19:08:25.615591 [SYS] Done waiting on dependencies

I'm not sure why it would "start" the DVR server at 16:30. The time stamp 19:08 is when restarted the Pi.

I submitted the logs listed below.


1 Like

Could it be overheating when running comskip ?

Hmmm... I don't know. I could check the next time it detects, but it must be fairly rare/intermittent since it has happened once Friday night and once today (Tuesday). I'm a little skeptical because it had never happened until I updated to the pre-release, but maybe that's just coincidence.

Edit: It does look like commercial detection didn't complete, so maybe?

See this thread - Nvidia Shield and Pi's

Don't know if the timestamps are off because it just rebooted and its internal clock isn't accurate until it syncs with an Internet (NTP) time server?
2021/04/27 16:33:04.411958 [SYS] Waiting on dependencies

I wondered about that too, but I think they are probably accurate just because the movie finished recording in line with the time stamp, and 19:00 is when I rebooted, and it definitely failed to record things in between during the missing 2.5 hours there.

Did you upgrade to OS 2021.0415.1533, or did it start after a DVR update?

I did both. I did the OS because I didn't realize it was separate from the DVR update and I was trying to get the fix for the scheduling of duplicate recordings. After the OS updated to 2021.0415.1533, I realized it wasn't the version number you had mentioned and I grabbed the DVR update (2021.4.22.1948)

So I just noticed it happening again, except this time it appears to have spontaneously restarted the DVR server several times consecutively - about 4 times in 10 minutes - and has never started working again properly on its own (I just get the spinning cursor in the settings tab via my browser, but I am able to get to the logs, although it is slow).

This loop seemed to continue until I again rebooted the Pi. And now it again appears to not be working....

Logs submitted be9b4e47-dc00-42ce-9971-95f2b3966e51

Edit: yeah it’s not even working on reboot now.

2021/04/27 22:17:46.592002 [DVR] Commercial detection for Philly D.A. S01E02 2021-04-27-2100.mpg finished with 6 markers in 17m45.595274549s.
2021/04/27 22:51:20.587032 [SYS] Starting Channels DVR v2021.04.22.1948 (linux-arm64 pid:2760) in /mnt/data/channels-dvr/data
2021/04/27 22:51:20.938468 [SYS] Started HTTP Server
2021/04/27 22:51:21.745546 [HDR] Found 0 devices
2021/04/27 22:51:24.757735 [DVR] Recording engine started in /media/DVR
2021/04/27 22:51:24.902150 [DVR] Skipping job 1619640000-33 Good Witch
2021/04/27 22:51:24.902272 [DVR] Waiting 16h8m35.097751267s until next job 1619647200-15 The Love Boat
2021/04/27 22:51:24.925913 [SYS] Bonjour service running for dvr-server.local. []
2021/04/27 22:51:36.267103 [IDX] Pruned 220 expired airings from X-LOCAST in 227.428573ms.
2021/04/27 22:51:36.750466 [IDX] Pruned 463 expired airings from X-TVE in 483.064262ms.
2021/04/27 22:51:53.875153 [SYS] Created database snapshot: backup-20210427.225153
2021/04/27 22:51:53.875639 [SYS] Removing old backup backup-20210402.051029
2021/04/27 22:53:05.286951 [SYS] Starting Channels DVR v2021.04.22.1948 (linux-arm64 pid:2808) in /mnt/data/channels-dvr/data
2021/04/27 22:53:05.573094 [SYS] Started HTTP Server
2021/04/27 22:53:06.189320 [HDR] Found 0 devices
2021/04/27 22:53:10.020947 [DVR] Recording engine started in /media/DVR
2021/04/27 22:53:10.276605 [DVR] Skipping job 1619640000-33 Good Witch
2021/04/27 22:53:10.276735 [DVR] Waiting 16h6m49.723286067s until next job 1619647200-15 The Love Boat
2021/04/27 22:53:10.286835 [SYS] Bonjour service running for dvr-server.local. []
2021/04/27 22:53:20.960872 [IDX] Pruned 0 expired airings from X-LOCAST in 3.142788ms.
2021/04/27 22:53:20.963683 [IDX] Pruned 0 expired airings from X-TVE in 2.613204ms.
2021/04/27 22:53:26.213408 [SYS] Created database snapshot: backup-20210427.225325
2021/04/27 22:53:26.213904 [SYS] Removing old backup backup-20210402.105324
2021/04/27 22:54:55.003374 [SYS] Starting Channels DVR v2021.04.22.1948 (linux-arm64 pid:2867) in /mnt/data/channels-dvr/data
2021/04/27 22:54:55.221948 [SYS] Started HTTP Server
2021/04/27 22:54:55.921568 [HDR] Found 0 devices
2021/04/27 22:54:59.216935 [DVR] Recording engine started in /media/DVR
2021/04/27 22:54:59.394451 [DVR] Skipping job 1619640000-33 Good Witch
2021/04/27 22:54:59.394567 [DVR] Waiting 16h5m0.605443946s until next job 1619647200-15 The Love Boat
2021/04/27 22:54:59.424488 [SYS] Bonjour service running for dvr-server.local. []
2021/04/27 22:55:10.141306 [IDX] Pruned 0 expired airings from X-LOCAST in 7.395466ms.
2021/04/27 22:55:10.143748 [IDX] Pruned 0 expired airings from X-TVE in 2.281461ms.
2021/04/27 22:55:14.862963 [SYS] Created database snapshot: backup-20210427.225514
2021/04/27 22:55:14.863705 [SYS] Removing old backup backup-20210403.103735
2021/04/27 22:59:03.535557 [SYS] Starting Channels DVR v2021.04.22.1948 (linux-arm64 pid:2924) in /mnt/data/channels-dvr/data
2021/04/27 22:59:03.798780 [SYS] Started HTTP Server
2021/04/27 22:59:04.451267 [HDR] Found 0 devices
2021/04/27 22:59:08.968813 [DVR] Recording engine started in /media/DVR
2021/04/27 22:59:09.100987 [DVR] Skipping job 1619640000-33 Good Witch
2021/04/27 22:59:09.101089 [DVR] Waiting 16h0m50.898925027s until next job 1619647200-15 The Love Boat
2021/04/27 22:59:09.159499 [SYS] Bonjour service running for dvr-server.local. []
2021/04/27 22:59:19.995477 [IDX] Pruned 1 expired airings from X-LOCAST in 55.46477ms.
2021/04/27 22:59:19.997441 [IDX] Pruned 0 expired airings from X-TVE in 1.80083ms.

New Edit this AM: Tried to restart the Pi this morning and I can’t get the DVR to work at all. If I browse to the DVR with my browser, I get the menu bar across the top, but below that is the spinning icon and nothing happens. Something seems to have gone pretty wrong. Any suggestions for how to proceed?

I have 2 pi dvrs that are overlclocked and in cases that have a small fan.
Not having issues with Channels DVR image. (so far)
Server OS: 2021.0415.1533
DVR ver: 2021.04.28.0029

Are your pi's in a casing that gets good airflow/cooling?
Do you have the heatsinks applied to all the chips on the board, including the usb chip?

What power adapter are you using?
Cheapo no name ones are known to have issues and often not provide enough power.
Suggest using only the Official Pi USB C adapter or the CannaKit ones.

I’m using the recommended case and applied the heat sink as directed. I had no problems with the DVR at all - was up and running and recording a bunch for well over a month. Just started after I updated OS and DVR. I have the Canakit power supply.

I edited my above post to note that I left the Pi off all night and restarted this morning, but DVR still hangs up and won’t completely reboot. It doesn’t seem to be related to heat and it’s not an issue of power supply cutting out.

At this point, what was an intermittent issue is persistent.

Edit: After further exploration, I can still see logs and library, albeit slowly. But the settings page will never load. Just spinning.

After each restart - spontaneous or intentional - the log shows the last thing that happens is “removing old backup” and nothing else happens unless and until the Pi or DVR restarts again.

What drive and enclosure ?

The 5 TB elements portable (larger version of the recommended drive). And I put it on a powered hub to be safe. Everything worked perfectly for quite a while.

Edit: if you were asking about Pi enclosure, it’s the recommended FLIRC with the heat sink applied as directed.


From your diagnostics I see you're running into a lockup in the exfat driver. It seems to be related to the latest performance patch which I guess is still buggy. That lines up with your experience of the problem starting after the latest upgrade.

Please try updating to the new OS v2021.0428.1641

Is there a way to do that if I can’t get the settings page to load?

Try this from another computer:

curl -XPUT http://x.x.x.x:8089/distro/updater/check/prerelease

If that doesn't work, you might need to setup SSH and then you can run:

distro-upgrade 2021.0428.1701

Ugh. Tried to upgrade OS, and not the pi's not coming up at all. Not responsive for ssh nor the 8089 interface. Tried a couple of hard restarts too, no luck.

interesting - of course it came up on the 4th try, but the GUI is still prompting for the upgrade
Trying ssh upgrade now...

Thanks very much. It appears to be up and running again.


When three reboots fail the upgrade is aborted and the old version is booted instead.

But that's strange because I didn't change anything that would cause it not to boot at all. I upgraded my Pi here without issue..

Try 2021.0428.1701 instead, I made a change in there to fix an issue I saw in your previous diagnostics where the device would boot up in emergency mode because fsck failed.

Up and running without issue on 1701 via ssh.

1 Like