Edl file location


#21

I’ll try again…tested MrMC with .txt but not .edl…didn’t work (was also using DLNA).

We have used MrMC (on DLNA from Emby). I’ll try with direct and the .edl. If this works, it will be a perfect solution.

Edit: Note: previously, only tried on iOS, not tvOS. Thanks for the suggestion…as I’ve learned to trust your previous recommendations I’m very hopeful.


#22

I wouldn’t recommend ever using DLNA again (it also dissolved In Jan 2017). MrMC has native Emby/Plex support, but edl’s won’t work mapped that way. You’ll need to directly map with SMB or NFS for them to be used.


#23

Well, I was sure that you were the original poster suggesting to use Plex DLNA as a basis for MrMC playback (used for metadata), which I then applied to Emby…as Plex sucks. Guess I am losing my mind…expected for those of us 70+, is my only excuse.

Anyway, as usual, I can’t get a hold of even one ATV4 in the household to test…unless I want to go outside in the cold at midnight…NOT.

Tomorrow is another day, looking forward to testing direct MrMC playback with the edls. At least, the NFOs created by Emby serve fantastically for the Kodi metadata…hopefully, also MrMC with direct. :smiley:


#24

MrMC direct works great in both iOS and tvOS…utilizing the Emby created NFOs…so local info. A few aren’t making an NFO match but the edl is spot on. At times MrMC is a pita, but comskip is working. Awesome.

Thank you again!


#25

Anytime! I just try to suggest things that work :wink: (and why I recommend Channels to everyone)


#26

Update to the edl hack

My husband is finally using MrMC to watch our Channels recordings, due to the addition of comfree playback on MrMC (offered by edl addition to Channel’s recordings).

Ironically, the first one (he is now watching) was recorded from TCM (already commercial free). We’ll see if his next choice has comms on the recording so he can really test the edl file addition on the original Channels recording. :smiley:

Edit: He just started watching a recording with comms. His evaluation: It worked perfectly. :joy:


#27

As per above, I’ve got MrMC working using smb…also found that with so many files in the Channels Movies folder that if I setup a playlist (with all Movie files) and as a favorite, there is an immediate load of all files.

Previously, just using the smb path it took 30-60sec to load the files.

Thanks again for guidance and great advice.


#28

I just wanted to throw out my appreciation for this thread! As a new user to Channels I am still learning but the comskip ability is really awesome!

I just set everything up last night and tried out MrMC today with a couple of recordings and I am really impressed! I was already impressed with the ability to double tap my remote in the Channels App (using both on Shield TV) but having the player just auto skip the commercial is awesome!

I wish I had starting using this months ago! (although, it was the official port to Android TV that made me look at this app again).

Thanks again!


#29

I had my first chance tonight to watch several back-to-back recordings that were recorded using the edl function. I watched all of these via MrMC on the Shield TV device. Wow! Even with rare occasion comskip doesn’t push fully to the end of the commercial break it’s an easy skip or two to get through it. Thanks so much for this!

Now for a question - I just started testing the DVR on the Shield and noticed it doesn’t save the edl file like on the Windows 10 version. I assume this is because the Shield DVR version is older. However, I wanted to double check that there isn’t still something I could do to make this happen. Any ideas? It is still workable for me to just use the Channels App if I end up going with the Shield as the DVR but wanted to check all my possible options.


#30

You need to enable the edl option with the command in this thread


#31

Thanks. How would one do this on Android?


#32

Replace the IP in the curl command with the IP of the SHIELD.

SHIELD_IP=xxx.xxx.xxx.xxx
curl -XPUT http://${SHIELD_IP}:8089/dvr/hacks/edl


#33

Ah! Thanks! I also didn’t realize I could run this from my terminal on the Windows 10 machine! I thought I had to run it from within the Shield somehow.

Thanks again!


#34

How can I disable this hack from the server so it does not save the edl files to the same folder with the show anymore?

Thanks.


#35

curl -XDELETE http://x.x.x.x/dvr/hacks/edl


#36

Thank you!


#37

I am looking at this forum post trying to understand how this works. I was running mcebuddy with comskip on my PC and using the HDhomerun pvr to record programs and remove commercials. I started using Channels last month and have the Channels DVR running on my Synology server. I disabled my mcebuddy on my Windows 10 PC so I could use the commercial skipping ability on the Channels but that removed the ability to skip commercials on my Kodi devices in my house. Discovered though sometime after a reboot the mcebuddy service started back up and started removing commercials again which screwed up the Channels recorded programs since the commercials were deleted. So today discovering about EDL files from comskip, wasn’t at all knowledgable about what an EDL file before today, so the Channels recorded videos could be go through the mcebuddy with comskip and create the EDL file for Kodi but discovered that still didn’t work with Channels

So TL;DR: I would like to setup the Channels DVR to create the comskip EDL files it uses so Kodi can use them also with them in that directory and not remove them, but reading through this post I am confused on how to make this work.

I see on this post:

With the latest pre-release (shift + check for updates), you can enable the edl hack:

curl -XPUT http://127.0.0.1:8089/dvr/hacks/edl9

I am not quite sure how to do this on my Synology NAS to implement this hack so the EDL file will be saved in the directory with the video file. If anyone could be of assistance on steps to do this from my Windows PC if would be appreciated. Thank you.


#38

If your running windows10, do that same command, but replace the IP with the IP of the DVR. I believe Win10 has a curl alias


#39

On Windows the curl alias doesn’t handle many options, so use:

Invoke-WebRequest -Method PUT http://127.0.0.1:8089/dvr/hacks/edl


#40

Well I am not sure if this worked or not, I tried both, the address is my Synology IP:

C:\WINDOWS\system32>curl -XPUT http://192.168.1.75:8089/dvr/hacks/edl9
true

C:\WINDOWS\system32>Invoke-WebRequest -Method PUT http://192.168.1.75:8089/dvr/hacks/edl
‘Invoke-WebRequest’ is not recognized as an internal or external command,
operable program or batch file.

The top one took, how do I determine that it was a success past the ‘true’?