Fast Forward not working anymore

Fast forwarding is not working at all for me as of this morning. I have no problems fast forwarding on other AppleTV apps and I can see that the AppleTV is responding to the remotes fast forward area of the remote so that rules out the remote as the issue. Rewind still works without issue. I have tried in both Channels DVR app and Channels Plus app and both exhibit the same issue. I have also tried rebooting the AppleTV itself and no change. Help!

TVOS v14.0.1
Channels Plus v4.1.2

And out of the blue, fast forwarding is working again. I'm stumped...

There was a bug with forward seek while watching recordings that were currently recording. It's been resolved with version 4.1.3 which just got approved and is up on the store.

Thanks @maddox as that was my exact situation. I had 2 recordings going at the time and started one of those recordings from the beginning and hit the bug at the first commercial break while trying to FF. When it had started working later on, the 2 recordings were both finished.

Thanks for the quick fix!

NP!

All the updates are approved and up there now.

1 Like

Still having this issue with latest version available in AppleTV App Store (just checked App Store, said update so I did, v4.2.0). If watching a show while it's recording, but not watching live to allow me to skip commercials, once the live show ends, I can't FF anymore. Doesn't matter if I exit show and resume it.

EDIT - about 10 minutes watching later it will FF again. Checking the DVR Settings, I see it is now "Processing" and detecting commercials. Maybe that's what freed it up?

Great feedback, thanks for the detailed scenario. I’ll check it out.

1 Like

Having the same issue too. DVR is scanning another show for commercials, so it hasn’t started to scan the show I’m watching. No click FF or click and hold FF.

Same issue here, on 4.2.0, same scenario.

In a somewhat related issue, even after the commercials are marked, I am unable to fast-forward past the last 30 seconds of the recording to end it. I watch a show that has several minutes of commercials at the end of the recording and I can fast forward through most of it, 30 seconds a click, but it gets stuck at the last 30 seconds that must be played through. Very annoying! Yes, I could just stop the playback, but I want the episode marked as completely watched. Ideally, I would want to have the Skip button available and have it skip over the last block of commercials, to the end of the recording.

It does this in the tvOS Channels DVR app version 4.2.0 and the current Channels Beta app version 10.19.2047

Theses are all known and understood issues. Thanks guys! We’ll get a beta out with a fix soon.

FF during recording was broken. You fixed it. (Thanks!) Then you released a new stable release and it's broken again.

It is terrifically annoying to be watching something while recording and not be able to FF past either commercials or, as in the case of the pap that passes for "news," these days, the more repetitive, nonsensical garbage.

Please fix ASAP. Thanks!

Another data point on this issue. Running TvOS 4.2.0 client on AppleTV 4K and server
2020.10.16.2213 on a Synology box. I recorded two shows in the same time slot (PBS newshour at 6-7pm and NBC nightly news at 6:30-7). Both via HDHomeRun Prime. Both H.264 1280x720 59.940 fps. I could immediately fast forward just fine through the nightly news recording. I could not fast forward at all through the PBS newshour recording. Then 22 minutes later I could fast forward through both just fine. From the logs It appears that during the time the nightly news was doing commercial detection (the 22 minutes), fast forwarding was locked out on the other show (actually 22 minutes seems very long for a 30 minute show on an intel quad core synology box) After the nightly news commercial detection finished, fast-forwarding worked again on the PBS newshour. So the problem appears to be on the server and not on the client.