FBN Live issue

I have been having an issue watching FBN live on the ATV for the week I have been using Channels DVR. it randomly freezes about 5secs-2 minutes into the stream, then the purple buffer continues to increase but the playing has stopped from the server. It only happens on this TVE channel and plays just fine on the server(Windows 10). It also happens virtually everytime with the exception that it played fine a couple times after a Channels DVR restart. I have updated ATV OS and app to the latest versions and it occurred with all, and same with the DVR server(used the last 5 updates) and all the same results. I believe it happens on the iphone IOS as well but have used this less so it may be a server issue and not a client issue.

UPDATE: It definately does have the same error when using the server for playback, just less often or it plays longer.

Here is the dvr server log and the error is always the same when it stops playing(but no error when viewing on the server), first trying to play on ATV, then normal play on server, then trying again on ATV:

2019/10/31 07:17:09 [ERR] Error during stream TVE-Cox ch6074 FBN: Failed to download file: https://foxvdms.akamaized.net/ause/slices/8a6/5b6fd7c6528d417e8bdad7f79754bb9e/8a6f2ea9144c4bb9b997ad74325b11d2/H000000C2.ts?pbs=7fdf347779924453994fc7624c010688&_jt=l&chid=0889265100704d178922db41fa6b6b91&si=0: 503 Service Unavailable
2019/10/31 07:17:09 [TNR] Closed connection to TVE-Cox for ch6074 FBN
2019/10/31 07:22:40 [TNR] Opened connection to TVE-Cox for ch6074 FBN
2019/10/31 07:22:42 [HLS] Probed live stream in 1.189781s: h264 1280x720 progressive 5071238bps
2019/10/31 07:22:42 [HLS] Starting transcoder for channel 6074 from (encoder=remux, resolution=, deinterlacer=, bitrate=10000)
[aac @ 00000000025de540] env_facs_q 253 is invalid
2019/10/31 07:27:56 [HLS] Stopping transcoder session ch6074-dANY-ip127.0.0.1 @ 5m18.677334s
2019/10/31 07:27:56 [TNR] Closed connection to TVE-Cox for ch6074 FBN
2019/10/31 07:29:13 [TNR] Opened connection to TVE-Cox for ch6074 FBN
2019/10/31 07:29:46 [ERR] Error during stream TVE-Cox ch6074 FBN: Failed to download file: https://foxvdms.akamaized.net/ausw/slices/27f/4f59ea65df184a2580ad8fc80d3eaa32/27fb477eac2c4b2e928af979db3f090f/H00000007.ts?pbs=748dc332569344e09018d8cc956ead77&_jt=l&chid=0889265100704d178922db41fa6b6b91&oid=5b6fd7c6528d417e8bdad7f79754bb9e&si=2: 503 Service Unavailable
2019/10/31 07:29:46 [TNR] Closed connection to TVE-Cox for ch6074 FBN

See this topic. Issues with FBN and FNC

Thanks. I reviewed this thread. Maybe a similar issue but Mine has some different behaviors:
FNC always works flawless.
It does not seem to be associated with commercials.

Not sure which of your behaviors are different. FNC also worked for me where FBN failed?
Did you see my posts in the thread where I streamed and recorded both?

It was a SWAG guessing commercials had anything to do with it and may have been a Red Herring.

It appears that either their CDN has isuues, or Channels DVR has isuues parsing the Master/Slave playlists given the error codes that occurred and are still occurring.

503 Service Unavailable - The server cannot handle the request (because it is overloaded or down for maintenance). Generally, this is a temporary state. i.e. server is overwhelmed and can't keep up with requests

Was just trying to help by pointing out it's not just you having these issues.