Fox TVE auth problems

I'll give that a try and see if it resolves my local fox issue.
Nope, still can't get local fox added. Same as before, no login form found and same weird screenshot

2022/10/25 16:24:44.713543 [TVE] action=version product=Chrome/97.0.4692.56 jsVersion=9.7.106.18 protocol=1.3 [email protected]
2022/10/25 16:24:44.735403 [TVE] action=navigate url=https://www.foxsports.com/live
2022/10/25 16:24:44.740885 [TVE] action=request type=Document method=GET url=https://www.foxsports.com/live
2022/10/25 16:24:44.740939 [TVE] action=auth_domain domain=www.foxsports.com
2022/10/25 16:24:44.740958 [TVE] action=foxsportsauth step=start
2022/10/25 16:24:45.157234 [TVE] action=wait_for_page
2022/10/25 16:25:15.157518 [TVE] action=wait_for_page err=timeout
2022/10/25 16:25:15.169564 [TVE] action=click_interstitial
2022/10/25 16:25:16.471438 [TVE] action=tvejs msg="foxSportsSelect: path=/live"
2022/10/25 16:25:16.514337 [TVE] action=wait_for_interstitial
2022/10/25 16:25:20.043046 [TVE] action=exception err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught", LineNumber:131, ColumnNumber:83, ScriptID:"67", URL:"tveinterhelper.js", StackTrace:(*runtime.StackTrace)(0xc001d26940), Exception:(*runtime.RemoteObject)(0xc001d04990), ExecutionContextID:2, ExceptionMetaData:easyjson.RawMessage(nil)} value=TypeError: Cannot read properties of null (reading 'click')
    at tveinterhelper.js:132:84
2022/10/25 16:25:34.230879 [TVE] action=exception err=&runtime.ExceptionDetails{ExceptionID:2, Text:"Uncaught (in promise)", LineNumber:0, ColumnNumber:3259, ScriptID:"23", URL:"https://cdn.opecloud.com/ope-fox.js", StackTrace:(*runtime.StackTrace)(0xc000d11080), Exception:(*runtime.RemoteObject)(0xc000860120), ExecutionContextID:2, ExceptionMetaData:easyjson.RawMessage(nil)} value=Error: failed to locate __uspapiLocator iframe
    at new n (https://cdn.opecloud.com/ope-fox.js:1:3260)
    at https://cdn.opecloud.com/ope-fox.js:1:33848
2022/10/25 16:25:34.233048 [TVE] action=exception err=&runtime.ExceptionDetails{ExceptionID:3, Text:"Uncaught (in promise)", LineNumber:0, ColumnNumber:3259, ScriptID:"23", URL:"https://cdn.opecloud.com/ope-fox.js", StackTrace:(*runtime.StackTrace)(0xc000d111c0), Exception:(*runtime.RemoteObject)(0xc0008601b0), ExecutionContextID:2, ExceptionMetaData:easyjson.RawMessage(nil)} value=Error: failed to locate __uspapiLocator iframe
    at new n (https://cdn.opecloud.com/ope-fox.js:1:3260)
    at https://cdn.opecloud.com/ope-fox.js:1:33848
2022/10/25 16:25:36.830378 [TVE] action=error_response type=Media error=net::ERR_ABORTED url=https://vidstatb.taboola.com/vid/blackScreen60.mp4 
2022/10/25 16:25:46.514609 [TVE] action=wait_for_interstitial err=timeout
2022/10/25 16:25:47.886552 [TVE] action=fill_form u=USERNAME
2022/10/25 16:25:50.584415 [TVE] action=screenshot
2022/10/25 16:25:54.449238 [TVE] action=error_response type=Script error=net::ERR_ABORTED url=https://image6.pubmatic.com/AdServer/PugMaster 
2022/10/25 16:25:59.791105 [TVE] action=screenshot size=286081
2022/10/25 16:25:59.843212 [TVE] action=capture_html
2022/10/25 16:26:07.370030 [TVE] action=capture_html size=1869732
2022/10/25 16:26:07.420961 [TVE] action=script_error err=&runtime.ExceptionDetails{ExceptionID:4, Text:"Uncaught", LineNumber:9, ColumnNumber:5, ScriptID:"89", URL:"", StackTrace:(*runtime.StackTrace)(0xc0002fb780), Exception:(*runtime.RemoteObject)(0xc0013b5440), ExecutionContextID:0, ExceptionMetaData:easyjson.RawMessage(nil)} exp=&runtime.RemoteObject{Type:"string", Subtype:"", ClassName:"", Value:easyjson.RawMessage{0x22, 0x6e, 0x6f, 0x20, 0x6c, 0x6f, 0x67, 0x69, 0x6e, 0x20, 0x66, 0x6f, 0x72, 0x6d, 0x20, 0x66, 0x6f, 0x75, 0x6e, 0x64, 0x22}, UnserializableValue:"", Description:"", WebDriverValue:(*runtime.WebDriverValue)(nil), ObjectID:"", Preview:(*runtime.ObjectPreview)(nil), CustomPreview:(*runtime.CustomPreview)(nil)} exp_value="no login form found"
2022/10/25 16:26:07.746432 [TVE] action=fox_station err="no login form found"

Logs have been submitted as 31ff29c8-c623-4fe8-bd0c-1991cfa21410

Try new build.

Thanks, but still getting no login form found
screenshot

Logs have been submitted as faa45692-1936-4783-b741-018502240645

No success for me on the latest build.

I'll try again during Primetime after 8pm.
Right now I'm getting this in a browser after selecting my Provider (and not having to login)

Please try new build

I just noticed the error screenshots I get when trying to add local fox is from foxsports, not fox.
If I go to the foxsports url in the log and signin with my provider, it looks like my error screenshot.

When I go to the fox homepage, I have to select TV Provider Sign In on the upper right first.
If I select Live first it starts a free 60 minute preview.

When I go to the foxsports homepage, I have to select Sign In > TV Provider Sign In on the left first.
If I select Live first it starts a free 60 minute preview.

Same result (no login form found), different screenshot now


Logs have been submitted as 5cd88ed2-9669-4917-a52d-4406235c5041

Tried again while streaming from Fox using my Brave browser.
Same error.
Only thing it's really doing is reloading the complete guide everytime.
Time to give up tonight.

Since I turned on auto auth at Xfinity yesterday, I decided to give it another try but it still fails with no login form found
Updated to prerelease v2022.10.26.2053
Update Password to clear chromedata
Removed Xfinity TVE source
Changed my user password at Xfinity
Added Xfinity TVE using the new password
It started auth for Fox Local at 2022/10/27 15:26:51 and errored out at 2022/10/27 15:28:46
Every other channel authorized fine, including ABC, CBS and NBC locals

Logs have been submitted as 1114d60f-8aa0-4f30-9451-121dc4056354

I just setup Channels newly on a new server box yesterday.

I came here to report I am not even getting the Fox local channel option when it scans my TVE channels. I did double check that local Fox TVE is still offered and I can access it fine via their website with my Spectrum login credentials.

I am getting all the FX TVE channels and FS1 and FS2 just fine. I don't get any errors in the logs that I can see, it just doesn't even scan.

My apologizes if you already checked this, but you would be surprised how many times it is over looked. I forgot to check this setting this last Spring when I setup a new server.

Have you checked the Local Networks via TV Everywhere under experimental. Sometimes toggling it back and forth will do the trick.

1 Like

That is a fair thing to point out.

I do have that box checked. I am getting the NBC, ABC and CBS TVE channels though.

It is only FOX. When I try to do a new scan now it only tries for like a second before the window closes and show 0 new channels. No other errors pop up in the log.

Did you try to uncheck it. Then re-check it. Also you need to be connected via https:// for it to work correctly.

I tried all that. Running the troubleshooter also shows all green for each point.

I am just going to skip it since I do have FOX via antenna it's not worth it to keep messing with it right now.

Good to know it's not just me.
I run two Channels DVR servers with Xfinity-TVE sources.
One gets Fox local, the other doesn't.
Both get all the other channels including ABC, CBS and NBC.
Both Synology NAS servers run the Channels DVR Synology package.
They each use a different Xfinity Viewer only account.

Don't know if this is any help to the devs to maybe compare.
On my Channels DVR server that shows the local Fox channel, I started viewing live from the grid guide using the web UI player.
It had to reauth the channel, but worked and I watched it starting at 2022/10/29 10:37:17
Logs have been submitted as 419c6340-f264-42c7-9f70-22733da2f4c2

Log
2022/10/29 10:36:42.233838 [TVE] action=auth mvpd=Comcast_SSO requestor=fbc-fox
2022/10/29 10:36:42.449644 [TVE] action=version product=Chrome/97.0.4692.56 jsVersion=9.7.106.18 protocol=1.3 [email protected]
2022/10/29 10:36:42.451118 [TVE] action=navigate url=https://sp.auth.adobe.com/adobe-services/authenticate/saml?noflash=true&mso_id=Comcast_SSO&requestor_id=fbc-fox&no_iframe=true&domain_name=adobe.com&redirect_url=https%3A%2F%2Fsp.auth.adobe.com%2Fadobe-services%2FcompletePassiveAuthentication
2022/10/29 10:36:42.454363 [TVE] action=request type=Document method=GET url=https://sp.auth.adobe.com/adobe-services/authenticate/saml
2022/10/29 10:36:42.698402 [TVE] action=request type=Document method=GET url=https://sp.auth.adobe.com/adobe-services/completePassiveAuthentication
2022/10/29 10:36:42.698444 [TVE] action=authed
2022/10/29 10:36:42.754492 [TVE] action=wait_for_page
2022/10/29 10:36:42.754538 [TVE] action=wait_for_page done=true reason=auth_finished
2022/10/29 10:36:42.761225 [TVE] action=cookies num_domains=1 num_cookies=4
2022/10/29 10:36:42.763285 [TVE] action=error_response type=Document error=net::ERR_ABORTED url=https://sp.auth.adobe.com/adobe-services/completePassiveAuthentication 
2022/10/29 10:36:43.512860 [TVE] action=version product=Chrome/97.0.4692.56 jsVersion=9.7.106.18 protocol=1.3 [email protected]
2022/10/29 10:36:43.562681 [TVE] action=navigate url=https://www.foxsports.com/live
2022/10/29 10:36:43.565586 [TVE] action=request type=Document method=GET url=https://www.foxsports.com/live
2022/10/29 10:36:43.565619 [TVE] action=auth_domain domain=www.foxsports.com
2022/10/29 10:36:43.565627 [TVE] action=foxsportsauth step=start
2022/10/29 10:36:44.024460 [TVE] action=wait_for_page
2022/10/29 10:36:57.456537 [TVE] action=page_ready
2022/10/29 10:36:57.456593 [TVE] action=wait_for_page done=true reason=page_ready
2022/10/29 10:36:57.466796 [TVE] action=click_interstitial
2022/10/29 10:36:58.043955 [HLS] Couldn't generate stream playlist for ch6002-dANY-ip192.168.1.8: Timeout waiting for session to start after 8s
2022/10/29 10:36:58.044053 [HLS] Stopping transcoder session ch6002-dANY-ip192.168.1.8
2022/10/29 10:36:58.204451 [TVE] action=tvejs msg="foxSportsSelect: path=/live"
2022/10/29 10:36:58.229409 [TVE] action=request type=Document method=GET url=https://www.foxsports.com/provider/register
2022/10/29 10:36:58.229452 [TVE] action=foxsportsauth step=register
2022/10/29 10:36:58.233091 [TVE] action=wait_for_interstitial timeout=12s
2022/10/29 10:36:58.549636 [TVE] action=exception err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught (in promise)", LineNumber:0, ColumnNumber:0, ScriptID:"1", URL:"https://www.foxsports.com/live", StackTrace:(*runtime.StackTrace)(nil), Exception:(*runtime.RemoteObject)(0xc0002597a0), ExecutionContextID:2, ExceptionMetaData:easyjson.RawMessage(nil)} value=DOMException: Failed to load because no supported source was found.
2022/10/29 10:36:58.553915 [TVE] action=exception err=&runtime.ExceptionDetails{ExceptionID:2, Text:"Uncaught (in promise)", LineNumber:0, ColumnNumber:0, ScriptID:"1", URL:"https://www.foxsports.com/live", StackTrace:(*runtime.StackTrace)(nil), Exception:(*runtime.RemoteObject)(0xc001d37170), ExecutionContextID:2, ExceptionMetaData:easyjson.RawMessage(nil)} value=DOMException: Failed to load because no supported source was found.
2022/10/29 10:36:58.555059 [TVE] action=error_response type=Media error=net::ERR_ABORTED url=https://cdn.taboola.com/libtrc/static/video/v1661756231/liq0neimeru0d3y8mc77.mp4 
2022/10/29 10:36:58.816754 [TVE] action=error_response type=Image error=net::ERR_ABORTED url=https://id5-sync.com/c/464/429/6/2.gif 
2022/10/29 10:36:58.816829 [TVE] action=error_response type=Image error=net::ERR_ABORTED url=https://sync-t1.taboola.com/sg/bidswitch-network/1/rtb-h 
2022/10/29 10:36:58.835547 [TVE] action=error_response type=Fetch error=net::ERR_ABORTED url=https://rum.browser-intake-datadoghq.com/api/v2/rum 
2022/10/29 10:36:58.835603 [TVE] action=error_response type=XHR error=net::ERR_ABORTED url=https://pips.taboola.com/ 
2022/10/29 10:36:58.835632 [TVE] action=error_response type=Image error=net::ERR_ABORTED url=https://fox.tagger.opecloud.com/fox/v2/pixel.gif 
2022/10/29 10:36:58.835649 [TVE] action=error_response type=Script error=net::ERR_ABORTED url=https://cdn.segment.com/analytics-next/bundles/ajs-destination.bundle.69f445038fee7a77bb89.js 
2022/10/29 10:36:58.835666 [TVE] action=error_response type=Stylesheet error=net::ERR_ABORTED url=https://vidstat.taboola.com/vpaid/units/32_3_9/assets/css/cmOsUnit.css 
2022/10/29 10:36:58.835682 [TVE] action=error_response type=Script error=net::ERR_ABORTED url=https://vidstat.taboola.com/vpaid/units/32_3_9/infra/cmTagWIDGET_ITEM.js 
2022/10/29 10:36:58.835720 [TVE] action=error_response type=Script error=net::ERR_ABORTED url=https://www.foxsports.com/_foxsports/04f8339.js 
2022/10/29 10:37:06.761022 [TVE] action=page_ready
2022/10/29 10:37:06.761085 [TVE] action=foxsportsauth event=page_ready
2022/10/29 10:37:06.771282 [TVE] action=click_interstitial
2022/10/29 10:37:06.872679 [TVE] action=tvejs msg="foxSportsSelect: path=/provider/register"
2022/10/29 10:37:06.873250 [TVE] action=tvejs msg="foxSportsSelect: pick mvpd"
2022/10/29 10:37:06.928233 [TVE] action=wait_for_interstitial timeout=12s
2022/10/29 10:37:07.106403 [HLS] Couldn't generate stream playlist for ch6002-dANY-ip192.168.1.8: Timeout waiting for session to start after 8s
2022/10/29 10:37:07.106492 [HLS] Stopping transcoder session ch6002-dANY-ip192.168.1.8
2022/10/29 10:37:08.401684 [TVE] action=request type=Document method=GET url=https://api.auth.adobe.com/api/v1/authenticate
2022/10/29 10:37:08.808715 [TVE] action=request type=Document method=GET url=https://sp.auth.adobe.com/api/v1/authenticate
2022/10/29 10:37:09.196455 [TVE] action=request type=Document method=GET url=https://www.foxsports.com/provider/register
2022/10/29 10:37:09.196498 [TVE] action=foxsportsauth step=registered
2022/10/29 10:37:14.083423 [TVE] action=foxsportsauth step=done
2022/10/29 10:37:14.083462 [TVE] action=authed
2022/10/29 10:37:14.083477 [TVE] action=wait_for_interstitial done=true reason=auth_finished
2022/10/29 10:37:14.088531 [TVE] action=cookies num_domains=3 num_cookies=33
2022/10/29 10:37:16.782180 [TVE] stream timestamps: fox: start_at=2022-10-29T10:36:39-07:00 end_at=2022-10-29T10:37:07-07:00 live_delay=5.240174998s
2022/10/29 10:37:16.782267 [TNR] Opened connection to TVE-Comcast_SSO for ch6002 KTXL
2022/10/29 10:37:16.783081 [HLS] Starting live stream for channel 6002 from 192.168.1.8 (bitrate=7477)
2022/10/29 10:37:16.783886 [TNR] Closed connection to TVE-Comcast_SSO for ch6002 KTXL
2022/10/29 10:37:16.908346 [TVE] stream timestamps: fox: start_at=2022-10-29T10:36:43-07:00 end_at=2022-10-29T10:37:11-07:00 live_delay=1.362339435s
2022/10/29 10:37:16.908443 [TNR] Opened connection to TVE-Comcast_SSO for ch6002 KTXL
2022/10/29 10:37:16.909262 [HLS] Starting live stream for channel 6002 from 192.168.1.8 (bitrate=7477)
2022/10/29 10:37:16.909728 [TNR] Closed connection to TVE-Comcast_SSO for ch6002 KTXL
2022/10/29 10:37:17.039847 [TVE] stream timestamps: fox: start_at=2022-10-29T10:36:43-07:00 end_at=2022-10-29T10:37:11-07:00 live_delay=1.49384169s
2022/10/29 10:37:17.039938 [TNR] Opened connection to TVE-Comcast_SSO for ch6002 KTXL
2022/10/29 10:37:17.040721 [HLS] Starting live stream for channel 6002 from 192.168.1.8 (bitrate=7477)
2022/10/29 10:37:17.774797 [HLS] ffmpeg: ch6002-dANY-ip192.168.1.8-remux:  [hls @ 0x88f9f00] Timestamps are unset in a packet for stream 1. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
2022/10/29 10:37:17.885904 [HLS] Probed live stream in 844.867018ms: h264 1280x720 progressive 5346764bps
2022/10/29 10:37:42.013412 [HLS] Stopping transcoder session ch6002-dANY-ip192.168.1.8 (out: 27.944589s, finished: false)
2022/10/29 10:37:42.021463 [TNR] Closed connection to TVE-Comcast_SSO for ch6002 KTXL
2022/10/29 10:37:42.031483 [SNR] Buffer statistics for ch6002 KTXL: buf=0% drop=0%

I then went to my Channels DVR server that won't get local Fox and toggled the Exprimental Local Networks checkbox.
It still fails with no login form found.

Logs have been submitted as 7da8757b-672e-48e9-8302-6884b34d00e2

Just updated to prerelease 2022.11.09.1733 and got Local Fox to authorize this time.
Took about 1.5 minutes.
Not sure if it was the prerelease or Fox & Xfinity playing nice today.

For me FOX also not working on latest build, re-checking helped however after problem with geo-lock I get FOX (but it's unable to connect) but lost CBS weird.