Fox TVE auth problems

I lost my Fox channel again.
When I updated Channels DVR to the latest prerelease it automatically scanned my locals and removed NBC and FOX. I was able to rescan them and get NBC back but not FOX.

I'm not receiving FOX with my Service Electric Cable TV login. It should have it, as our local affiliate is FOX-owned (WTXF-TV) and I can access it on the Fox website. Running current pre-release.

Try this build:

Thanks. Worked on one of my two servers with Xfinity TVE, but not the other server.
It errored out with no login form found

Logs have been submitted as 877080fd-efb1-48ce-b0f7-021ce726cd63

If it helps to compare, here's diagnostics from the server it worked on

1 Like

The two servers are using different Xfinity usernames for TVE. I just logged into Xfinity using the one that failed and there are no security questions or popups when logging in.

Same chrome version on both?

1 Like

Yes, should appear in the diagnostic logs.
[TVE] action=version product=Chrome/97.0.4692.56

They're both running the Synology package.

1 Like

Tried again today to get Fox local back and ended up also losing FS1 and FS2.
Updated password to clear chromedata
Removed TVE source
Added TVE source back
Multiple rescan attempts

Logs have been submitted as 15991262-b09d-4219-a337-f7ed1aff06d7

Appears that if I can get headless-chrome updated to v109 on this Synology Package installation it would work. Only problem is it won't update chrome past v97.
I spun up a new updated TVE Docker Container that uses chrome v109 and it was able to authenticate local Fox, FS1 and FS2.

I lost FOX as well on FIOS. Any updates?

@mstras Server update resolved the original complaint from this thread. Make sure your server has updated and then I would suggest toggling the “experimental local tve” check box on the web ui off and then back on during prime time shows or national broadcasts.

I am not sure if this is still causing other folks problems, but I have this issue for Fox in the LA area. I have youtube tv, and toggling local channels off and then on works for abc, nbc, and cbs, and gives me the errors below for fox. I am running v 2023.01.23.1746 on an intel mac mini. I can log in via the same browser (chrome) in another tab, and successfully authenticate using my tv provider. Any thoughts?

2023/02/12 23:20:59.937896 [TVE] action=navigate url=
2023/02/12 23:20:59.969922 [TVE] action=request type=Document method=GET url=
2023/02/12 23:20:59.969946 [TVE] action=auth_domain
2023/02/12 23:20:59.969953 [TVE] action=foxsportsauth step=start
2023/02/12 23:21:04.468869 [TVE] action=exception err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught (in promise)", LineNumber:0, ColumnNumber:33636, ScriptID:"220", URL:"", StackTrace:(*runtime.StackTrace)(0xc001c78100), Exception:(*runtime.RemoteObject)(0xc001220480), ExecutionContextID:2, ExceptionMetaData:easyjson.RawMessage(nil)} value=Error: [object Object]
2023/02/12 23:21:04.468938 [TVE] action=exception err=&runtime.ExceptionDetails{ExceptionID:2, Text:"Uncaught (in promise)", LineNumber:0, ColumnNumber:33636, ScriptID:"220", URL:"", StackTrace:(*runtime.StackTrace)(0xc001c78240), Exception:(*runtime.RemoteObject)(0xc0012205a0), ExecutionContextID:2, ExceptionMetaData:easyjson.RawMessage(nil)} value=Error: [object Object]
2023/02/12 23:21:04.469270 [TVE] action=exception err=&runtime.ExceptionDetails{ExceptionID:3, Text:"Uncaught (in promise)", LineNumber:0, ColumnNumber:33636, ScriptID:"220", URL:"", StackTrace:(*runtime.StackTrace)(0xc001c78e00), Exception:(*runtime.RemoteObject)(0xc001220ea0), ExecutionContextID:2, ExceptionMetaData:easyjson.RawMessage(nil)} value=Error: [object Object]
2023/02/12 23:21:09.431437 [TVE] action=tvejs msg="foxSportsSelect: path=/live"
2023/02/12 23:21:09.444058 [TVE] action=request type=Document method=GET url=
2023/02/12 23:21:09.444084 [TVE] action=foxsportsauth step=register
2023/02/12 23:21:15.282113 [TVE] action=foxsportsauth event=page_ready
2023/02/12 23:21:15.371725 [TVE] action=tvejs msg="foxSportsSelect: path=/provider/register"
2023/02/12 23:21:15.371805 [TVE] action=tvejs msg="foxSportsSelect: pick mvpd"
2023/02/12 23:21:48.682772 [TVE] action=fox_station err=Cable provider authentication failed

I am in San Francisco area and cannot get FOX either. Access was mostly hit and miss with the Super Bowl likely changing the way the standard TVE works. Looks like all major events the networks kill off TVE access for that event and then restore it later. This has happened too many times for it to be a coincidence. You will have to use OTA to ensure access. Guess I will finally have to put that antenna up.

Lots of conversation in this thread, it appears, about the same issue. Seems fox broke everything for the Super Bowl. Updated to the 2023.02.13.0044 prerelease, and toggled local channels off and on to get fox back. I did not click the 4k feature (for now). Need to do more reading before enabling that.

Lost FOX(6002) after the Super Bowl. Will not authenticate with 4K off or on.

@mtnbkr60 this happened to me too and this morning I had to get it back by doing the following:

  1. uncheck the Local Networks via TV Everywhere option at the bottom of the server's settings page
  2. load your server in a secure tab/window of your browser: add "https://" at the beginning of the local URL
  3. check the Local Networks via TV Everywhere option
  4. accept the request from your browser to access your location
  5. wait until the local channels are added

nope, still wont authenticate

What version of the server are you running?


OK, you're on the latest pre-release, same as my server.

To be honest, I have never seen the message "fox content missing" so this is new to me.
Sorry, I don't know what else to suggest.

Unless somebody else reading this has had the exact same issue and can explain how they resolved it, you should get the attention of the developers.