Freezing issue Nvidia Shield

I'm having an issue where streams will just stop anywhere from 5-20 minutes into them. They don't appear to be buffering just stopping on a single frame. Backing out to the guide and selecting the channel again restarts the stream with no issues. I tested ESPN through channelsDVR and its native app. Freezing only occurred when using the channelsdvr app.

Any suggestions as to what would cause this?

Is there a piece of hardware that works best with channelsDVR? I'm within my return period and will gladly switch to apple TV if it performs better.

The Shield is great ... could be where you have the DVR running what device is your DVR on?

On a brand new mac mini. Storage is USB drive if that matters

Could be a Wi-Fi issue. Is the shield wired or on Wi-Fi.

Does the Log tab of the DVR web UI show any errors when the stream stops?

Please click the Submit Diagnostics button in the player settings tab of the app right after the freeze and post here when the logs are uploaded.

Shield is connected via wifi but I dismissed that when the native app wasn't experiencing the same issues.

I submitted earlier today. Not sure if that's too old now. I will submit as soon as it happens again then post here confirming . Thanks

Happened again. and I clicked submit

did it again and submitted again. i'm getting a few minutes tops before it does it.

Does the dvr log tab show any errors?

Can you record from that channel and watch the recording?

Also is the Mac on Wi-Fi or wired?

Mac is wired. I'll try and record tonight.

Here are the logs
2020/01/09 15:04:14 [HLS] Stopping inactive session ch6140-dANY-ip--1 @ 2h36m54.233944s
Last message repeated 4 times
2020/01/09 15:04:14 [TNR] Closed connection to TVE-Comcast_SSO for ch6140 ESPN1
[GIN] 2020/01/09 - 15:04:49 | 200 | 185.504µs | ::1 | GET /dvr
[GIN] 2020/01/09 - 15:04:49 | 200 | 260.557µs | ::1 | GET /dvr/programs
[GIN] 2020/01/09 - 15:04:49 | 200 | 203.531µs | ::1 | GET /dvr
[GIN] 2020/01/09 - 15:04:51 | 200 | 1.670592642s | ::1 | GET /log
[GIN] 2020/01/09 - 15:05:53 | 200 | 106.89µs | ::1 | GET /dvr
[GIN] 2020/01/09 - 15:05:53 | 200 | 41.025941ms | ::1 | GET /system
[GIN] 2020/01/09 - 15:05:53 | 200 | 1.781143ms | ::1 | GET /remote
[GIN] 2020/01/09 - 15:05:53 | 200 | 159.884µs | ::1 | GET /dvr/scanner/paths/movies
[GIN] 2020/01/09 - 15:05:53 | 200 | 1.628202ms | ::1 | GET /settings
[GIN] 2020/01/09 - 15:05:53 | 200 | 343.431µs | ::1 | GET /updater
[GIN] 2020/01/09 - 15:05:53 | 200 | 247.322µs | ::1 | GET /bonjour
[GIN] 2020/01/09 - 15:05:53 | 200 | 96.91µs | ::1 | GET /dvr
[GIN] 2020/01/09 - 15:05:53 | 200 | 2.212597ms | ::1 | GET /devices
[GIN] 2020/01/09 - 15:05:53 | 200 | 223.687µs | ::1 | GET /dvr/lineups
[GIN] 2020/01/09 - 15:05:53 | 200 | 188.432159ms | ::1 | GET /troubleshoot
[GIN] 2020/01/09 - 15:05:55 | 200 | 11.158501ms | ::1 | DELETE /debug/http
2020/01/09 15:09:47 [TNR] Opened connection to TVE-Comcast_SSO for ch6143 ESPNEWS [transcode=none]
[GIN] 2020/01/09 - 15:17:36 | 200 | 12m46.582346339s | ::1 | GET /dvr/events/subscribe
2020/01/09 15:30:25 [TNR] Closed connection to TVE-Comcast_SSO for ch6143 ESPNEWS
2020/01/09 15:33:32 [TNR] Opened connection to TVE-Comcast_SSO for ch6143 ESPNEWS [transcode=none]
2020/01/09 15:33:42 [TNR] Closed connection to TVE-Comcast_SSO for ch6143 ESPNEWS
2020/01/09 15:39:21 [TNR] Opened connection to TVE-Comcast_SSO for ch6143 ESPNEWS [transcode=none]
2020/01/09 15:39:32 [TNR] Closed connection to TVE-Comcast_SSO for ch6143 ESPNEWS
2020/01/09 15:40:22 [TNR] Opened connection to TVE-Comcast_SSO for ch6143 ESPNEWS [transcode=none]
2020/01/09 15:42:24 [TNR] Closed connection to TVE-Comcast_SSO for ch6143 ESPNEWS

The diagnostics from the shield show it is getting disconnected from your Mac due to some type of network issue. I would recommend hard wiring the shield if possible.

Ordered powerline adapter. Will give that a shot. Thank for the exceptional support!

In our experience power line is worse than Wi-Fi. Hard wiring with Ethernet is recommended, or if you have coax in your walls you can use Moca2 adapters.

I can do Moca. I'm actually an Actiontec reseller

My mother reports this happening a few times a day where the stream just freezes.
Changing channel and re-loading it restores it.
Not sure how long it is after, 40min to a couple hours, she can't remember.
She is disabled and watches tv all day, 12-16hrs a day constant.

Was thinking maybe the playback buffer gets full, but it should have plenty of space.
Device is a 2019 Shield (tube model) and has a new 64GB Samsung Pro Endurance micro sd card. The setup is from a OTA antenna via Connect Q, and TVE via Xfinity and Philo.

Edit: It happens on my Pro model occasionally too.

Problem solved! Bought an Apple TV.

2 Likes

The swipey-remote not made you want to launch it through the closest window yet?! :slight_smile:

Strange and definitely takes some getting used to but it's tolerable. Bottom line is the Apple TV worked when the shield didn't. For that I'll use the Flintstones bird remote.

Still the occasional buffering but night and day performance wise when compared to the shield.

Not sure of the issue is Android tv, the shield itself or the channels dvr Android TV app. The channels dvr app was by far the worst performing app on the shield.

1 Like

I have 2 Fire TV Cubes and a couple of Sticks and can't say I've seen any issues there... they've been fully accepted by the wife (after some initial moaning).

I reported this issue several months ago. Aman looked at my diagnostics, but had no insight. My Shield 2017 is hardwired to ethernet, and has 5G wireless as well. Both DVR Server and client run on the Shield, and freezing occurred both on HDHR Extend OTA channels and TVE channels. I had replaced by HDHR when at first this appeared to be a HDHR issue, but it still occurs, Like you, I tested the same TV channels on other apps (HDHR, KODI, Live Channels (Google) ) and none of them had any issue.

I have stopped using Channels DVR as a viewing client, because the freezing is intolerable. Will continie to follow this thread, because I paid for a year of the DVR server.

Peter