FX Channels (6080 - 6084) Random Jitter, Frame Skips & Pixelation

Update: Now seeing the same issue(s) with the FXNow livestream as well. I should've checked that as well. So it appears to be an FX livestream issue.

Lately I've noticed the issues (listed in the topic title) when tuning to any of the FX networks. The issue begins to appear after a minute or two. It persists for the entirety of viewing & only on FX networks. I (primarily) use my YTTV credentials for TVE access to these channels. I've also tried using my Frontier credentials as well. Same results for both across all clients - Apple TV 4k's (and sometimes an iMac desktop).

Here's what I've tried so far:
Updated Channels DVR
Rescanned all the FX channels (6080-6084)
Switched between YTTV and Frontier for TVE access to these channels.
Rebooted my server

That's about the extent of what I know to do. I'm wondering if this would be an issue on my end, if it's an FX TVE thing, or if it may be Channels thing. If it helps, here's my server info & most recent FX Channels log. Thanks in advance for any input.

NUC8i5BEHS Windows Microsoft Windows 11 Pro
10.0.22621.2283 Build 22621.2283 (kernel: 10.0.22621.2283 Build 22621.2283)
8 cores / Intel(R) Core(TM) i5-8260U CPU @ 1.60GHz 32gb RAM

Last viewing FX log:

2023/09/13 09:30:41.792190 [TVE] stream timestamps: fx: start_at=2023-09-13T09:29:40-05:00 end_at=2023-09-13T09:30:09-05:00 live_delay=28.0301909s
2023/09/13 09:30:41.792190 [TNR] Opened connection to TVE-YouTubeTV for ch6080 FX
2023/09/13 09:30:41.801421 [HLS] Starting live stream for channel 6080 from (bitrate=11893)
2023/09/13 09:30:42.712827 [HLS] Probed live stream in 911.3298ms: h264 1280x720 progressive 5236219bps
2023/09/13 09:32:21.727048 [HLS] Stopping transcoder session ch6080-dANY-ip192.168.1.142 (out=1m42.386511s finished=false first_seq=1 last_seq=51)
2023/09/13 09:32:21.759269 [TNR] Closed connection to TVE-YouTubeTV for ch6080 FX
2023/09/13 09:32:21.759338 [SNR] Buffer statistics for ch6080 FX: buf=0% drop=0%

Which credentials you use does not matter, they are only used to authenticate for the stream. The stream itself is the same regardless of which login you use.

Have you tried accessing the streams on the networks' websites? If the problem shows up there, that's a "them" issue, not a Channels issue.

1 Like

Just updated my initial post. I'm seeing it there as well. Thanks for the reply

My FX TVE Pacific feed Channels all play fine using XFINITY TVE.

I see same issues on Nate Geo WILD and Disney owned channels stations on TVE as well. I have reported it to Nat Geo/ ABC/Disney, and after several emails back and forth, they can not re-produce the issues reported, blaming "your provider".

I sent them a video clip & got the same "can't reproduce the issue" response as well! I have Allo Fiber with 500 up & down speed. The only (ATV4K) device not hardwired is 10ft away. It consistently averages over 450 up & down. It's NOT my ISP.