Hardware Transcoding new build

I have a new build and can't get hardware transcoding working. I usually run it with the TVE docker, and that didn't work. I built my own container (based on ubuntu bionic and focal) and have that running as a user and adding that user to video groups (based on linuxserver.io's plex container) and everything works there except hardware transcoding. I also tried running it directly on my server, and still no hardware transcoding.

uname -a
Linux server 5.4.0-39-generic #43-Ubuntu SMP Fri Jun 19 10:28:31 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

id
uid=1000(timstephens24) gid=1000(timstephens24) groups=1000(timstephens24),4(adm),24(cdrom),27(sudo),30(dip),44(video),46(plugdev),109(render),120(lpadmin),131(lxd),132(sambashare),998(docker)

ll /dev/dri
total 0
drwxr-xr-x   3 root root        100 Jun 25 10:56 .
drwxr-xr-x  20 root root       5.0K Jun 25 10:57 ..
drwxr-xr-x   2 root root         80 Jun 25 10:56 by-path
crw-rw----+  1 root video  226,   0 Jun 25 10:56 card0
crw-rw----+  1 root render 226, 128 Jun 25 10:56 renderD128

cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 165
model name	: Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz
stepping	: 5
microcode	: 0xc8
cpu MHz		: 1591.533
cache size	: 16384 KB
physical id	: 0
siblings	: 16
core id		: 0
cpu cores	: 8
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 22
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault invpcid_single ssbd ibrs ibpb stibp ibrs_enhanced tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid mpx rdseed adx smap clflushopt intel_pt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp pku ospke md_clear flush_l1d arch_capabilities
bugs		: spectre_v1 spectre_v2 spec_store_bypass swapgs itlb_multihit
bogomips	: 7599.80
clflush size	: 64
cache_alignment	: 64
address sizes	: 39 bits physical, 48 bits virtual
power management:

sudo lshw -C display
  *-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: [email protected]:00:02.0
       logical name: /dev/fb0
       version: 05
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:600-5ff iomemory:400-3ff irq:139 memory:6008000000-6008ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff

I got it to at least recognize hardware transcoding with a pretty generic ffmpeg build (but I'm missing a lot of your build configuration/dependencies). Guessing it just needs updated for the new 10th gen iHardware.

Yea 10th-gen is currently not supported. See previous discussion in NUC 10i3

1 Like