HD HomeRun Tuner not working on FireTV

HD HomeRun tuner was working fine with Channels DVR on FireTV 4k but now does not. It shows up as a tuner with the correct IP address but there are no channels.

This started when I changed the IP address of the HDHR. The correct IP address is listed.

Everything works normally from the Channels DVR computer and recordings are working as they should.

Any ideas?


Oh - by the way, I've restarted everything, I've cleared the app data on the FireTV Stick, I've removed and re-installed the app on the FireTV stick and I also tried the beta version of the app. No change with the the tuner.

When you say "there are no channels" do you mean in the guide?

Don't forget that the guide has several "views" such as "Favorites", "HD", "All Channels", etc. Perhaps you've inadvertently chosen a view that has no channels associated with it?

Thanks VTTom - Yes, no channels in the guide or On Now. The guide is set to 'All'. When I go to Tuner and select the HDHR it would normally list the channels but in my case it just says 'Channels' but nothing listed.

It asks if I want to update the firmware to 20170930 and that's older than what I'm running at 20190621.

Does the dvr web UI show the right IP for your tuner?

Yes, the web UI shows the correct IP address as does the Fire TV app. Live TV and scheduled recordings all work from the browser/computer running the DVR.

Please submit diagnostics from the app

Clear the data on your Channels DVR firetv app then start Channels DVR APP.

I'll submit the diagnostics from the app shortly.

I have already cleared the data, removed and re-installed the app, tried the beta install - same result.

Can you try updating your dvr by click-and-hold on the Update button.

Looks like the update to 2020.02.03.2211 did the trick!

I installed that, closed the app on the fire stick and cleared the data and cache but it still didn't work. I then restarted the Firestick and it's back to normal.

Not sure what the deal was but thanks - back in business!

Bummer - looks like the trouble is back. I tried to watch a live channel and received a message that 'the tuner is not responding'. When I go to the tuner it is now again offering to update the firmware to 2017 and there are no channels listed.

Any idea what could be going on?

It seems like a network issue where the FTV isn't able to talk to the HDHR and get all its details correctly. Are you running across VLANs or something?

Hmm - nope, just one network flat network. The HDHR status page comes up from any other computer/device I try it on.