Help with Docker on Raspberry Pi

So I am definitely not super familiar with linux but I am comfortable working in command line provided someone helps me with the syntax and such.

So I've got my Raspberry Pi setup with a static IP on my network, I think I have Docker installed correctly because if I run: "sudo docker version" I get a reply with 20.10.0 for version number.

I ran the docker commands as I found somewhere else and I think it's worked because when I attempted: "sudo docker run --restart unless-stopped --name pluto-for-channels -p 8080:80 jonmaddox/pluto-for-channels" and it returns essentially "Conflict. The container name "/pluto-for-channels" is already in use.

So I think the Docker container is running appropriately but when I put "http://raspberryip:8080playlist.m3u" in the server settings but it doesn't seem to find any channels.

Any help?

You need the full url for the playlist.m3u

Something like http://XXXXXXX:8080/playlist.m3u

The XXXXXXX being the ip (or name if you have it setup to be addressable this way) of the RPi

Try the url in a web browser (that can reach the RPi) and see if it populates or gives an error.

Yeah, sorry, the forum removed a tag I used in attempting to show the IP.. I did use the IP for the RasperryPi. It's 192.168.86.10

When I try to connect to that from my phone I do get an error that it can't be reached. My routed definitely identifies the Raspberry Pi with that IP and on the RaspberryPi if I use "hostname -I" it returns: 192.168.86.10 172.17.0.1

Does docker ps show it as running?

You can try docker stop pluto-for-channels && docker rm pluto-for-channels then try to recreate it.

It should show you it's running when you click http://192.168.86.10:8080

If I don't use "sudo" none of the commands work. But "sudo docker ps" does not show any containers running.

Running the stop command and then re-running the original docker run --restart unless-stopped......." did show it pulling EPG data and follows with "SUCCESS Wrote EPG to epg.xml!" and "SUCCESS Wrote the M3U8 tuner to playlist.m3u8"

And when I just tried from my phone it downloaded the m3u file so give me a couple minutes to check the server and play from the nvidia shield.

I think you're missing a -d on that run command.

It does seem to be working right now (without the -d).

What does the -d part of the command do, and should stop the Docker and restart it again with the -d?

It puts it in the background so it keeps running

10-4. I'll stop it and re-start. I'll also need to relocate the Raspberry PI and power it off, does the Docker container restart automatically?

Just tried to stop and rerun it adding the -d and I get a "Conflict. The container name /pluto-for-channels is already in use" error but docker ps doesn't show any containers running.

Just wanted to thank everyone, I believe I have it working. It's downloaded the channels and the guide data. Let's hope my Pluto Channels don't drop like they did on the other m3u file.

I did have to run "docker system prune" to delete the non -d container. But I just recreated it with the correct command and all seems good.

1 Like

Is the docker install on tap for the dedicated Pi image?

Docker is installed already on the RasPi DVR image so this is super easy to accomplish. If you enable SSH access per tmm1's instructions from the RaspberryPi page (BETA: Channels DVR Server for Raspberry Pi 4 (USB BOOT IMAGE)), then ssh in and run the command listed in the "Setup" section on the Pluto Project page (https://github.com/maddox/pluto-for-channels#set-up) you should be up and running. Run "docker ps" to verify.

docker ps

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
e8fae16b667a jonmaddox/pluto-for-channels "/usr/src/app/entryp…" 3 hours ago Up 3 hours 0.0.0.0:8080->80/tcp pluto-for-channels

Then just follow the rest of the Pluto instructions to set it up. For the least friction this may be the simplest DVR to set Pluto up. (Edit: the Docker command is set to persist across reboots so I removed my question about starting this on boot)