How to access new folder on Pi4 to input Streaming Link?

I feel silly for asking this but.....

I'm running Channels on the Pi4. I have a Windows 10 PC. I can successfully create the new folder for the Stream Links on the Pi4 but I cannot find a way to access the new folder to paste in the Stream Link text file.

I've shut down the Pi4 and moved the USB3 drive from it to my PC figuring I could access the file that way but my PC cannot see/open the drive(?). Is this because it is formatted for the Pi4?

Moving the drive back to the Pi4 and powering it up everything came back online (whew!).

I know I'm missing a "hiding in plain sight" step, I just can't figure out what it is.

Depends on how u are running the sever on the Pi4.

Using the Channels image? Or different os with the Channels server installed?\

For me, I remotely access my Pi's vis SSH.
I can access the file system via SSH using FileZilla.
I do this to backup config files for my custom DNS server on a pi that is running RaspberrianOS Lite.
Not fully certain if the same method would work with a pi running the Channels Image, since that is using a different os. I would think it would, but u may not have write permissions to many folder.

Thanks. I'm running the Pi Channels Image. I did that because it was incredibly easy to do and it kept the Pi as a dedicated machine. I can get comfortably deep in the bowels of a Windows OS but am an admitted complete noob for anything having to do with the Pi OS. If there is a simple step I'm missing I'd love a pointer. I can't/won't expect a ton of hand holding if it is much deeper than that. Learning the OS is something I should do. From reading the instructions here though Channels Support - Import Content from Streaming Services with Stream Links (getchannels.com) it seemed like a simple copy/paste event.

The drive is supposed to appear in Windows when you plug it in. I'm surprised that didn't work.

Are you currently trying over samba? Do you see the dvr files in your Windows explorer? Which directory did you create? What happens when you try to make the file using Notepad.exe?

Maybe you can post a screenshot of where you're getting stuck.

Updated to the latest firmware and pre-release server. I can create the folder but simply cannot find a way to paste the text file inside of it. As mentioned shutting down the Pi, moving the drive to my Win10 PC does not allow me to view the files since Windows doesn't recognize it. What's weird is Windows will let me "Safely Eject" the invisible drive even though it won't display it next to my other drives. It's a WD 2TB USB3 Drive that has only ever been used on the Pi4.

Okay thanks for the screenshot. You don't need to change anything under Storage Paths. Please click trash there.

There is a separate section called Local Content down further on the page where imports are configured. If you're using the precreated Import folder, then you don't have to do anything there either. You can use the dropdown there to kick off a scan once you're created the strmlnk file.

Currently there is no way to create the stream link file from the web browser interface. The problem is that you've created a folder called 1x01.strmlnk. You need to delete that folder. Then you need to open notepad.exe and paste the URL. Then go to file>save as and save it into your Season 1 folder with the name 1x01.strmlnk

That all makes perfect sense, thanks. Creating the Streamlink in notepad is not a problem but I have no way to paste it via the web interface and for whatever reason my PC won't recognize the drive to allow me to do so there so I guess I'll not use this feature. Do you think there will ever be a way to do this via the web interface?

Did you try accessing via Samba? In Windows Explorer it should show the Pi, let you connect, and list all the files including your recordings. That's where you'd create the directory and file.

It seemed like you already created those directories somehow and I wasn't sure.

I would like to make it easier to create a strmlink directly from the web UI. It's on my TODO list.

1 Like

I had a similar issue, had to do this then it appeared and worked fine:
Guest access in SMB2 is disabled - Windows Server | Microsoft Docs

1 Like