Removing the source will remove all the movies that were imported from that source.

ok, then how do you remove it? for two days ive ran the following command and they still appear:


ive tried every permutation with out the doubled unc path, with the ip address, local host, etc. nothing happens, no entry in the logs, nothing. ive even tried in windows with curl.exe


I think that's supposed to be backslashes, not forward slashes. Only backslashes are doubled up. Forward slashes are not.

1 Like

Hmm, that's weird. It works for me:

Just tired again and works. Sorry about that.

How about
Movies/A Christmas Carol (1984)/A Christmas Carol (1984).m4v
Movies/A Christmas Carol (2009)/A Christmas Carol (2009).m4v

I just wanted to make sure everyone understood that this feature is pre-alpha. It wasn’t even supposed to be public yet, but here it is lol.

It’s important to remember that you shouldn’t rely on any of this data at all. We’re a couple weeks into it and things will change dramatically. Don’t be surprised if you update your server and your entire imported library is gone (data not files).

If you don’t like the sound of that, stay away from it for now until we make a public call for testing. This is very much an internal feature for now.

I just want to make sure the expectations were set. Thanks :grinning:


Understand this is pre-alpha. I will say that I'm impressed that I had a >98% match rate scanning over 2500 movies. These files were collected off my Tivo and surfaced via Plex. Some special characters were stripped in the file names and the movie year may or may not be right. Tivo's guide has gotten worse when they moved off Gracenote. It looks like ignoring apostrophes on search would have helped a lot of these find matches.

List of unmatched movies:

10,000 B.C. (2008).mp4
50_50 (2011).mp4
Alien The Directors Cut (2003).mp4
All the Presidents Men (1976).mp4
American Ninja IV (1991).mp4
Babettes Feast (1988).mp4
Brooklyns Finest (2010).mp4
Brüno (2009).mp4
Bucktown, USA (1976).mp4
Cah (2010).mp4
Carlitos Way (1993).mp4
Charlottes Web (1973).mp4
Chatos Land (1972).mp4
Childs Play (1988).mp4
Crooklyn (1994).mp4
Dumb And Dumberer (2003).mp4
Enders Game (2013).mp4
Everybodys All-American (1988).mp4
F_X (1986).mp4
Face_Off (1997).mp4
Fools Gold (2008).mp4
Grandmas Boy (2006).mp4
Gridlockd (1997).mp4
Heavens Gate (1980).mp4
In and Out (1997).mp4
Its Alive (1974).mp4
Jennifers Body (2009).mp4
Jimmys Hall (2015).mp4
Kellys Heroes (1970).mp4
Keplers Dream (2016).mp4
La Cage aux Folles (1978).mp4
Les Misrables (2012).mp4
Lets Be Cops (2014).mp4
Logans Run (1976).mp4
Machine Gun Preacher (2011).mp4
Made of Honor (2008).mp4
Mans Best Friend (1993).mp4

Understood perfectly. Thanks for letting us play along.

I stopped importing my movies two things I did not like ....

  1. They show up within the recorded Movies would prefer an imported section instead.

  2. I am not sure of this but I believe anybody can delete the imported movies from the UI ?

Yes, totally got it on the Pre-Alpha. I also love helping you guys test stuff though because you're so quick with fixes and changes.

I can see this is probably way off from what it could/would eventually be. There are lots of things I would change regarding UI and usability but I figured you aren't close to ready for that yet.

So far playback has been good on my end. I have run a couple of movies through it so far.

Movies are movies, why does it matter if they were recorded or imported?

I guess coming from SageTV they separated recorded media from imported media .. to avoid accidental deletion as the imported section can be set to no delete .. no big deal if all are grouped as movies as long as users cannot delete any imported movies.

Okay that makes sense. Right now the DVR will never delete any imported movie from the disk, regardless of what the UI shows. The UI will change in the future as the current work is happening on the backend.

Thanks for the list! Looks like most of the failures are due to apostrophes. Unfortunately that's out of our control as the guide search API does not deal with it very well. We're seeing the same behavior on when trying to search for "Charlottes Web" vs "Charlotte's Web".

These should work starting in v2019.11.04.2345

This is also fixed in v2019.11.04.2345

Were those original recordings renamed to remove the air date at the end of the filename?

Or did you have to fix the matches when you imported?

This is fixed in the latest build v2019.11.05.0016. You will need to remove and re-add the folder which contains these movies.

I did not receive any more examples from you, so its possible other files with different patterns will not match automatically.

No way to change the poster image at the moment.

The latest build now shows movie posters in the Imports section when available.

We do not control the list of genres- they come from the guide provider. The web UI was only showing top 5 genres, but I have changed it to list them all out in the latest build.

Just curious since it will probably help others- are you renaming by hand, or using some program to do it?

Well done. Thanks for the extremely quick changes. > 95% of my movies were auto matched. I fix the remaining.

Regarding the Genre. Yes, there are lot of them now. I assume this will also be available in the Apple TV Client :slight_smile:

Thanks for the Posters in the Import section. That was helpful when fixing my initial imports.

Suggestion: I assume you will have a Watched vs UnWatched Selection at some point. It would be helpful to MARK all as Watched as a option after the first setup.

1 Like

Thanks. Just re-scanned the movie Home and it's finding the correct one now.

1 Like

Plex ignores anything within square brackets.

In MacOS I'm using the rename feature in finder. Its basically like a Find/Replace in a word processor. I would do things like searching for 2013 and replacing with (2013), or search for 1080p and leave the replace field blank. Its not totally automated but it does fix a lot at a time with a lot less work.

The more manual work will be adding years to all of the files.

1 Like

Most media platforms use the year in the parent directory, but use it as optional for the file itself:
Some Movie Title (2057)/Some Movie Title.ext

I just don't see the point in an unnecessary folder in the directory tree.

I know you can import from multiple paths like this
curl -XPUT
curl -XPUT
Does the scanner then scan both paths for changes every 5 minutes, or only the most recent path you imported from?

Is there a way to view what scan/import paths you have set?
I know you can see it as ImportPath in the /dvr/files json of each file, but anywhere else?