The old files never went away even after I had a new source directory selected for a few days, so I deleted them manually one-by-one. As noted above, using Delete on an import removes the listing but does not actually delete the file. (Using Delete on anything else does delete the file.) I have since run Scan and the old batch has not returned.

If a user were to import movies with 5.1 channel audio, could these files be played remotely retaining the 5.1 channel audio?

I would also like the ability to import TV shows. The thumbnail art isn't as important so long as I can read the show name, season, and episode number (and episode title, if possible) in Channels. The movies import has worked extremely well for me. I previously used EyeTV software to record both movies and TV shows on a Mac Mini. Extracting the .meg file from the .eyetv package and naming it with the movie title and (year) has allowed me to salvage years of recordings from my old EyeTV folders.


This would be a really useful feature for people moving from TiVo, etc. I saved all the remains shows when I switched, but now I have to watch them through iTunes, or Flex. It would be perfect if they were in ChannelsDVr with all the newly recorded shows.

1 Like

I've just given this a quick test with importing my movies folder from Plex, I'm running the Channels DVR server on a QNAP NAS with the Plex folders on the same NAS. When I import movies they all come through as 0 sec in duration and with a lot of duplicate files/versions of the same movie showing up:

Could you please post to this thread with a description of your directory structure?

1 Like

I've added some info in that thread, it looks like it's finding some hidden thumbnail files somewhere related to the directory for the movie file and then treating them as another version of the movie, but not all movies are doing this. it's inconsistent and I can't seem to spot a common cause of it. The image below shows the filename of the correct video file that plays as expected, and the one below refers to a thumbnail image but treats it as the movie.

On that screenshot, the second copy is a split resource fork for the recording. (You can tell because it starts with ._.) Those files are created by macOS when accessing files systems that do not support resource forks.

To disable:

Edit: No, after looking at it again, it looks like some hidden directory is being used to create thumbnails for whatever program you used before.

You may want to clean up your library a bit if you're going to use Channels' pre-alpha movie imports.

Thanks for the response, but I'm not running on macOS this may be a similar thing that the QNAP os does but when viewing in its file browser or via Windows explorer I can't find any hidden folders or files.
Edit: just seen your edit, the directories are pretty clean. The only extraneous files I can see are subtitle files that Plex has downloaded and plenty of the films that have those don't show the duplicated behaviour. I've manually cleared all the .NFO files that an experiment with Emby generated and in basically all the folders there nothing but the movie file

The screenshot clearly shows a [email protected]_thumb directory under the movie's parent folder.

This could be a side-effect of some type of media file indexing that your QNAP NAS is running ...

Yeah I think you're right, a recent QTS update added some multimedia indexing app and I've just spotted it's got a thumbnail generating process which I've just now disabled and I'm trying to force it to remove the previously generated thumbnails then I'll rescan and report back!

I've uploaded a new build of the DVR which will ignore these .@thumb directories. You will need to update, then remove the movies source and re-add it.

1 Like

Thanks for the quick turn around on this, I had previously removed the movies source directory which seemed to get rid of all the genuine movie files from Channels but I'm still seeing the references to the .@thumb files. Is there a quick way to remove these from the DVR rather than manually deleting them all individually, there's about 1000 otherwise!

Yes if you follow my instructions:

That's what I did, and those files were still present, I removed the source and only the actual video files were removed, the thumbs and invalid files remained. I then added the directory again and it still found these .@thumb files. I've restored to a previous database backup and they're now gone. I've since tried the import again with the same folder and it's adding these .@thumb files again. I'm not complaining about the feature not working as final, I know it's pre-release and I just wanted to provide any useful feedback to help get it working as well as possible, I totally understand the nature of pre release software :slight_smile:

I've tried this a couple more times and when I try and remove a source folder the DVR eventually hangs, it seems like it fails during the process where the files are being removed from the ChannelsDVR database. I have to force close the DVR app in the QNAP OS and restart it for it to work again, then the imported files are still present in the Imported and Movies, but the source folder is removed. Clicking prune deleted doesn't have an affect and I'm unable to remove the directory again to try and kick off the files being removed. is there a command I can run to remove all imported files without having to roll back the DVR to a previous backup without them?

Could you check the log to see if there are any errors after you ask it to prune?

No errors in the log after clicking prune, unfortunately.

Please try the latest build. It should ignore those @thumb folders now.

Thanks for the update, my only problem is I still have all the .@thumb files and the previous movie files present in my Imports folder. I've removed the movie source folder from within the DVR Web interface, but as I mentioned above the DVR hung while in the process of removing the folder, and I had to force a restart which left a large amount of the thumb files and genuine movie files still visible, and prune doesn't remove these files. So I'm ready to test the new DVR build that should ignore the .@thumb files but won't be sure whether it's really ignoring them or not until I remove the old ones that are still there. Is there a command or something I can do to clear these files?