Keeps losing connection

Some days I turn on my Apple TV and it can't find the server. Switch to my Fire tv attached to the same receiver and it's fine. Any thoughts.

Do you have a static dhcp lease set for your dvr server? Did you click Connect to DVR and enter the IP of the dvr?

Yes and it just takes so long to connect. For instance. I just turned on the Apple TV and all the tve everywhere has no guide data and channels say tuner not available. Fire tv works fine. The only way I can get it to work is re enter my ip.

Does restarting the app help? Click TV/Home twice and swipe up.

Is the bonjour checkbox on your DVR checked?

I don’t use the Apple remote, tried restarting. Bonjour is checked.

So still happening and getting worse. Is there a way to automatically switch between home and out of home when the connection is gets lost gain?

Now my iPad won’t connect

Please submit diagnostics from the app

error: url= domain=NSURLErrorDomain code=-1001 description=The request timed out.

error: url= domain=NSURLErrorDomain code=-1001 description=The request timed out.

It looks like either your network is not reliable, or your IP on your DVR laptop keeps changing.

You should login to your router and setup a static DHCP rule for your DVR so it keeps the same IP. It's also recommended to do the same for your HDHR.


How come it only affects Apple devices, Not Firetv or Android?

Set static IP on both my Hdhomeruns and dvr server. So far so good. Big plus is channels change so much faster

1 Like

And not working again. Says no server at IP address. How can the browser on the iPad find the server and the app can’t

Please submit diagnostics again

I pad sent. Will send Apple TV when I can get into app

On the Apple TV I can’t open the app, but I can watch OTA only from the top row.

On your iPad in Safari can you open

How long does it take to load?


In your diagnostics it shows it tried to connect two times, and waited 2 seconds each time and did not get any response.

Is your laptop going to sleep maybe?

The only difference in Android is it waits 3 seconds instead of 2 seconds.

Just checked, Laptop is not asleep

Well it would have woken up if its loading fast now. But maybe it was sleeping before and slow to wake up?

You can check the window settings to see if its set to sleep: