Laptop UI not working, but clients are working

When I go here to try to watch nothing plays from any source, just a spinning circle.
Also Add Source has a small spinning circle next to the Down Arrow inside the selection box.
I see that the "Enable DVR" box is UNCHECKED.
I click it and a screen comes up to enable DVR Recordings,
I pick my directory on the D: drive and it says there is already an existing directory and would I like to restore
Well all my clients work fine, watching channels and recordings.
I want to be sure I should say to Restore, since it is all OK on clients, just not from above laptop UI. ???
Nothing seems to show in the LOGS

You don't need to restore unless it is fresh install. Try clicking Save

I tried clicking Save
Now spinning circles on Check for Update and Add source

I closed out the Channels Settings tab and went back in.
The spinning circles were gone, my Sources showed,
I tried to play a channel from the Guide nothing played
and all the Sources disappeared again, spinning circles returned, Enable DVR again unchecked.
Reloaded Channels Settings tab again and all "looks" fine, I can click on a source and see all its channels
But as soon as I try to go to the Live TV guide and play something all the issues return !!!
If I don't try to play something in the Guide but just go back to Settings all is still fine.

Submit diagnostics

I go to Channels Support / Logs
Nothing there that shows me trying to watch a channel just previous.
But something from about 15 minutes previous: here it is about 35 minutes back
I think this is all from a Client, nothing shows in the LOGS from trying to use the laptop UI
2022/11/06 08:50:31.151040 [IDX] Pruned 188 expired groups from X-TVE in 7.9891ms.
2022/11/06 08:50:31.151040 [IDX] Pruned 0 expired groups from X-M3U in 0s.
2022/11/06 08:50:31.157041 [IDX] Pruned 30 expired groups from USA-OTA70508 in 6.0008ms.
2022/11/06 08:50:31.169340 [DBG] Scheduling wake timer for scheduled recording in 23h58m30s
2022/11/06 08:50:31.177055 [IDX] Pruned 1600 expired airings from USA-OTA70508 in 9.931ms.
2022/11/06 08:50:31.242552 [IDX] Pruned 4509 expired airings from X-TVE in 65.4955ms.
2022/11/06 08:50:31.245586 [IDX] Pruned 54 expired airings from X-M3U in 3.0347ms.
2022/11/06 08:50:31.245586 [DBG] Scheduling wake timer for guide data in 24h49m58.7544133s
2022/11/06 13:54:59.520194 [DVR] Recording engine stopped.
2022/11/06 13:55:02.886447 [DBG] Scheduling wake timer for scheduled recording in 23h58m30s
2022/11/06 13:55:02.894453 [DVR] Recording engine started in D:\ChDVR
2022/11/06 13:55:02.935390 [SYS] Created database snapshot: backup-20221106.135502
2022/11/06 13:55:02.935889 [SYS] Removing old backup backup-20221008.182226
2022/11/06 13:55:12.911741 [IDX] Pruned 452 expired airings from USA-OTA70508 in 7.5089ms.
2022/11/06 13:55:12.926183 [IDX] Pruned 1027 expired airings from X-TVE in 14.4419ms.
2022/11/06 13:55:12.930856 [IDX] Pruned 30 expired airings from X-M3U in 4.6728ms.
2022/11/06 13:55:12.931053 [DBG] Scheduling wake timer for guide data in 19h27m17.0691437s
2022/11/06 14:10:08.213222 [TVE] stream timestamps: fnc: start_at=2022-11-06T14:09:08-06:00 end_at=2022-11-06T14:09:36-06:00 live_delay=27.3272221s
2022/11/06 14:10:08.213222 [TNR] Opened connection to TVE-Cox for ch6073 FNC
2022/11/06 14:10:16.716505 [SNR] Buffer statistics for (Family Room TV) for ch6073 FNC: buf=0% drop=0%
2022/11/06 14:10:16.761674 [TNR] Closed connection to TVE-Cox for ch6073 FNC
2022/11/06 14:10:24.340436 [TVE] stream timestamps: cooking-channel: start_at=2022-11-06T14:09:22-06:00 end_at=2022-11-06T14:09:54-06:00 live_delay=27.6834367s
2022/11/06 14:10:24.340436 [TNR] Opened connection to TVE-ATTOTT for ch6109 COOKING-CHANNEL
2022/11/06 14:10:56.746019 [SNR] Buffer statistics for (Family Room TV) for ch6109 COOKING-CHANNEL: buf=0% drop=0%
2022/11/06 14:10:56.760110 [TNR] Closed connection to TVE-ATTOTT for ch6109 COOKING-CHANNEL
2022/11/06 14:14:06.867916 [TVE] stream timestamps: fnc: start_at=2022-11-06T14:13:06-06:00 end_at=2022-11-06T14:13:35-06:00 live_delay=27.7872165s
2022/11/06 14:14:06.867916 [TNR] Opened connection to TVE-ATTOTT for ch6073 FNC

Support > Troubleshooting

Ahhh, OK, doing that.
I am getting spinning circle on Support TroubleShooting submit diagnostics

I've tried other Bowsers, all doing the same, spinning circle on Submit Diagnostics
and nothing plays.

This has been going on for a few days, not just today.
I usually use the UI when I have added or changed a Custom Channel and want to try it out on the UI first.
The only thing I can think of is I tried adding a Custom Channel m3u that would show a static guide type screen for a movie Channel, Dark Matter.
It didn't work it just showed the Dark Matter movie currently playing not a guide, so I deleted it.
Not sure of the timing of that vs when the UI stopped working.

Random shot in the dark here, but it is sounding more like some type of network/firewall issue. Can you try accessing the web UI from a different device on your network, using the DVR's IP address? Also, try using the loopback address instead of localhost when accessing the DVR. Both tests can help weed out simple network/nameserver errors, and allow additional directions of support to be taken.

Windows and its default settings leave much to be desired ... have you ensured that your connection within your home is marked as a "private" network as opposed to a "public" network in the Windows settings?

1 Like

Well nothing has changed except for me playing around with a Custom Channel,
unless of course some Windows Update changed something.
How do i et to the Admin/Settings from my iPhone.
I tried http://localhost:8089/admin/settings but it says Could not connect to Server
Phone IS on same network.

Substitute the ip address of the channels server for local host when accessing it from another device

Same thing, cannot play a channel.

That will not work from your phone or another device ... you need the ip of the server.

Phone says
This connection not private
won't go

remove the s in https:// to just have http://

Yes, that now goes to the server using my phone...
BUT, same issue, spinning circle, won't play

Will it play from the app on your phone?

Yes, the actual Client app plays fine including recordings on all Clients including Phone.
The Admin UI will not play a channel on phone, fails just like on the laptop.