Latest Beta fails to play

Just installed the latest beta on my Apple TV and now it will not play any source live local or TVE

Went back to the previous version and it works fine reloaded the latest beta and it will not play any source

Tried to send logs but the latest beta acts like it has no Network connection at all.

Hmm, weird. It is working here..

I deleted it, did a reboot of the atv, reinstalled it and whatever source I select I get a black screen and a spinning wheel. DVR sees no activity, nothing playing. Uninstall, go back a level on the ATV beta and it works as normal.

Remember, you need to delete both the beta and the release. They share settings in the device, so as long as one remains installed, the app's settings/data will not be purged upon removal.

Sounds more like a deadlock. Can you submit diagnostics after restarting the app, before trying playback again.

Are you sure you're on the latest 2022 build?

DVR also no longer reporting activity by IP, now using local names of clients. This is a problem because I have devices in two locations that use the same names such as Livingroom or bedroom. Can’t tell which device where is playing. Maybe this is related if it’s seeing the same name in more than one instance

Hold on, will do that


I don’t have the release installed at all.

I’m getting a hang while trying to play a recording on the latest beta. Regular client is fine. Just submitted diagnostics.

Same on 2256. Diags sent again.

Tried another ATV with the latest beta,still no playback. Rolled backed to yesterdays beta and everything is fine with that.

Can you try the latest build that just went out?

We've taken another run at fixing this and our initial tests looked positive.

Nope , just tried. Works with default driver, not experimental. It fooled me at first, I turned off default and went to experimental and back to the same show I was watching and it played, but when I changed channels it failed. Went back to default and that channel played.

@mtnbkr60 can you submit diagnostics from the app after it hangs on the latest build?


Seems related to experimental video + match frame rate.

That’s new. Never had a conflict there before.

@mtnbkr60 We've taken another pass at fixing this. Can you see if this latest beta does any better?