Live TV glitch/stutter channels only

I have started to see an issue with live TV stuttering periodically, just for a second, enough to notice that the video and audio has stopped, the status bar on the bottom of the screen comes up with the spinning circle, then the video starts again.
I have submitted logs this morning on this issue. I have tried to troubleshoot anything I control, everything is wired Ethernet. The HDHomeRun Quattro is wired and updated to the latest firmware, I reset, updated and reinstalled the channels app and still happens. I don’t see any issues with the streaming apps I have on this Apple TV, including watching sports live.
Hardware is Apple TV 4K A2169, running tvOS 16.4
Happy for any help to find the issue!!


Have an additional detail, I have been sending logs today. If I leave the tv on for a couple hours, with the stutter, then try to change channels I get the warning that it looks like your behind the guide. So it's like its not losing connection to the source when the stutter happens, more like a 1-3 second pause.

Does it happen in the official HDHomeRun app

1 Like

Great question, sorry that was not a troubleshooting tool I tried. I do see similar behavior with that app as well. So the issue seems to be specific to this device and only when pulling live tv, no issues are seen using streaming apps.

You can't compare streaming apps which pull h264 from internet CDNs to mpeg2 over local network.

The HDHR is very sensitive to LAN latency and antenna signal issues.

You can try changing Settings > Playback > Advanced > Tuner Sharing: On

1 Like

I had already tested with tuner sharing with no difference noted. I also tested with the HDHR connected to the same switch as the ATV with no difference noted. I also tested this on a second ATV in my home, different room and switch. We don’t typically use channels on that one, but it exhibits the same behavior. I sent the logs from that ATV as well. Starting to think it’s an issue with the HDHR quattro, hoping the logs may give a clue.

1 Like

Is HDHR firmware up to date?

You may need to contact SiliconDust support so they can look at the tuner logs.

You can also watch the HDHR status page for signal info while watching

1 Like

Thanks, the firmware is upto date, signal on their page along as what I monitor thru the signal GH app on my ipad shows 90% signal strength and 100% quality.

Further troubleshooting, I have a HDHR connect tuner as well on a different switch with a different antenna. Same issue exists when the ATVs use that tuner as well. Now, I run my channels DVR on my QNAP NAS, its connected to my home's core switch, and connects to the quattro to record shows. The recordings don't have any issues. So the QNAP isn't seeing the issue, nor are my ipads. This issue looks to be limited to tvOS devices. I sent more logs this morning from my ATV connected to the connect tuner with the issue.

FYI, I believe the issue is something slowing down the channels app ability to write to the storage on the ATV. I can make the issue go away by closing other streaming apps that are in the background on the ATV. So maybe a memory leak?? Any chance all the logs I have sent would have that info??

I'm seeing this same exact issue over the past several weeks as well.

FYI, as a further troubleshooting step I purchased a new ATV 4k it took almost 3 weeks but the issue came back. I can clear it by closing all apps and rebooting the ATV.

I have been able to narrow the issue to either something related to Deinterlacing Mode or the use of stereo HomePods.

Thus far, what seems to have mitigated the issue to a tolerable level... upgrade to Beta TVOS 16.5; use Hardware Deinterlacing Mode; Audio Driver set to experimental. This reduces the issues to a brief video pause when first tuning a channel, but otherwise things appear to work well.

1 Like

This issue and others has been happening for years with the HomePods.

There is an old thread of a bunch of us complaining. The answer we got is that they use the apis Apple gives them even though every other app works fine with HomePods.

We complained so much that a tweak was made to get what we have now.

I don’t notice it anymore. It’s baked into my “that’s how the app works” part of my brain. Trust me, it used to be bad. This second delay is nirvana.

This problem doesn’t happen if you use AirPods or any other speaker source.

1 Like

I’ll look at my deinterlacing mode, I don’t use a HomePod as a speaker for any of my tvs, all Sonos speakers.

Oh, I remember! I was a part of that thread. It appears as though some of those bugs are creeping back.

Any chance your issues are related to ATSC3 station(s)?

1 Like


Not for me either I don't believe, I don't have the newer homerun tuners to pull in ATSC3 stations. I have swapped back to my older ATV 4k, deinterlacing was already set to hardware and the experimental audio driver messed up sound to my Sonos beam so I am on default. Will continue to monitor and update.

1 Like

I'll hop on this bandwagon of lip sync issues. I'm still pretty new to Channels but have been reading tons on it.

Apple tv 4K newest model, I play the audio through my tv speakers only. I've also tried turning the experimental audio on in advanced settings. It may have helped a smidge but it's still pretty bad/annoying.

+1 happening today on Australian free to air channels. Using latest firmware on HDHR. Micro pauses on playback in channels on wired network. Glitches only happen in the channels app (playback via HDHR app is fine).