Losing channel lineup

I have a strange problem. I scan for channels, it finds plenty of channels and I can see them on the Favorites guide, nothing shows on the regular Guide view, and then it loses them. I checked the HDHomeRun source in the Settings and it shows 0 channels. I can't figure out what's happening.

The DVR is running on a PC on a network with 2 other PCs and various streaming devices such as a 2 Apple TV4Ks and a Fire Stick.

I have been auditioning VPNs that will be running on the same PC that houses the DVR and that's when the problem seems to start. I have since shut down any VPN running on that PC but I still have the missing channel issues.

Check on my.hdhomerun.com

Is the HDHR firmware up to date?

Do the channels show up there?

Can you click scan channels there and have it populate the list of channels?

It is now! Let me do a re-scan and I'll post back how it turns out. I'm not sure how it got out of date, SD usually sends an email notifying me about firmware updates, I don't recall getting any SD notifications in quite a while now that I think about it.

Still not right, it scans on the HDHomeRun webpage and finds over 400 channels but when I go back to the Channels setup page is still shows 0 channels found. I must be missing something somewhere.

BTW, the HDHR DVR works fine and uses the same PC to house the DVR software and storage.

Actually, I'm going to give it some time as it looks like it might be loading the guide info. I know it takes some time for that to complete.

Nope, nothing's happening, it's still not seeing any channels.

Did you try clicking the gear icon in Add Sources and select Scan Network. That should refresh the channel list coming from the HDHR.

Can you click Support > Troubleshooting > Submit Diagnostics

It works, the guide loads - I've had to scan on each client to get a guide to load - then on one ATV4K it works, I can watch content, select a new channel and watch that. BUt on the other ATV4K it does the scan, shows X-amount of channels found, I get a guide, select a channel and get a yellow text error "got response code htpp 502 error". And then neither ATV4K works. It appears to work but then it stops working. All the guide info disappears.

I submitted diagnostics.

You should only scan from the my.hdhomerun.com and do it once. There is no need to click scan in the apps.

Once the tuner is showing channels, then you can refresh the dvr via Scan Network.

Once the dvr is showing the channels, you can restart the app on Apple TV by clicking TV/Home twice and swiping up.

1 Like

I've seen thsi a couple of times also,

[code] A Javascript error has occurred!

Please refresh the browser after reporting this issue on Channels Community or to [email protected].

Cannot read property 'os' of undefined

[email protected]/settings/Status.js:59

[email protected]/cjs/react-dom.production.min.js:153

[email protected]/cjs/react-dom.production.min.js:261

[email protected]/cjs/react-dom.production.min.js:246

[email protected]/cjs/react-dom.production.min.js:246

[email protected]/cjs/react-dom.production.min.js:239

[email protected]/cjs/react-dom.production.min.js:123

[email protected]/cjs/scheduler.production.min.js:19

[email protected]/cjs/react-dom.production.min.js:122

[email protected]/cjs/react-dom.production.min.js:123 [/code]

I sent the logs, was I supposed to email them?

Try updating to prerelease using the Check for Update drop down

1 Like

Just did that and it shows up to date, 2021.05.26.1807, I'm not sure what it was previously, should have noted that.

Should I go through the scan procedure again?

You have to click the down arrow next to the button.

Scan needs to happen exactly once and only on the tuner setup page

On the HDHR tuner app or the web GUI for the tuner?

On my.hdhomerun.com under Channel Lineup

So I did the scan, and then "click here" and it shows source loading, and it still shows 0 channels on 192.168.50.179 which is the IP addy for the tuner.

Can you post some screenshots of what it shows on the tuner page and on the dvr page

It's all working fine now and I have no idea why or how. Two things I did before I stopped messing with last night were to remove completely the software for the two different VPN services I've been auditioning and to change the Windows user control set to 0 or no control. I started all devices this morning and they all have guide data and seem to be working fine. I suspect that maybe the VPN software was causing problems even though I was using split-tunneling on specific apps and never used the VPN on the whole computer.

I now have two questions, what is the procedure for using a VPN on the same machine that runs the Channels software, if it can even be done, and do you have a list of devices that can be used in lieu of the current PC?

Again, I'm not even sure the VPN usage was the issue, you guys would probably know the answer to that.:slight_smile:

We have heard of problems with VPN software with buggy split tunnel implementations. It breaks the DVR's ability to talk to other devices on the network. In some cases it also breaks the loopback network device.

2 Likes

That's probably what was happening then, thanks!

So, no VPN on the DVR machine then?

Correct, I don’t think it’s officially supported.

Third-party VPN providers have always been support nightmares for something like this. If you use a direct self-hosted VPN (run your own server for L2TP/IPSec, WireGuard, OpenVPN, etc.), then you can just connect as if your were locally in the same LAN (assuming your routing is properly setup). Otherwise, the hoops one needs to jump through introduce unforeseen issues as you have experienced.

1 Like