Missing all Discovery Channels (No login form found)

Greetings all!

Recently I am not able to tune any discovery channels, I went to my TVE sources (xfinity, Hulu and Philo) and for all the discovery channels I am seeing the message “no login form found”.

Here is from my logs:

2022/01/14 16:54:08.073848 [TVE] action=version product=HeadlessChrome/97.0.4692.71 jsVersion=9.7.106.18 protocol=1.3 [email protected]
2022/01/14 16:54:08.077055 [TVE] action=set_cookies domains=1 cookies=14
2022/01/14 16:54:08.079370 [TVE] action=mock
2022/01/14 16:54:08.081773 [TVE] action=navigate url=https://auth.sciencechannel.com/login-affiliates?returnUrl=https://www.sciencechannel.com/live-now&hostUrl=us1-prod-direct.sciencechannel.com
2022/01/14 16:54:08.082153 [TVE] action=request type=Document method=GET url=https://auth.sciencechannel.com/login-affiliates
2022/01/14 16:54:08.082161 [TVE] action=auth_domain domain=auth.sciencechannel.com
2022/01/14 16:54:08.082165 [TVE] action=scienceauth reason=login
2022/01/14 16:54:08.979643 [TVE] action=wait_for_page
2022/01/14 16:54:14.035671 [TVE] action=error_response type=Image error=net::ERR_CONNECTION_REFUSED url=https://analytics.twitter.com/i/adsct 
2022/01/14 16:54:14.153365 [TVE] action=error_response type=Image error=net::ERR_CONNECTION_REFUSED url=https://ads.scorecardresearch.com/p 
2022/01/14 16:54:15.098960 [TVE] action=error_response type=Image error=net::ERR_CONNECTION_REFUSED url=https://www.facebook.com/fr/b.php 
2022/01/14 16:54:15.140546 [TVE] action=page_ready
2022/01/14 16:54:15.140725 [TVE] action=wait_for_page done=true reason=page_ready
2022/01/14 16:54:17.141912 [TVE] action=click_interstitial
2022/01/14 16:54:17.145805 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2022/01/14 16:54:17.155183 [TVE] action=wait_for_interstitial
2022/01/14 16:54:19.079383 [TVE] action=request type=Document method=GET url=https://api.auth.adobe.com/api/v1/authenticate
2022/01/14 16:54:19.288878 [TVE] action=error_response type=Document error=net::ERR_CONNECTION_REFUSED url=https://api.auth.adobe.com/api/v1/authenticate 
2022/01/14 16:54:24.393524 [TVE] action=page_ready
2022/01/14 16:54:24.393742 [TVE] action=wait_for_interstitial done=true reason=page_ready
2022/01/14 16:54:25.370519 [TVE] action=fill_form u=3128108010
2022/01/14 16:54:25.376179 [TVE] action=screenshot
2022/01/14 16:54:25.474793 [TVE] action=screenshot size=3249
2022/01/14 16:54:25.475063 [TVE] action=capture_html
2022/01/14 16:54:25.475939 [TVE] action=capture_html size=39
2022/01/14 16:54:25.476116 [TVE] action=script_error err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught", LineNumber:9, ColumnNumber:5, ScriptID:"248", URL:"", StackTrace:(*runtime.StackTrace)(0x140016a1340), Exception:(*runtime.RemoteObject)(0x140016627e0), ExecutionContextID:0, ExceptionMetaData:easyjson.RawMessage(nil)} exp=&runtime.RemoteObject{Type:"string", Subtype:"", ClassName:"", Value:easyjson.RawMessage{0x22, 0x6e, 0x6f, 0x20, 0x6c, 0x6f, 0x67, 0x69, 0x6e, 0x20, 0x66, 0x6f, 0x72, 0x6d, 0x20, 0x66, 0x6f, 0x75, 0x6e, 0x64, 0x22}, UnserializableValue:"", Description:"", ObjectID:"", Preview:(*runtime.ObjectPreview)(nil), CustomPreview:(*runtime.CustomPreview)(nil)} exp_value="no login form found"

I submitted diagnostics: e3153ce6-93ce-49e1-8520-aa3e7fc4c5f8

Any help would be appreciated! I’ve tried streaming from the respective webpages and have no issues at all.

Seems like issue with your adblocker DNS

What kind of adblocker are you using?

I had a couple of safari ad blocking extensions running on the Mac, I removed them and still cannot get the channels to scan. What else can I check?

Also, I just tried on Philo and I get this in the log:
2022/01/14 18:09:29.508170 [TVE] action=version product=HeadlessChrome/97.0.4692.71 jsVersion=9.7.106.18 protocol=1.3 [email protected]
2022/01/14 18:09:29.524076 [TVE] action=navigate url=https://auth.sciencechannel.com/login-affiliates?returnUrl=https://www.sciencechannel.com/live-now&hostUrl=us1-prod-direct.sciencechannel.com
2022/01/14 18:09:29.524597 [TVE] action=request type=Document method=GET url=https://auth.sciencechannel.com/login-affiliates
2022/01/14 18:09:29.524606 [TVE] action=auth_domain domain=auth.sciencechannel.com
2022/01/14 18:09:29.524610 [TVE] action=scienceauth reason=login
2022/01/14 18:09:29.960098 [TVE] action=request type=Document method=GET url=https://prod.discoveryplus.com/
2022/01/14 18:09:30.640682 [TVE] action=request type=Document method=GET url=https://www.discoveryplus.com/
2022/01/14 18:09:31.166230 [TVE] action=wait_for_page
2022/01/14 18:09:42.694307 [TVE] action=page_ready
2022/01/14 18:09:42.695483 [TVE] action=wait_for_page done=true reason=page_ready
2022/01/14 18:09:44.696628 [TVE] action=click_interstitial
2022/01/14 18:09:44.702154 [TVE] action=tvejs msg="xfinityApprove not found"
2022/01/14 18:09:44.702245 [TVE] action=wait_for_interstitial
2022/01/14 18:10:14.702545 [TVE] action=wait_for_interstitial err=timeout
2022/01/14 18:10:14.702700 [TVE] action=fill_form u=MYEMAIL
2022/01/14 18:10:14.708888 [TVE] action=screenshot
2022/01/14 18:10:15.081080 [TVE] action=screenshot size=570420
2022/01/14 18:10:15.081565 [TVE] action=capture_html
2022/01/14 18:10:15.095747 [TVE] action=capture_html size=912040
2022/01/14 18:10:15.096107 [TVE] action=script_error err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught", LineNumber:9, ColumnNumber:5, ScriptID:"101", URL:"", StackTrace:(*runtime.StackTrace)(0x14001dcc300), Exception:(*runtime.RemoteObject)(0x140022803f0), ExecutionContextID:0, ExceptionMetaData:easyjson.RawMessage(nil)} exp=&runtime.RemoteObject{Type:"string", Subtype:"", ClassName:"", Value:easyjson.RawMessage{0x22, 0x6e, 0x6f, 0x20, 0x6c, 0x6f, 0x67, 0x69, 0x6e, 0x20, 0x66, 0x6f, 0x72, 0x6d, 0x20, 0x66, 0x6f, 0x75, 0x6e, 0x64, 0x22}, UnserializableValue:"", Description:"", ObjectID:"", Preview:(*runtime.ObjectPreview)(nil), CustomPreview:(*runtime.CustomPreview)(nil)} exp_value="no login form found"

It interesting that it mentions xfinity when I was rescanning Philo.

For good measure, here is what I get when I try to scan via the Hulu login:

2022/01/14 18:17:46.862212 [TVE] action=version product=HeadlessChrome/97.0.4692.71 jsVersion=9.7.106.18 protocol=1.3 [email protected]
2022/01/14 18:17:46.870483 [TVE] action=set_cookies domains=1 cookies=1
2022/01/14 18:17:46.873016 [TVE] action=mock
2022/01/14 18:17:46.875784 [TVE] action=navigate url=https://auth.sciencechannel.com/login-affiliates?returnUrl=https://www.sciencechannel.com/live-now&hostUrl=us1-prod-direct.sciencechannel.com
2022/01/14 18:17:46.876243 [TVE] action=request type=Document method=GET url=https://auth.sciencechannel.com/login-affiliates
2022/01/14 18:17:46.876253 [TVE] action=auth_domain domain=auth.sciencechannel.com
2022/01/14 18:17:46.876258 [TVE] action=scienceauth reason=login
2022/01/14 18:17:47.368767 [TVE] action=request type=Document method=GET url=https://prod.discoveryplus.com/
2022/01/14 18:17:48.040601 [TVE] action=request type=Document method=GET url=https://www.discoveryplus.com/
2022/01/14 18:17:48.886265 [TVE] action=wait_for_page
2022/01/14 18:17:53.972743 [TVE] action=error_response type=Image error=net::ERR_ABORTED url=https://www.pinterest.com/.well-known/attribution-reporting/trigger-attribution
2022/01/14 18:18:00.441058 [TVE] action=page_ready
2022/01/14 18:18:00.441231 [TVE] action=wait_for_page done=true reason=page_ready
2022/01/14 18:18:02.442449 [TVE] action=click_interstitial
2022/01/14 18:18:02.447128 [TVE] action=tvejs msg="xfinityApprove not found"
2022/01/14 18:18:02.447198 [TVE] action=wait_for_interstitial
2022/01/14 18:18:32.448391 [TVE] action=wait_for_interstitial err=timeout
2022/01/14 18:18:32.448546 [TVE] action=fill_form u=MYEMAIL
2022/01/14 18:18:32.453097 [TVE] action=screenshot
2022/01/14 18:18:32.803597 [TVE] action=screenshot size=570420
2022/01/14 18:18:32.803826 [TVE] action=capture_html
2022/01/14 18:18:32.817623 [TVE] action=capture_html size=912039
2022/01/14 18:18:32.817980 [TVE] action=script_error err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught", LineNumber:9, ColumnNumber:5, ScriptID:"621", URL:"", StackTrace:(*runtime.StackTrace)(0x14000643f80), Exception:(*runtime.RemoteObject)(0x1400197c090), ExecutionContextID:0, ExceptionMetaData:easyjson.RawMessage(nil)} exp=&runtime.RemoteObject{Type:"string", Subtype:"", ClassName:"", Value:easyjson.RawMessage{0x22, 0x6e, 0x6f, 0x20, 0x6c, 0x6f, 0x67, 0x69, 0x6e, 0x20, 0x66, 0x6f, 0x72, 0x6d, 0x20, 0x66, 0x6f, 0x75, 0x6e, 0x64, 0x22}, UnserializableValue:"", Description:"", ObjectID:"", Preview:(*runtime.ObjectPreview)(nil), CustomPreview:(*runtime.CustomPreview)(nil)} exp_value="no login form found"

Looking back at my recordings, this issue started on December 21 when y’all moved to the new Discovery TVE backend:

v2021.12.21.2353

• IMPROVED: Discovery TVE channels moved to new backend

Submit diagnostics after each rescan attempt.

What is your dns server set to?

I just tried the solution here and it worked!

Would you still like diagnostics?

I have had this same issue exactly since the fix in V2021.12.21.2353. Rescan of the Discovery and HGTV channels just gives in logs:
2022/01/15 14:57:17.691060 [TVE] action=cbs_station err=unavailable in location

I tried this fix and it hasn't worked for me, and I am also running both HGTV or Discovery in another tab on Chrome while trying it. I even am trying to use my VPN and still nada.

I have just reverted back to my V2021.12.16.2117 and it has worked to keep it going but now it is automatically updating to the latest stable and this won't let me run the old beta.

Who is your provider for tve access?

Are you outside the USA? If so, it may take some creative use of your VPN :slight_smile:

Sorry. Cox in Las Vegas.

Are you able to log in and watch at:
https://www.sciencechannel.com/channel/discovery

yes. I logged into https://www.sciencechannel.com/channel/discovery on Chrome on one tab, then went to another tab and tried to rescan discovery channel, still get:

2022/01/15 16:15:36.749677 [TVE] action=cbs_station err=unavailable in location

Are you trying to rescan the entire cox source or just discovery’s? Your log says cbs. Go to sources-cox-managelineup-edit- and just rescan discovery family networks. And you really need to update cox password in the dvr web ui to the current password before rescanning. This clears cookies in chrome folder

Yes, that is what I have done exactly. same result.

My best guess is in the way channels is identifying my IP address?

I am using a VPN to avoid home-based authentication(My Channels DVR server has a different dedicated internet by cox) and it still logs into https://www.sciencechannel.com/channel/discovery and all the discovery channels pages(HGTV) with no issue at all. I have never had an issue prior to the December code change.

You could try using your phone on cellular data and create a hotspot to share with your server. Use that connection and you can avoid the vpn. After the channels authorize you can go back to your normal server internet