More accidental clicks on pip button

Im not sure when it started but its been in the last few weeks. When Im trying to skip a commercial or go back a few minutes I tend to rapidly press the right side or left side of the touch pad. Recently this has, after 2 or 3 clicks activated the pip mode. Obviously its because the pip button is highlighted and then any click activates it. It just seems to get highlighted more easily than it has in the past. Not sure if anyone else has had this but I figured I would mention it.

Nothing has changed regarding this. This sounds like it’s just being caused by the not so great track pad on that remote. It’s not a great design, and this is kind of proof.

Having to click the same pad that is also used for moving focus just turned out to be a bad design, which is why they redesigned the remote.

Gotcha, thats what I figured. I may just disable the pip button. Figured I would mention in case there was a bug something. Thanks for the prompt response!

I don’t think that’s the case. I have also noticed the exact issue over the past few weeks and this never happened before. I am using a remote with a d pad (not the AppleTV remote), so clicking the up arrow by mistake isn’t happening. I notice often that the PIP button is highlighted resulting in the timeline staying up on the screen until I realize what’s going on and press the down arrow to dismiss it.

1 Like

Thanks for that, I'll take a look and see if I can repro.

1 Like

Not sure if that event gets logged, but I just sent diagnostics from tvOS right after it happened to help troubleshoot just in case.

This seems related:

I've had my PIP button hidden for a long time, have PIP automatically enabled because I use it all the time, but for those that don't, this appears to be a new problem.

1 Like

i had PiP set to auto, but also had the button enabled. it would stick to the PiP icon and that would also not allow me to swipe down for the overlay. i disabled the PiP icon for the first time tonight and it's so much better.

1 Like

As of the latest TestFlight beta, the PIP button being focused no longer keeps the timeline open indefinitely.

Can anyone confirm if this is actually fixed?
I'm still seeing the issue and the only difference is now the PIP button flashes when its hovered. The timeline is still stuck on the screen until you move the cursor off the PIP button.

This is still not fixed.

I keep getting the same result every time I touch the track pad. Is there a way to turn off pip completely. thought I did in settings, guess not.

Settings > Playback > Picture in Picture

Over four months later and sadly this issue is still not resolved.
I posted some mock-ups of a potential solution on this thread:

This should tell you that the issue is non-trivial. It is sporadic, and difficult to reliably reproduce, which means finding the cause is difficult, and a solution even more so.

(As I have mentioned previously, I have also experienced similar types of issues—where the focus seems to mysteriously move up—in other apps as well. I personally believe there is some underlying OS issue, which means a quick fix for Channels will probably not be arriving soon.)

1 Like

I respectfully disagree. I run into this bug multiple times per day, every day in Channels. It has annoyed my entire family, so I know it's not something with the way I'm holding/using the remote. I have two Apple TV's, one with the new USB-C remote and the other with the older Lighting remote, and the issue happens on both. Multiple people have also said the issue occurs when using a traditional remote without a touchpad so we can rule out its due to "finger slipping" or anything like that. Personally, I have not seen this behavior in any of the other apps on my Apple TV, so I don't see how this is an OS issue unless it's somehow linked to a special API that Channels is using.

In my mind, there are three things Channels should do to try to solve this.

  1. Spend more time debugging why the issue occurs in the first place. - This would take the longest, and from what @maddox said, they weren't able to figure this out the last time they looked at it, so I would skip this.
  2. Change the behavior so that if the PIP button does get highlighted, the timeline still hides after a few seconds. This is what @maddox said the plan was back in Sept 2023, but the purposed fix didn't work, graduated from beta to production, and still malfunctions. (it just flashes on the screen, video of this is also in the other thread)
  3. Move the PIP button somewhere else so that it can still be activated when desired but not randomly floating above the timeline where it can be accidentally selected/focused on.

My suggestion would be to focus on the third option since it might not only solve this problem, but would also make the UI more polished.

I am in the TestFlight and happy to do any testing or debugging to aid in getting this resolved.

And this is where we disagree. I have seen this across Channels, Peacock, Max, and Prime Video. I have experienced this with the AppleTV remote, and the TV's own remote over CEC.

We'll just have to agree to disagree.

A UI change would break consistency with the PIP button being above the timeline (as is standard in other apps), but in this case I agree that a change would be advantageous and beneficial.

Beta v2024.01.29.1736 seems to have fixed this issue!

1 Like

Channels 5.8 for Apple TV & iOS has fully resolved this issue. Thank you!

1 Like