Timeline won't hide when PIP button is selected

After the update to version 5.6.6 or 5.6.7, a new bug has appeared.

When watching any media and using the left and right arrows to move back and forward, it has become very easy to accidentally swipe up to the little PIP icon:

When then PIP button is selected, the timeline remains on the screen. You have to manually swipe down off of the PIP button, and then the timeline will hide after a few seconds like normal.

This never occurred in previous versions and has become very annoying. I hope this can be fixed within in a reasonable time frame.

I’m seeing this as well, except most times I can’t even swipe down to dismiss PIP and have to exit the video and restart to clear the banner. (Also, when the banner is visible, hitting the Back button should dismiss the banner, not exit the video.)

You can hide the pip button if it's bothering you

You’re not suggesting that it’s expected behavior to not be able to dismiss this banner, I hope.

I do use the PIP feature from time to time. If I turn off the PIP button, then how would I invoke the PIP when I want to use it? Going into the settings to turn it on and off is not a good solution.

Before this most recent update, this problem did not exist. Rather then trying to work around the issue, could efforts be made to revert or fix it?

The problem I'm having is even worse. When I scrub through a video with my Apple TV remote, after pushing ffw about 3 times the pip button will highlight, then if I push ffw again it will activate pip, forcing me to navigate down to the tiny window and turn it off. At no time am I pushing up, so the pip button should never come on. I thought maybe my Apple TV remote was buggy, so I tested with my LG remote which has 4 separate direction buttons, and pushing right on the LG also activates pip.

This never happens in any other app, and the problem only started a couple of weeks ago in your app, so I think there must be a bug in your software. I'm currently using build 2023.08.18.2205.

1 Like

@tmm1 Several of us have reported this bug now. Can you please have the engineers look into fixing this?

Seems related: More accidental clicks on pip button

This is a SUPER annoying bug. Like the worst I have seen on the app at least for daily usage because it happens so often.

1 Like

I'm seeing this bug also. I'm using the tvOS beta, so I assumed that it was related, but I don't really know.

We're currently investigating the bug, as nothing has changed on our end to cause this issue.

To avoid it, which it does sound terrible, I would highly suggest just hiding the PIP button for now.

2 Likes

I believe this might be an OS level issue, or something with the remote firmware.

The issue does not always occur, and I have noticed similar behavior in other apps, too. (For example, in Max, Peacock, Prime Video, and others, always while during playback.

I want to sort of wrap up this issue.

By Design

Currently, when the PIP button is focused, the timeline stays up until it's not focused anymore. This is to prevent the bad experience of the timeline disappearing right before you're about to click the button.

  1. This has fall out of course in that if it's focused, the timeline doesn't go away.
  2. This is made worse if you accidentally focus it and don't even know it.

Changes on our end with this

Nothing.

Changes to tvOS or Problems with the Siri Remote

It's possible something changed with the remote to be more sensitive. I would be willing to bet that everyone having this issue is using the original touch based Apple TV remote.

This remote has the absolute horrible side effects of the fact that the seek button is also the same button that allows you to move focus around the interface. Clicking the left and right side of the remote makes it INSANELY easy to accidentally move focus.

What we can do

There's not much we can do here to help prevent the focusing issues. This is just a badly designed remote. Every time you press to seek forward, you have the chance to shift focus. This is why I personally never used that remote, it feels awful. The updated Apple TV remote has a much better experience.

What we CAN do is stop the timeline from being sticky when the PIP button is focused. So we'll adjust it to be a longer timeout before it disappear, so it WILL eventually always disappear...and hopefully before you're about to select it.

1 Like

Actually, I'm using the aluminum remote. But whereas last week nearly every time I would seek forward the PIP button would end up focused, this week it has rarely happened. (Conversely, I rarely noticed a similar behavior in others before this past week, and now when trying to select a button during playback like the brief "Skip Intro" kind, that other elements would become focused instead of a single click being registered.)

It could be that my button precision varies wildly, but I'm more likely to believe this is an OS or remote issue, and not anything to do with Channels.

As of the latest TestFlight beta, the PIP button being focused no longer keeps the timeline open indefinitely.

2 Likes

Has anyone confirmed the latest beta fixes the issue? I tried it and for me when button is focused, it just flashes and the timeline never hides.

Welp, you're right. Sorry about this. We'll take a look at it next week and get it actually fixed.

2 Likes