Nagging on going PIP crash

Long time PIP bug when toggling PIP in apple tv app is driving me nuts. If i toggle pip i can get a scenario where i can only view the small window. When i toggle (either using the remote shortcut) or manually with the apple remote pip icon, i loose the full screen video and just have audio. If i toggle again, the video comes back in the small window.

During this process if i select a different station the app crashes

Just submitted diagnostics. This bug has been around for a long time. Any way to fix this once and for all. Im sick of not being able to use pip within channels reliably.


Please make a small video of the issue so we can see what's happening

Heres a shared dropbox link with small clip.

1 Like

This has recently started happening on one of my Apple TV 4Ks. Any solutions?

PIP support on Channels is generally quite poor to be honest - when I last posted about the issues I had people told me it was because I use a HomePod mini for audio..

Would be nice if the devs could put some proper time into R&D and fix this for good.

For me when the PIP modal opens the sound drops and I can't get it to come back unless I end the feed by startling a new channel several times over. If I disable PIP it works fine.

Annoying as PIP is such a useful / crucial feature but I have to disable it because of these issues

I have been using iProTv for several years now. I really dont use the built in pip in channels any more…

This started happening for me a few months back. I was hoping by now it would have been resolved as it never did this in the past.

Typically when I try and go to the guide and then I want to go back to full screen it will freeze and crash.

There is also another issues with the status not closing properly. If I fast foward it will bring up the timeline screen, and you can see that it tries to close it but it does not go away. I have to manually push the down button to get it to dissapere.


Just wondering if there has been any movement on this, seems like a bug that has been around for a while. I have submitted numerous logs, but I would be happy to submit more, it is a very repeatable problem on my end.

I wish this would get resolved. The weird thing is, it only happens on one of my ATVs. The other two behave normally. For now, I have turned off PIP until it gets fixed.

for me it happens on any of the tv's where I am using the Logitech Harmony remote.

Interesting… come to think of it, it’s the same for me. The one giving me trouble is the one controlled by a harmony remote.

I just induced it with a sofabaton remote. Not specific to harmony remote..

Does it happen in the On Now tab?

Just tried it and can verify it does the same thing on the “on now” tab.

It is finicky on all the tabs.

Sometimes it can work very reliably and toggle pip when navigating between the guide, library, on now, on later, etc just as expected. In fact I couldnt get it happening just now at all and I was excited. But I know Ive seen the issue as recently as today using the guide tab. In the meantime Ive been doing lots of things non channels related on my apple tv all day…

So to be thorough,

1: I went into the apple tv settings and did a soft restart.

2: Then I opened channels beta - observed “preparing your tv”

3: Then I went into the on now guide and selected a live station. Then I used the toggle pip shortcut on my sofabaton, and the issue presented itself again the first time i tried.

Way way back years ago you entertained the possibility of writing some diagnostic code to narrow this issue down. If I remember, I think you were seeing two back to back toggles which confused the code. I moved on and began using the iProTv app for my 99% of my pip needs so I never poked you and followed through.

It seems some other folks might be seeing this now.

Im happy to do further testing if you would like. Just let me know.

Please elaborate


I am using HDMI-CEC and the “toggle PIP” remote shortcut in the channels apple tv app.

Im using a Yamaha surround AV receiver with HDMI switching in between my apple TV and my Panasonic plasma TV.

Ive got the color buttons all mapped on both my sofabaton and my harmony 650 remote to the Yamaha receiver and have HDMI-CEC all working. Ive been using this setup for years.

Both toggle function remote shortcuts in the channels app are flaky for me and have been for a long time. Ive arranged other workarounds in my setup here and have been perfectly content.

The PIP toggle exhibits what others are seeing lately in this thread. The CC toggle shortcut has never reliably worked for me.

This morning I just bypassed my yamaha home theater receiver and fed the apple TV directly into my panasonic TV and duplicated the PIP toggle bug again to narrow things down.

The commonality seems to be using HDMI-CEC and the remote shortcut toggle functions in the channels apple tv app.

Check out these really old posts. Golly this goes back a couple of years, but I think you were seeing back to back commands, at least with the CC toggle function. My theory is that the same back to back commands might be confusing the PIP toggle function as well, causing the video to disappear. Or it could be a completely different issue causing this PIP toggle problem - but its pretty suspicious. Hope this isnt opening a can of worms for ya..

Does it happen with the API

POST /api/toggle_pip

Regarding the PIP, I just tried with the APi using an iOS shortcut. Initially it worked fantastic. Then to stress test the system, while I was toggling with the API I tried using the HDMI-CEC method using my sofabaton, and it immediately induced the loss of fullscreen. When I used the API after that to toggle back and forth, it was stuck in that flacky mode like in the video, never going fullscreen. Tried this on several of the tabs, including on now, library etc.

I tried to reproduce this again and restarted my apple TV, and i havent been able to reproduce the PIP toggle with either the API or the remote shortcut for now. . I have seen the toggle work with the remote in the past for quite a while before it gets hosed. I havent figured out the exact set of conditions to ALWAYS immediately get it to happen.

Im gonna guess that as long as the API is used it will never have a PIP toggle problem, but once it gets stuck in that mode - like I induced by using the other remote shortcut , the API cant get it out of flakiness without using the app switcher to close channels and resetting things.

I can confirm that I have used the API for the CC toggle using an ios shortcut on my apple watch complication reliably every day for two years and it has never failed once. That has been my workaround for CC, and as for PIP I just havent really been using it very often inside channels enough to bother me to use the API all the time.

Hope this helps…and have a great holiday!

Just to add some more context to this. Generally this always happens the first time you try and do anything after the tv has been on for a while. So I can pretty much garentee that if the tv has been on for a while that I can pick up the remote go to the guide screen, select a different channel, and when I press the button mapped to the pip it will crash and close the app without fail every single time.

Now after it crashes and I re-open it, everything works as expected without any probelms for a while. But if I watch a show for a half hour or an hour than the same behaviour returns.

Do you mean the apple TV?
What client are you using?