New Toggle CC still a bit buggy

I’ve created this new topic in the beta area after such an amazing quick response by @tmm1 to my feature request.

I’m soliciting more feedback from other beta testers on ATV that use the extra remote commands. So far it appears that one person @Fofer is having great success (yay!) but I am having no luck with the cc toggle, just a slight pause of the video.

My setup is ATV with Mac mini server running high Sierra.
I’m using a Yamaha home theater av receiver to send hdmi-cec commands to the Apple TV. Those have been working fine for months, as I’ve been using pip toggle and other commands with much success. Also have been using this with latest server pre release

I’ve tried assigning the cc toggle to different color buttons. I’ve also rebooted ATV and the server and even my router.
Also I’ve noticed an interaction with the release version of the app. If you assign the toggle cc button in the TestFlight release, the assignment also makes it into the release app, but of course the behavior is different when you use the button.

I only bring this up just in case the two apps may not be able to coexist on the Apple TV at the same time as far as this new cc toggle feature goes. Up till now I have found the beta and release apps have coexisted very nicely.

Anyone else out there have a chance to test this feature?

Submit diagnostics from the app after using the new shortcut

Hmm. Now you've got me curious. Does it work for you after a force-quit and relaunch of the app? Does it work after you first toggle PIP on and off? Awhile back, I had issues where channel surfing buttons would stop working but only after I toggled PIP, so I'm just guessing at possible explanations here.

FWIW I only have the TestFlight version installed. As a test you may want to remove the release version and see if it fixes the issue. You can always redownload the release version if it makes no difference.

Thanks for all the suggestions…

Does it work for you after a force-quit and relaunch of the app?

Nope. 1st thing I tried

Does it work after you first toggle PIP on and off?
Awhile backl I had issues where channel surfing buttons would stop working but only after I toggled PIP, so I'm just guessing at possible explanations here.


although as an aside, regarding the pip toggle, occasionally the app gets confused. This happens in both the beta app and release version @tmm1

When you toggle from small picture back to full screen only the audio works, but no video. Whatever menu you were on when going from small picture insert to full screen remains, but with the program audio only in the background. When you toggle back to pip the small pip insert video comes back. The only way to get out of this state is to do a force quit and relaunch of the app.

In fact when I was just double checking that a pip toggle could perhaps fix the cc toggle as you suggested @Fofer , I got this flaky pip behavior to occur and couldn’t get a full screen video of either a recording or a live channel. Interestingly enough I was able to get the cc toggle working when in pip mode in this stuck state.

So @tmm1 I’m going to submit two sets of diagnostics from the app.

1: after toggling CC several times during “normal” operation
2: after toggling PIP several times once in the “stuck” state.

Perhaps the two are related.

BTW. I haven’t been able to reliably reproduce the stuck PIP toggle, but I’ve noticed that it seems to be aggravated by first selecting some of the remote shortcut assignments

FWIW I only have the TestFlight version installed. As a test you may want to remove the release version and see if it fixes the issue. You can always redownload the release version if it makes no difference.

Tried this as well

Toggle PIP is not related to anything going on here.

I need you to go issue the Toggle CC shortcut, then go to Settings > Support > Submit Diagnostics

OK. Done. Submitted.

The toggle function is working as expected.

If the captions aren't appearing that's due to something else going on. If you toggle via the quick guide options menu at the top, the captions appear as expected?

Is there any change with Settings > Playback > Advanced > Video Driver: Experimental

If I manually use the top menu the setting works as expected and the captions appear when set to ON, and go away when set to OFF as expected.

If I use the channels API and toggle using an iOS Shortcut, the captions come and go as expected.

I also tried the experimental video driver as well - no luck.

Okay I understand.

It appears your remote is sending two commands back to back, so CC gets turned on and then immediately off again.

I’ve looked into this further on my end.
I’m using a Yamaha AVR-750 (a fairly recent model) home theater receiver.

I’m using the color buttons of the Yamaha receivers remote over HDMI-CEC to the Apple TV.

If the remote is sending a double command, than I think it is in Yamahas implementation on their remote. OR something is going on with the implementation of HDMI-CEC in my system.

Either way, is there any logic in your code when using a toggle (either cc or PIP) to let the input settle before “retoggling”.

If there is a race condition (two back to back toggles coming in too quickly) , this could also explain the PIP toggle confusing the app as well as I mentioned before.

Hey @tmm1

First of all thank you for looking into this and discovering the double command coming in.

I did some more troubleshooting to try and narrow down the back to back command issue with the CC toggle.

Yesterday I took my harmony remote out of the equation by using the Yamaha AV receiver OEM remote. With that remote I see exactly the same behavior.

Today I took the Yamaha av receiver completely out of the equation, by moving the Apple TV hdmi connection directly to my TV (a Panasonic plasma display) and enabling the Panasonic “vierra link” HDMI control of the TV.

Using this direct connection from the Apple TV to the Panasonic Tv, and using the Panasonic’s OEM remotes color buttons, I am seeing EXACTLY the same behavior with the CC toggle. The other remote shortcuts, assigned to the other color buttons of the Panasonic OEM remote work fine, although I did observe the annoying PIP toggle behavior as well.

So it looks like this back to back command is happening with several different manufacturers OEM remotes and two different HDMI-CEC setups - one from Yamaha and the other Panasonic.

The only other common thread I can think of is my Apple TV and the hdmi cable, so I swapped the hdmi cable to eliminate that as a possible source of weirdness. Same behavior.

I hope this helps in case you want to spend more time looking into this. I understand if you don’t if there are higher priorities..

Many Thanks

Thanks for the additional information.

This sounds familiar to some other reports where people are saying some commands come in twice, for example when pg up/down on the guide.

I will need to add a lot more diagnostics logging into the app, and then have you test and resubmit diagnostics so I can see exactly which code path is being triggered twice and add protection there.

Remind me again next week and I'll get a TestFlight build out with the extra logging.

Sure thing. Have a great weekend!

FWIW, just as a basis of comparison. The room I'm using the Harmony 650 in, has a Sony Bravia TV, and this new Toggle CC shortcut is working "as advertised.”

(My living room has a Samsung TV but is using a Harmony Companion w/hub, so handles CC toggling differently. No A/V receivers, I use Sonos for whole home audio, and the Phillips HDMI Hue Sync Box as an input switcher.)

Good luck, I hope you're able to get this resolved. Happy to offer any troubleshooting info I can, if it helps.

1 Like


Just a reminder that you mentioned to remind you this week that you were going to create a TestFlight build with some more data logging for the toggle CC.

From what I can see on the community board, you may be swamped, so there is no rush on this on my end.

Here to help out if and when you want to give it a go.
NFL redzone much more import!


1 Like


Hi Aman,

I wanted to share some further insight on the double cc toggle issue we discussed a few weeks back.

This morning I narrowed this down a bit more for you, so if you need to write some additional diagnostic code it might narrow down where to put the extra diag code.

I discovered that on my system the remote cc toggle shortcut works fine as long as I am not watching a recording or live video when I hit the toggle command.

If I initiate the toggle when in the guide, or on a shows info page (where the watch button is) the toggle works and when I start watching the live channel or recording the captions are toggled as expected.

For example, if I’m in the process of watching a recording and I want to toggle from no caption to captions by using the shortcut, I could hit the menu button , and now on the recording info page I could use the shortcut - and then hit watch and it would be toggled as expected.

So I’m assuming the double command (toggling twice) is not coming in during static pages, but only when video is playing.

I confirmed the same behavior by going to the guide and other “static” menus.

Hope this helps you narrow things down.

It also occurred to me that the double command may be coming in on other shortcuts as well but with a more benign affect.

For instance if Im watching a recording or live video and use a shortcut to jump to the guide, two consecutive commands would end up in the same place, and the user would never know anything was wrong.


Hi @tmm1

I was using the latest prerelease today and notice a few revisions ago you folks are using a new ios/tvos sdk.

This somehow prompted me to check out the toggle closed caption remote shortcut.

To my great surprise -

It is 98% working now. Something has definitely made things much better. Not sure if you found the double click bug, but it is toggling now most of the time. Sometimes i have to try a second or third time to get the toggle to happen, but something has definitely shifted.

Wanted to provide feedback.

Im stoked that i can use the toggle cc shortcut button now!




Well it worked for a few days but now isnt working at all. @tmm1