Occasional stutter during playback


#1

I’ve been noticing this for the last week or so - not sure if it just started then, or if I just finally noticed it.

When I’m watching shows I’ve recorded, occasionally I’ll get a slight stutter, with what appears to be a couple of dropped frames. It’s only a frame or two - but it’s there. I notice it maybe a few times every hour.

I thought it might be related to I/O on the NAS (like when recording two programs and watching a third), but I’ve also seen it happen when nothing is recording or processing, and the only thing happening is I’m watching a show. No other significant processes running on the NAS at the time.

Thought about a possible network issue, but it’s all wired between the NAS and the Apple TV.

I’m using a HDHR Connect. Typical bit rate for my recordings is around 12-15 Mbps.


#2

Was it a recording?


#3

An occasional frame stutter like that happens for me during times of very heavy traffic. It is rare though. My antenna is the best place I can get it. Thankfully, this usually only happens during a small portion of the day (about an hour) and not during the times of day when I am recording or have shows I regularly watch.


#4

If you rewind and replay the same segment, I assume the stutter is gone the second time?


#5

Yes.

Correct.

It occurred to me the issue could be on the client. So, tonight I watched an hour long show, and saw the frame drops. Then I restarted the Apple TV, and then watched two other shows all the way through (90 mins total). I think I noticed maybe one or two drops in the last 90 minutes - it’s quite a bit better than before.

Not sure how hard the channels app pushes the Apple TV - but if it’s resource intensive, then I can imagine the reboot helping…


#6

FYI, I’m noticing the frame drops again today. Tried restarting, still see then occasionally.


#7

I am seeing frame drops viewing recorded OTA shows thru AppleTV. Much more then a frame or two. Enough to be distracting. I haven’t noticed it when watching live television thru the same AppleTV.

It has happened for quite a while now.


#8

10 posts were split to a new topic: Glitches during recording in Windows DVR


#9

I’ve seen this too. Something is causing a CPU spike on the ATV. Will investigate on Monday.


#11

I don’t think it is the Channels software. I have watched multiple shows, mostly hour long recordings and with no frame drops at all. The only time I have seen anything similar was when I hadn’t yet fully optimized my antenna placement.


#12

I’m leaning toward something with Channels recording playback. I don’t notice the problem with live tv but it occurs regularly watching recordings.

For the devs, for live tv I watch without transcoding. Recorded shows are transcoded by extend using heavy setting. May or may not mean anything.


#13

Yeah, we’re seeing it too. Its on our radar. Thanks everyone!


#14

Not sure if this is a separate issue or not but I have noticed a similar problem recently with recordings. In my case my TV loses the HDMI connection all together for 2-3 seconds. It happens with both the release and beta of the AppleTV Channels app so I assumed it was an issue with the DVR running on my Synology NAS. If there is a frame drop I don’t see it as a result of the loss of HDMI which maybe causes a problem with my HDMI signal? Live viewing is not affected. Thanks for all of the great work!


#15

That sounds like a different issue… either with the HDMI cable or TV/ATV hardware.


#16

It only happened when viewing a recording via Channels DVR. Live viewing worked fine and no other Apple TV app caused it. I’m trying to replicate it now but it’s not cropping up. I suspect my NAS was up to something at that time which caused some kind of bandwidth issue. Apologies for the interruption!


#26

@tmm1, In your setup do you have both Win and Mac running DVR simultaneously? On different sub nets or what? Or close 1 to run on the other?

At times, when I am testing, I shut down my always on DVR on ancient mac mini to start up and do testing on iMac i-7. For the first time, I ran into a problem the other day doing this, as the db hadn’t updated for >12 hrs, hence on the i-7 when I loaded latest db, it wasn’t up to date.

As I now have a Surface Pro 3 (i7) I would like to test, I’m a bit hesitant with my prior procedure due to the attendant db updates.

Any suggestions? Please move accordingly, as I realize this is off the topic of this thread.


#27

I run multiple development DVRs (on windows, NAS, etc), but all have bonjour unchecked. Only accessed via IP.

Only main “production” DVR (on mac mini) has bonjour enabled.


#28

Thanks


#29

Is this still under investigation? I’m also seeing more audio drops over the last week than ever before.


#30

See Windows DVR BUG: Glitches during recording for the Windows-specific issue. In that case, the recorded file itself contains the disruptions.

If you’re not on windows and are seeing a similar issue, then try to rewind and play the same part of the video again and see if it still has the stutter. If so, then the issue was a network or antenna signal blip while the recording was happening. If you rewind and replay and it doesn’t stutter the second time, that means the bug is in the video player.

Narrowing down this to the DVR vs the player will help us figure out what’s causing it, so please leave a comment describing which behavior you see.