Permission denied when creating /media/DVR

Setting up a new RPi 4 DVR server and when I try to create the /media/DVR directory on the sever settings page I get the following:
Error: unable to create dvr directory: mkdir /media/DVR: permission denied

Any ideas on how to fix this?


What kind of drive did you flash the OS image onto?

Samsung 870 EVO SSD 1tb

I would suggest flashing it again

That fixed it. And now it shows 922.80 GB available and before it only showed 1.8 GB available. Not sure what happened the first time I flashed it but the second time fixed the issue.


1 Like

I'm having same error on an external WD elements 10TB. image procedure was wipe all partitions, use pi imager, flash image, hook to Pi. Boots, I get into DVR ui, and only a /media folder exists. I attemtp to create a DVR folder and I get:

unable to create dvr directory: mkdir /media/DVR: permission denied

Redid the same process over again and got the same result, not sure where to go from here. Enabling samba allows me to browse to the /media directory but I can't write/create anything in it via that way either.

Third time a charm .. only thing I did different this time was I logged into my channels account immediately on first boot. The previous two times I bypassed that screen as I was planning on doing a restore - I am not sure if some sort of additional setup happens by completing the login or not but in any event seems to be working now.

I am having this issue at the moment. Using a Samsung T7 Shield 1TB SSD. I have flashed it many times (8+) to no avail. I have also tried formatting the drive as exFat then flashing it using the Pi Imager.

Any ideas?

Try this image:

Bingo! That imaged worked!

Thanks, tmm1! You guys rock!

1 Like