Pi DVR: read-only filesystem

Hi everyone,

I'm having trouble with the Pi image and abruptly having permissions problems. I won't be able to ssh in until Sunday night, but am wondering if anyone has any suggestions as to what is going on.

The troubleshooting tab shows there are, in fact problems with permissions.

This started in the middle of the night -- something recorded fine late at night yesterday, and the first one was overnight at around 3 AM. I think maybe the software updated?

Last time this happened, I rebooted a few times and then somehow the entire volume was corrupted and couldn't even be fixed with fsck so I had to start over again.

What's the best way to fix permissions? Is there a way to do it from the web interface / API so I can do it remotely, and if not, what permissions should be set with chmod and for which folders?

(Of course it would be nice to know what happened here so it doesn't happen again!)


What kind of drive are you using?

One other person reported having problems like this and it went away after using a driver with its own dedicated power supply (or a powered USB hub).

It's also possible the filesystem could have gotten corrupted if there was sudden power loss.. did anything like that happen?

A handful of Pi users have reported something similar recently so I think there is a bug somewhere but I'm not quite sure yet. I also tried to add auto repair, but it seems the exfat fsck tool for linux is not quite functional yet. One user was able to attach the drive to a Windows machine and use chkdsk to repair the problem.

WD Elements, the same one recommended in the set up page, but 5 TB.

It happened spontaneously overnight, so the only thing I can think of is that it was during an update that was waiting for idle time to do it.

The last time I think this was the timing too, come to think of it.

I haven't gotten physical access to it yet so I haven't been able to see if there is even file system corruption, no less try fsck on a computer. Maybe just the permissions are messed up? What should they be -- I probably can start there.

I don't have ready access to a windows machine but I can borrow one if needed.

The guide seems to be updating and the Pluto docker seems to be running too by the way. I am able to watch stuff (at least the stuff I've tried) that is recorded remotely too. Just can't record anything or watch anything live.

Updating to the latest prerelease seems to work.

Also, no sudden power loss as far as I know.

Hoping it really just is permissions.

Update: before shutting down, over half of the TV and all of the Imports were missing from the directory, yet from the client, almost everything could still be played, even things that were missing. I was optimistic because of this.

I shut down, plugged the drive into a (virtual) windows machine and had it repair.

It took forever, and in the end nothing that was lost was found.

All of this reads like the drive is losing power or disconnecting while running. I had these same symptoms when running Channels on an different server, but with an external drive for recordings and a faulty USB port.

Were you a frequent user of remote transcoding?

I've uploaded a new OS beta v2021.0223.2002 (update by click-and-hold) which contains an updated exFAT driver. I believe we were hitting a bug in the older version of the driver which was causing the corruption.

This pre-release seems to have caused my pi to lose its drive.

148b0d9a-97d8-4604-ba23-ad4e69da87b8 submitted

phew. A 2nd reboot appears to have fixed this.

1 Like

Looks like it failed to mount but it's unclear why. I'm adding more diagnostics logging in case it happens again so we have better data next time.

No, never. I have gigabit up and down, and when accessing remotely always had original set.

Is there a way to do rsync to another external drive? having had this happen twice now, I'm a bit paranoid. I can initiate it over the network too but that would be slower, and I wouldn't mind doing a set of incremental backups since when this happens stuff "disappears."


You could enable SSH and then run rsync. I'll install it on the image.

rsync is available in the latest beta update (v2021.0224.1817)

Thank you!!!!

Just updated and 2021.02.24.1705 seems to be the latest?

Use the update button under the Operating System section.

Done. thanks!