Playback speed menu option disappears while being recorded

Hi guys and happy holidays.

It’s been an amazing year of updates…hat tip to you guys and if I could send more money your way, I would. Easily the most used app, across devices, in our home. Please add a tip option? :slight_smile:

On to the bug…

Begin recording a television show and start watching it on an Apple TV. The playback speed menu option isn’t available. If you open the same program while it’s being recorded on say an iPad, the playback speed option is there.

The playback speed menu option will appear after the recording is complete. It’s a subtle bug, but it’s maddening when you watch a lot of shows as they are being recorded on Apple TV and want to watch them at 1.5x speed while being recorded.

This option used to be there and disappeared a few months ago sometime. I chalked it up to a minor bug that will be fixed soon, but it hasn’t been and I haven’t seen any reports here highlighting it.

Steps to reproduce:

  1. Begin recording a television show.
  2. Open up the in-progress recording on an Apple TV.
  3. Observe that there’s no playback speed selector in the menu.
  4. Open up the in-progress recording on an iPad.
  5. Observe that there is a playback speed selector in the menu there.



1 Like

Speed controls aren’t available for live tv or recordings in progress. It has always been like this.

No it hasn’t.

For me, it used to have speed controls on currently recordings on seasons passes.

It even automatically changed to its configured speed during live playback after the recording finished in the background.

1 Like

None of this is true.

It did exist for live and in progress recordings, and this was a bug that was resolved. Because it eventually caught up to real time and can’t play at 1.5x and would cause an obvious huge issue.

However it worked, please consider adding back the “bug” where the speed changes to the setting on the server for the currently recording show once recording is finished while watching.

Basically, watching a currently recording show from the beginning at 1x speed then going to the set speed after recording is finished automatically while still watching.

That’s how it worked, now you have to get out of the stream and go back for the default speed to take place.


1 Like

It in fact, did not work. Once it caught up to live and tried to play faster than 1x the video player screwed up. This is why it was removed.

We're going to work on making it work for currently recording programs and live tv as well. I totally understand the need.

That may be, but then you're saying that it's a bug in iOS and iPadOS which currently do allow for this to happen. The behavior is inconsistent across devices.

As @AeroR1 said, I'd love to see this behavior's extremely useful when you want to view a live recording, but have to pause and are trying to catch up without missing anything. Yes, it becomes an issue when you've caught up to real-time, but it's still quite useful.

Please consider reverting the behavior to allow this to happen, even with the implications to catching up to real-time streaming. At the moment, people in my household have to revert to bringing Channels up on an iPad, Airplaying streams at 1.5x to an Apple TV until they catch up to real-time, and then opening the Channels app on the Apple TV. Convoluted, but it works.

TL;DR: suggest you either disable this across client devices (iOS/iPad/ATV) or (preferably) enable it across all, because this is an exceedingly useful feature for some of us.

This is a bug.

Like I said, we'll figure out a way to make it so it CAN work appropriately. I'm not sure what else I can say about this.

1 Like

Thanks, appreciate the clarity and direction.

Now...can you add a tipping option so I can throw more money your way??

This is a feature I've wanted for a while and finally decided to come here to see if it's been requested. I'm just curious about this post that says it would cause an obvious huge issue if you're watching in the buffer at faster than 1x and then catch up to live. I'm just curious why this is a huge issue? Wouldn't it just default to 1x at that point? That's the way TiVo handles it, but I realize your system with server/client is more complex. But it seems like it shouldn't be a difficult problem to solve. Am I wrong? If so, why?

1 Like


1 Like

I saw! Looking forward to seeing this when it's in the public release chain. Seems to work well on the beta.