Pluto for Channels

Interested in subtitles here…confirmed that I see it on the Pluto app

Channels gets them from the Pluto website. I’m guessing the web site does not provide them, or they are not provided in the format Channels needs them to be in. First step would be to see if there are captions available when watching Pluto in a web browser. If so, could see if the Devs could add support for them.

FYI: Via Pluto website and browser dev tools , I see the .ts stream available as something like:

And with CC on (in browser window), it looks like CC is transported to browser via a url like:

I don't know if Channels could "combine" these streams to get the CC working.

Looks like CC might be coming soon


I get CC when I use the official Pluto app on Android TV. Then again, I only watch 4-5 different stations.

The Channels Pluto grid interface with no subtitles is well worth the trade-off of using the nightmarish Pluto app interface. Google's Live TV app for Android TV works well and shows subtitles, never tried the built-in Shield timeshifting feature though.

I've created a non-Docker solution for the PlutoTV playlist.m3u that should work for people who can't (or do not want to) run Docker.
Please see: Non-Docker source for unique PlutoTV m3u playlist
Thank you.


When I update the Pluto for Channels Docker Container, it errors out on the first run.
To update, I stop and delete the container, delete the image and issue a run command to load the new one. Pretty sure it's happenned on every version since I started using it, just figured I'd report it. I haven't waited 3 hrs to see if it recovers, I just stop/start or restart the container and it works.

Here's the latest one from starting the v1.2.9 container

2021-10-22 01:59:05	stdout	[INFO] Grabbing EPG...
2021-10-22 01:59:05	stdout
2021-10-22 01:59:05	stdout
2021-10-22 01:59:05	stdout
2021-10-22 01:59:05	stdout
2021-10-22 01:59:10	stderr	(node:13) UnhandledPromiseRejectionWarning: Error: getaddrinfo EAI_AGAIN
2021-10-22 01:59:10	stderr	    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:60:26)
2021-10-22 01:59:10	stderr	(node:13) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
2021-10-22 01:59:10	stderr	(node:13) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
2021-10-22 01:59:14	stdout	
2021-10-22 01:59:14	stderr	mv: can't rename '*playlist.m3u': No such file or directory
2021-10-22 01:59:14	stderr	mv: can't rename '*epg.xml': No such file or directory
2021-10-22 01:59:14	stdout	Last ran: Thu Oct 21 18:59:14 PDT 2021

I run Pluto for Channels with Docker on my Synology NAS. I updated the container and now the channel numbers have all changed. Previously, all the Pluto channels were in the 9000s, but now they are in the 50s, 150s, 300s, 400s, 500s, and 600s. When they used to all be in the 9000s, it was nice since they were all grouped together in the guide. Now they are interspersed with my OTA channels. Is this a change on the Pluto side or did I do something wrong in updating the container?

Yes, @tmm1 mentioned this last week or so. With version 1.2.8 of the Pluto Docker, he added channel-number to the M3U.

If you go to your sources setting and change it so that Pluto's original channel numbers are ignored, then your own channel number assignments from before should return.

CleanShot 2021-10-26 at 12.51.39


Thanks! My feeble search before posting came up short. I have made the change and all is right in the world (or at least in my guide).

1 Like

Quick question for all you Pluto TV users. Do many of the Pluto stations just show a "Pluto TV" logo along with some floating yellow circles? It's as if the stations are offline. Many other stations work perfectly fine. Is this common?

1 Like

I just checked several channels at random and they all worked.
Which channels specifically are you seeing this on?
Do you see the same thing if you just go Pluto TV's website and watch there?

I see it when they are in a commercial break and the commercial(s) don't play. I'm sure it's completely automated, so consider those "glitches".

Getting duplicates of a channel using Pluto for Channels docker container as a source.

From container playlist

#EXTINF:0 channel-id="tv-land-drama-ptv1" channel-number="0"    tvc-guide-title="TV Land Drama" group-title="Entertainment", TV Land Drama
#EXTINF:0 channel-id="tv-land-drama"      channel-number="130"  tvc-guide-title="TV Land Drama" group-title="Entertainment", TV Land Drama

I have seen this before. Not truly duplicates. One channel is embedded and repeats a handful of episodes. The other has a broader selection of episodes. They got rid of a few of those embedded channels a while back. Looks like they are adding others.

In my case the schedule listings are identical for both channels.

1 Like

Maybe the docker should ignore channels with number set to zero.

Great, if that would solve it.
I do have Channels DVR set to ignore channel-number from M3U.
Both channels show the same schedule and play the same content.

Is there a video or step by step on installing and running this - especially on a QNAP or Synology NAS

My main problem is the kinda janky way that QNAP handles Docker containers I think

No need to horse around with Docker if you aren't comfortable with it. Details HERE.