Provider - DirecTV

You are an amazing help. That did get me the same error message as channels.

I spun up a virtual Ubuntu (with GUI), and tried an install there. And...everything worked.

So I went back to the debian. So it seemed to be a URL that was blocked, I looked at the firewall but didn't see anything. So I thought maybe it was the DNS server, which was pointing to Cloudflare ( I'm not sure if the DNS was blocking the stream URL...or not able to find it... so I switched it to Google (

And now....everything works. I'm not sure why worked all this time (ever since TVE launched on channels), and now started to fail. Or...maybe that's just a red herring to a different problem, and that different problem just got fixed when I redid the DNS. All I know is it is working now.

Glad you got it fixed. It could likely be a DNS caching issue, but perhaps that issue can be kicked down the road until it happens again.

Happy to help.

I am looking to confirm that A&E and Lifetime TV do not show up on my DirecTV TVE because it is a DirecTV account I am using?

A&E and Lifetime do not show up because they do not offer a live stream of linear programming. All A+E Networks channels only offer on-demand content via TV Everywhere.

Only networks that offer live streams of linear programming can be integrated into Channels.

1 Like

Thank you for the confirmation. Very much appreciated

There is some fancy things going on with discovery channels. I try to rescan and get

I couldn't record either and the error show up
2020/04/20 20:23:33.315404 [HLS] Couldn't generate stream playlist for ch6101-dANY-ip127.0.0.1: TVE: invalid character '<' looking for beginning of value

maybe you guys added some additional characters accidentaly inside the scripts ^^

Click Help > Submit Diagnostics. Which provider is this happening with?

I would say, some of the Discovery group - AHC,Science,Discovery,Animal PLanet from what I noticed

maybe it was some dns thing,however when I switch to VPN I get "no login form" error and in logs it is shown as:

2020/04/21 13:22:43.776402 [TVE] action=screenshot
2020/04/21 13:22:44.109459 [TVE] action=screenshot size=3249
2020/04/21 13:22:44.109726 [TVE] action=capture_html
2020/04/21 13:22:44.110672 [TVE] action=capture_html size=39
2020/04/21 13:22:44.110851 [TVE] action=script_error err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught", LineNumber:5, ColumnNumber:5, ScriptID:"3", URL:"", StackTrace:(*runtime.StackTrace)(0xc0002e1dc0), Exception:(*runtime.RemoteObject)(0xc0009c2120), ExecutionContextID:0} exp=&runtime.RemoteObject{Type:"string", Subtype:"", ClassName:"", Value:easyjson.RawMessage{0x22, 0x6e, 0x6f, 0x20, 0x6c, 0x6f, 0x67, 0x69, 0x6e, 0x20, 0x66, 0x6f, 0x72, 0x6d, 0x20, 0x66, 0x6f, 0x75, 0x6e, 0x64, 0x22}, UnserializableValue:"", Description:"", ObjectID:"", Preview:(*runtime.ObjectPreview)(nil), CustomPreview:(*runtime.CustomPreview)(nil)} exp_value="no login form found"

maybe those sites changed something on their backend and your chrome agent cannot detect.

Are you saying the error is occurring when you are trying to authenticate TVE sources from behind a VPN, but not when no VPN is used? If so, I don't think that's necessarily a bug, as geo-restricted services like TVE (US-only) aren't meant to operate properly for those behind VPNs.

That's why I am using smartDNS in my network, and the only channels that makes problem are from Discovery group. I wait then for my dns operator will say.

I am saying that I got different kind of errors on vpn and smartDNS

Not sure if this is affecting others, but authorizations for Discovery networks are not presently working. (I first noticed this 2 days ago, but still cannot login.) Previously authorized channels work fine, but when trying to reauthorize an expired token (either on-demand when tuning a channel, or when manually rescanning), Channels responds with chrome auth_timed_out.

This problem isn't just in Channels. Manually trying to access a channel in a web browser (ie, at the login fails, too. (The error is the same as shown in the tve_error_screenshot.png.) Just curious is others have noticed this recently, too.

What's the error shown?

I am using DirecTV and am not having issues with my Discovery networks just so you know.

That is also the same error message I get when I login from a private window in a browser.

I believe this happens when you use an email instead of your username (or vice versa).

This account never had a username, and all other TVE logins authenticate fine. (Even outside of Channels, such as through HBO Go, or the DirecTV app, the email is the login that works.)

(On an un-related note, is it possible to change the title of this thread to DirecTV? I was trying to find it by searching, and didn't find it at first because of the misspelling.)

Edit: I discovered the root cause of this. DirecTV expired my password, but didn't inform me. It was only by trying to login to their app, which informed me my password was expired and apparently only temporary. (I'm not sure how having the same password for over a decade is temporary, but AT&T, so …)

Okay I might be confusing this with a DISH issue then.

I also am having the same chrome auth time out error on discovery networks, using dtv seems to have just started. All other channels seem to be working fine. I am able stream from discovery go website in browser.

In case it helps anyone else, I figured out on mine what was happening. Apparently my dtv account password got changed so the old one wasn’t working. I deleted source and reset it up and now it works fine. What tipped me off was I went to dtv website and it said my account was locked so had to reset password again. Due to too many attempts with wrong password. In channels I didn’t get password error and other channels were still working. Go the chrome auth_timed_out error.

1 Like

Could you click Help > Submit Diagnostics on the dvr web UI