Provider - DirecTV

Please use this thread to discuss experiences and channel availability for Direct TV.

Current Status: All subscribed TVE channels work.

Select your provider here Channels Support - TV Everywhere Availability to see what channels might be available with Channels DVR TVE

DTV's TVE service appears to be having issues for some users today. Visiting a website like http://www.mtv.com/live-tv and using your DTV login is reporting "The system is currently unavailable. Please try again later."

I was trying out Food Network today and I can login at the food network website, but I don't see it show up in the list of channels found.

1 Like

Click the pencil icon under DTV, then Edit at the top right. Scroll down to FOOD and hit rescan

Showed up now. Was I doing it wrong?

Anyone else having trouble with setting up direct tv? We have a new direct tv account, and almost all channels say not authorized. Have to wait a while then can get some to authorize individually. Can log into roku apps etc with logins, go to website and never get a chance to put a password in just goes to signed in with direct tv, this is after clearing all passwords, history cookies etc, even in incognito mode. The. Nothing works because of course we never put any login info in. Talked to direct tv and of course they say it should be working
We have the choice package so should get a lot of channels. Have reset passwords etc still not working.

1 Like

Huh. Who is your internet provider?

Can you try with chrome incognito window?

Wave broadband is internet provider. Chrome incognito does the same thing, opens up like redirecting to provider then goes right back to site page like it’s logged in and says I don’t have access. Never gives option to put in password. If I click a different provider just to see what happens it opens a window to put in credentials. Maybe direct tv itself has an issue with logins.

Does clearing the cookies and cache in regular chrome clear everything that channels uses? Wonder if there’s a different cache I need to clear to get my other channels to authenticate

TVE was working for me but now many of the channels indicate "not supported". Not sure what changed. My subscriptions have not changed.

I’m having the same issue with some channels no longer working

I had to hook my server up via WiFi to my phone hotspot to authenticate, then after doing that, back to my cable internet. Tve Works fine till next time it needs to authenticate, at least so far. I have wave broadband for internet and something on their end is trying to auto log me in. I contacted wave and they opened a ticket but haven’t ever heard back. You might try that method to re authenticate to see if you’re having a similar problem.

I just recently been having issues with Discovery owned channels using (Discovery, Food, TLC, HGTV, Travel, Animal Planet, etc.) using DTV credentials on Channels. It is Giving: encountered exception ‘Uncaught’ (5:5). All other channels seem to work.

Anyone else seen this issue?

Not that particular issue. While trying to turn DIY recently the server kept telling the client it wasn't authorized; it wouldn't attempt to re-auth when it got the error. I manually rescanned the channel, and then the clients had no further problems.

What hardware are you running the server on, and what is the server's version? Have you updated recently?

Thanks for your reply.

Here is a snippit from my home server setup, which has been working great:
home_server

I am running version 2020.01.19.2104 which I believe is the latest version. The error image it gives me is:

image

That is the latest beta.

Is this system a headless server? Or can you log in to a desktop? Or SSH in with X forwarding? If so, I would recommend running Chrome/Chromium on your DVR server and attempting to view the streams directly from the websites. That would be the most likely next step in troubleshooting.

It is a headless server. i have my windows desktop, and I am able to open chrome and go the food network webpage, authenticate with my DTV credentials, and the live stream starts through chrome. So I know my creds do work with chrome on the live streams for the Discovery networks. I also know they work on the apps themselves, because I set my wife up with all the Discovery GO apps on fire and ATV for the meantime so she can watch her shows.

The debian server has no GUI, it is all cli. So not sure I can watch live streams on it.

If you can watch TVE streams through your server, Chrome or Chromium must be installed. I believe the pre-reqs for installation include X.org. However, if all you have is a Windows desktop, I'm not sure how you'd go about running X on Windows. (I know there are ways, because I've done it in the past.)

The problem with checking from Chrome running on your Windows install is that it is totally different than the Chrome running on your Linux server that actually connects to and receives the TVE streams.

As I said, getting a connection and testing from the server's Chrome installation is the obvious next step in troubleshooting.

I have a linux laptop and linux virtual machine. I can try running X through them.

Perhaps it is a bug in Linux chrome that just hates Discovery owned networks (as all other streams work). I can also try to setup channels on a different machine and see if I still get issues.

Use -X (or -Y) when you SSH in:

ssh -Y [email protected] google-chrome

That ought to give you Chrome running on your Debian server host, but displayed on your laptop.