QNAP Install issues


#21

I wonder if I need to open a port on the NAS…


#22

Opening ports is not required when you’re on the same network.

Can you check the ATV settings to see what IP is assigned to the apple tv?

With the Channels app open on the ATV, visit the web UI for DVR and uncheck the box, wait a few seconds, and check it again. That should make the DVR tabs show up on the ATV.


#23

Tried that no luck. AppleTV is 10.0.1.2. The HDHomerun is 10.0.1.25 just for record. Unclicked the DVR tab and reclicked and still just see “On Now”, “Guide” and “Settings”.

However, scheduling several shows to record via the web interface to the QNAP did work and I have one recording completed although no way to play it yet.


#24

Ok, just to confirm is the version of Channels on your Apple TV 2.1.6?

Can you ssh to your NAS and ping the apple tv’s IP from there?


#25

Downloaded PuTTY and SSH’d to my QNAP (10.0.1.24), logged in. ping 10.0.1.2 (appleTV) and it did ping.

[~] # ping 10.0.1.2
PING 10.0.1.2 (10.0.1.2): 56 data bytes
64 bytes from 10.0.1.2: icmp_seq=0 ttl=64 time=3.0 ms
64 bytes from 10.0.1.2: icmp_seq=1 ttl=64 time=0.9 ms
64 bytes from 10.0.1.2: icmp_seq=2 ttl=64 time=0.7 ms
64 bytes from 10.0.1.2: icmp_seq=3 ttl=64 time=0.7 ms

Confirmed in Channels Settings that I’m version 2.1.6


#26

Real head scratcher.

Do you have an iOS device. Can you try a free app like Discovery or Flame which scans your network for bonjour services, and see if it lists _channels_dvr as running on your NAS’s ip?

The ATV uses bonjour to find the ip of your DVR instance, but for some reason on your network it’s not able to see the bonjour records.


#27

You could try rebooting the ATV, which people are saying helps in Can't find DVR setup


#28

OK Interesting. Running Flame on my iPhone on the same network does NOT show a bonjour service on the QNAP. There are several others, but not that one. I’ll look more into the QNAP for why.

OK in Channels app on QNAP, I unchecked and rechecked the Bonjour service again, and this time it appeared on Flame. Checked on AppleTV and … nothing.

Rebooted app on appleTV and the bonjour service that was showing in Flame disappeared.

So, I quit the app on appletv, re-unchecked/rechecked the Bonjour service on QNAP (it did show back up in Flame), then started Channels again: Nothing. But the service seems to be still running on flame. The AppleTV can’t see anything.

Tried to reboot appletv again: sometime while rebooting appleTV the service disappeared from Flame. So before launching channels I unchecked/rechecked bonjour again in QNAP. It showed up in Flame again so then I launched app and: A DVR TAB!

Will see if it sticks around.


#29

Thanks for the detailed write up. I will run some tests with my QNAP and see if I can reproduce the problem.


#30

So while it was working I was able to play the one show that recorded. When I got home from work today, Channels was back to just On Now, Guide, Settings. No DVR anything. Checking Flame showed that the service had disappeared again.


#31

Can you upgrade to 2.1.7 from the App Store and see if that helps. It should stop losing the DVR tabs once they show up.


#32

Found a “log” button right in ChannelsQNAP, I see some errors like this.

2017/01/13 18:19:59 [IDX] Finished pruning 73 airings.
2017/01/13 18:19:59 [SYS] Created database snapshot: backup-20170113.181959
2017/01/13 18:28:50 [ERR] bonjour: Failed to bind to udp6 port: listen udp6 [ff02::]:5353: socket: address family not supported by protocol
2017/01/13 18:28:50 [SYS] Bonjour service running for dvr-nas021a1a.local. [10.0.1.24]


#33

OK I checked and I do have 2.1.7

So, it seems likely something on the QNAP is causing the service to stop broadcasting - no idea why. Uncheck/Recheck of the Bonjour option on ChannelsQNAP and it immediately reappeared on Flame, BUT the AppleTV Channels still couldn’t see the service (just like last time).

Reset the AppleTV, launched ChannelsATV and still NO DVR tab. So it’s like it was before. Not sure what the magic sequence is.

Is there any other useful log I can provide?


#34

I tried to move some of your older comments to this thread, but it didn’t quite work as expected.

I’m seeing the same behavior with my mac and QNAP as well. Nothing shows in the Flame or Discovery app about the DVR until I uncheck/check the box.

I’m not sure why this happens, but it’s considered normal behavior and should not affect you being able to access the DVR from the Apple TV. The bonjour discovery is only used once upfront to find the DVR, after which the Apple TV remembers where the DVR is and so it doesn’t matter if the bonjour broadcast stops.

What version of the ATV app are you currently running? Do you have any beta versions installed?


#35

I have the newest version of ATV app and also have a TestFlight version installed as well. I noticed my QNAP changed IP addresses, so I just set it up with Static IP based on MAC address. I’ll try the dance of shutting everything down/restarting everything to see if I can get the DVR tab to appear again and then see if it stays even after the bonjour stops broadcasting.


#36

Cool, hopefully you can coax the ATV into finding the DVR and then it will stick around.

If you’re having issues still, try with the testflight app and then go to the bottom of the Settings tab and click Submit Diagnostics.


#37

Is there some preferences file I can edit to just manually hack in the ip address/name of where server is?

Actually I guess it would have to be on the ATV side not the QNAP side I guess that wouldn’t work.


#38

No luck huh? Did you submit diagnostics so I can take a look?

I can see about adding an option somewhere in the app so you can enter the ip address manually…


#39

Can the devices be configured with static addresses? or at least with static reservations on the DHCP server/router so that their IP addresses don’t change… (while you are at it, also set static reservations for the tuners as well; the consumer SD units cannot have a regular static address).

What is the lease time set for the existing DHCP pool? Could the qnap be renewing too often or releasing the bindings on renewals? [there was an issue with a much older qnap firmware that had the qnap drop NFS shares upon a dhcp renewal intemittably… but that was fixed ages ago


#40

I found a serious issue with the bonjour implementation that was the cause of things not showing up in Flame and other bonjour browsers. This issue has been fixed in the upcoming 2017.01.25.0359 release.