QNAP Install issues


#1

OK, so I couldn’t get the DVR working as per my previous post. Bonjour services stopped running.

So I had time to try again, and I couldn’t even connect to the service when I clicked on channels DVR. So then I noticed there is a 1.03 version.

I tried to install it and it hangs on 45% and says it can’t install. I uninstalled the 1.02 version, and tried again to install 1.03 - hangs at 45%.

So then I tried to install 1.02 again, and it still hangs at 45%.

So now I can’t install it at all. I’m assuming this is more a QNAP problem than a channels problem, but I’m hoping someone can help!


Channels for Apple TVOS. How do you record a show via the guide?
#2

Also, the error in the system event log of the QNAP is:

Type Date Time Users Source IP Computer name Content

Error 2017/01/22 20:10:29 System 127.0.0.1 localhost ChannelsDVR 1.0.3 installation failed. Failed to run setup.sh


#3

The installation downloads the latest version from the internet. Sounds like something wonky is going on with your home network. What kind of router are you using?

See if you can ping google from the NAS after ssh-ing in.


#4

I downloaded the 1.3 qpkg and installed it manually using the QNAP app center. Where is the proper install procedure?


#5

That’s correct. That qpkg runs its own installer, which happens when you see it waiting at 45%


#6

OK getting putty to SSH in.

Once in, I can ping google no problem.

My router is just a standard netgear router. This did work to have version 1.2 installed previously so I’m not sure what has changed.


#7

Try uninstalling the DVR, reboot NAS and reinstall maybe?


#8

Yeah already tried, but when I try to re-install (whether 1.2 or 1.3) I just get the error in system log:

Type Date Time Users Source IP Computer name Content

Error 2017/01/22 20:47:47 System 127.0.0.1 localhost ChannelsDVR 1.0.3 installation failed. Failed to run setup.sh

I’ve rebooted a few times and right now as far as I can tell there is no channels installed.


#9

Which folder is channels installed in? Perhaps I can delete it from the SSH?


#10

/share/CACHEDEV1_DATA/.qpkg/ChannelsDVR/


#11

OK, using PuTTy, I went to the folder you specified and did rm -rf ChannelsDVR. It worked and the folder was completely gone, this should remove all trace of ChannelsDVR from the QNAP, correct?

I tried again from app center to run the .qpkg for 1.3 and it again got stuck at 45%…and then finished installing successfully. Trying to see if it works now.


#12

OK it worked for awhile, but now I’m having the same problem as before. After some amount of time, the QNAP ChannelsDVR app stops broadcasting on bonjour (according to the Flame app).

Even if I uncheck and recheck the “broadcast on bonjour” setting, it will appear on Flame but NOT appear on the AppleTV again, which has forgotten that it had the DVR tabs displayed. Even quitting the app and restarting it doesn’t make the tab come back.

Nothing seems to get the DVR tab back, including unchecking bonjour, unplugging appletv, starting bonjour, replugging appletv, killing app and starting app or any combination.

The only way I’ve ever had the DVR tab appear more than once is to completely uninstall channelsDVR from the QNAP.

Any ideas to improve?


#13

I have the regular app, and I have the service setup on my qnap, but the appletv app just looks the same as always. I reset the app, and then redownloaded the app but if I have DVR features I can’t tell. Yes I subscribed :slight_smile:


#14

OK Unchecked and rechecked Bonjour tab on the QNAP client.
Under it it says “Advertising dvr-nas021a1a.local. via [10.0.1.24]”

I also chose a location for files to go under the DVR check box (in the QNAP) client and then checked the DVR check box.

On the AppleTV still no DVR tab or any indication of anything related to a DVR. I Just “On Now, Guide, Settings” (I assume that is where the DVR tab would go)


#15

A ha! I noticed on the QNAP client that I had to set my zip code and OTA preferences. I did that and more showed up on the QNAP. Let me check that out.


#16

Ohhhh recordings are set through the QNAP application at a computer, not on the AppleTV. I have now set several shows to record. I assume once they are recorded something will pop up on the appletv app allowing me to play them.

Sorry I didn’t see a manual anywhere explaining how this works (I’m sure it’s right in front of me somewhere)


#17

This is false. The Apple TV app has full DVR features that let you search for shows and record shows in progress and at a later date through the guide, as well as manage your passes and recording schedule.

There seems to be an issue with your Apple TV seeing the DVR server. Do you see a single DVR tab in Channels?


#18

Nothing that says DVR anywhere on the AppleTV interface at this time.


#19

Is this the correct ip for your NAS?


#20

Yes that is correct, 10.0.1.24