Recording while watching causes glitches on recorded file


#1

I’ve been experiencing a weird bug lately. I’m often recoding shows for me that my wife watches live while they are recording. So when I get home to watch these shows, I’m getting random glitches where the video and audio will cut and pixelate. After a few seconds of choppiness, the audio will come back while the video still is pixelated. When the video comes back clean, it will be offset compared to the audio and the video will play in fast motion to catch up with the sound. The whole process can last from 30 seconds to 1 minute before the video and audio are back in sync and clean.

And when I ask my wife, she did not get the same glitches while watching the show live.

I tried to play the affected files on my iMac with VLC and I get the same glitches.

The bug seems to happen on any channels, even the ones with the strongest signal.

I’m pretty sure it has to do with recording while watching but I’m not 100% sure. Might also be recording while watching a different channel.

Hardware : HDHR Extend and Mini Beelink PC running WIn10 and the Channels DVR backend. Recording to external USB3 hard-drive.

Any input would be appreciated.

I can provide a short clip to show the bug in action. Dropbox maybe?


#2

Did you disable Ethernet flow control already? If you right click the DVR in the system tray does it show a “fix Ethernet Settings” option?


#3

Almost certainly network related.

My DVR back end runs on my MBP over 5G wifi. If for some reason the wifi drops downs to 2.4, I will see this randomly.


#4

I will check on these settings when I get home tonight.

Might be network related, but I’m all hardwired, nothing in the DVR setup is on WIFI.

However, I do get slow transferring rates between my mini PC and my iMac. Both of which are hardwired as well.

My router is a Apple AirPort Extreme latest generation. Being in the basement, I ran a Cat5 cable from the router to a small 10/100 switch next to my HDHR, Mini PC and Apple TV in the living room. It all seems legit to me.


#5

I checked and the “Fix ethernet settings” what present. I clicked it, I was prompted with a windows security thing and nothing (seemed to) happened after that. Now the option is greyed out.

What is it supposed to do?


#6

It disables flow control on the Ethernet adapter, which causes the issue you described.

If should be fixed now.


#7

Is it possible to disable this feature on a mac too? I’m not having the exact same issue, but lately I’m having serious problems streaming remotely without tons of buffering.


#8

This problem is specific to Windows and does not affect the Mac.

If you’re having issues streaming remotely, its likely due to bandwidth available on both sides. You can visit my.channelsdvr.net/speedtest to run a site-to-site speed test, and set your streaming quality in the app accordingly.


#9

Ok thank you. The issue is I’ve been able to stream with this setup with no problems until the last week. Even when I drop quality down it still happens. I’ll try the speed test and see if I can uncover anything.


#10

So, I recorded a show tonight and the issue remains.

BUT, I wasn’t watching the show live as it was recording. Si my whole point does not apply anymore.

I was, on the other hand, watching a previously recorded show while my new show was recording. ç

HDHR and Windows mini PC are both hard wired In the same lan switch. Don’t know how can it be networked related…


#11

you could try measuring the speed of file transfers on your LAN through the switch. Also could check the throughput on the HDHR admin page. Network issues can be tricky sometimes to pinpoint, but you won’t know if it is the switch or the windows network settings or the hdhr until you test it out a bit.


#12

I ordered a new gigabit switch yesterday. Should get it today. Perhaps my 10/100 wasn’t fast enough to cope with demand when trying to record and watch at the same time. The Apple TV and DVR mini PC being both plugged in the said switch.

Will report back later.


#13

Actually, I have the exact problem, using my Mac as the backend. We’re watching the olympics, and every 20 minutes or so, we get a fifteen second slot of massive pixelation, screeching sound, followed by rushed visuals, until everything catches up again. Everything is hard-wired using CAT6 cables and FIOS. If there’s anything we can do to fix this before the olympics end, we’d be much obliged. Thank you!


#14

Is everything wired into the same switch/router?

You could try going into your mac’s ethernet settings and turn off flow control.

I actually had something similar happen last week when I tried to chain my ATV4’s ethernet via my new Sonos playbar. I think the playbar only has 100mbps and not gigabit, and it started causing problems.


#15

Just a heads up. I have installed the new gigabit switch earlier over the week-end. So far so good, I haven’t watched a whole lot of recorded shows yet but it seems to be better now. Also, transfer rate between my iMac and the PC are a lot faster now.

Hopefully it will be ok. Will report back if the issue comes back


#16

Thanks for the thought! I’ll try that and will let you know.


#17

Would you mind explaining how to turn of flow control on a Mac? I am experiencing exactly the same issue and would like to try this. Thanks!


#18

Out of curiosity, has your switch resolved the issue?


#19

It’s under network preferences, if you click advanced and then switch to the last tab.


#20

Got it. I missed it before because I had it set to configure automatically. Thanks for helping out. Hopefully this does the trick!