Remote access headache

Hi all,

I'm a bit of a noob to this so I'll try and explain as much as I can.

Downloaded Channels yesterday and activated a trial DVR subscription. Really like what I see and it's a joy to use in macOS.

The main reason for giving this a go is to be able to remotely access recordings and to be able to set recordings when I'm away from home. Everything works perfectly when I'm on wifi but as soon as I try it remotely using the iOS app on my iPhone or iPad on a 4G connection I get the following message:
Your Channels DVR Server at home can not be reached.
Remote Access is enabled, but we can not reach your server. Please ensure that port 8089 has been properly forwarded from your router to the IP address of the computer you installed Channels DVR Server on.

I have spent the last few hours stuck in a Google hole looking for answers as well as going through every setting on my Apple router to ensure that port forwarding has been properly configured. I've tried what feels like 100's of different settings.

Port 8089 is open, automatic port forward in the Channels DVR page in on and I've set a rule for port forwarding in the router settings.

For reference these are the last few entries in the log:
2020/02/14 11:01:07.476388 [NAT] Successfully mapped port 8089 using natpmp
2020/02/14 11:01:07.636782 [SYS] Created database snapshot: backup-20200214.110107
2020/02/14 11:01:07.637017 [SYS] Removing old backup backup-20191106.131055
2020/02/14 11:01:08.165798 [SYS] Bonjour service registered with Neils-iMac.local
2020/02/14 11:01:17.738657 [IDX] Pruned 79 expired airings from GBR-1001670-DEFAULT in 108.570472ms.
2020/02/14 11:04:56.334816 [NAT] Successfully mapped port 8089 using natpmp

Any help would be appreciated as I've given myself a headache.


I can't help too much here, but you can try the troubleshooting tool to see if that brings up any issues. See below

Thanks for that. Definitely looks like I have set up the port mapping incorrectly.

Anyone with an experience of Apple Airport know the correct info to put in the boxes below?

I'm being driven crazy!


Use one or the other, but not both. For best results, a manual port forward on your router is best. When doing so, set the Channels server to "Manual".

UPnP and NAT-PMP are horrible protocols with poor and quite varied implementations. When they work properly—however rarely that may be—it can be nice. But since it is so rare that those protocols work well without issues, you're probably better off sticking to manual configuration.

Private TCP and Public TCP ports should both be 8089

Still nothing!

I have set the DVR Config page to "manual" and in the router settings both Public and Private ports are set to 8089. 09

I've even rebooted everything just in case.

I'm absolutely stumped now.

I'm guessing you have another router connected to your Airport. Who is your ISP and what kind of equipment did they give you?

You’ll also want to set whatever device is hosting the DVR with a static IP address. If it uses a dynamic IP address
It will eventually change and then remote access will break!

I'm with Virgin Media in the UK.

My main router is an Apple Time Capsule connected to a Virgin Media Superhub (not sure which model) which is in Bridge mode. The HDHR Quatro is connected to a Airport Express in the lounge which is joined to the network.

I have also set up a static IP for the iMac hosting the DVR.

Everything I try just seems to give me the same result.

Can you screenshot the Virgin Superhub settings where it shows it is in bridge mode? What IP do you use to access the superhub settings?

What IP Address does the Apple Time Capsule report?

Hopefully this will make some sense to you.

The is the HDHR and the MAC address relates to a Humax DVR sitting on the network.

The Virgin Media Superhub is a 3.0 model.

It is actually called Modem mode, not Bridge mode. It is it just handling the connection and the Time Capsule is connected to it by ethernet.

To access the settings in Modem mode the IP is

I can't access the settings at the moment as it appears that my modem is one of a batch that were sent out with an incorrect password to access to settings printed on the bottom. They are emailing me the correct one shortly.

It looks like your port-forwarding is working fine. If you go to does it show 8089 as open?

Are you running any VPN client on your Mac which runs the DVR?

The DVR is just running natively in Safari. No VPN or anything special.

And port 8089 is open.

I'm at an absolutely loss.

Please open

I'm not sure what you just did but that has done it.

I can't thank you enough!

Thank you!!!!