Remote shortcuts

I see remote shortcuts as an option in the settings of the beta. Is there a way to enable button mapper in firetv yet. Or will remote shortcuts ever be available on fireTV devices.

Yes it's available in the beta

I'm running beta 8.23.2012 on fs4k and firecube. using the sofabaton with the red green yellow and blue buttons assigned to f1 f2 f3 f4. The p for pip c for cc and record for record screen are working fine but the f1-f4 do not respond. I have this same setup on 2 androidTV boxes and the ts4k and they all work fine with channels button mapper on. Do I need to turn on the button mapper in the firetv devices somehow?

I see what you mean. FireOS doesn't have the accessibility settings menu. There may be some way to enable this via adb. I will have to do some research.

Do the f1-f4 work while inside the app?

Something like this may work:

adb shell settings put secure enabled_accessibility_services

No f1-f4 do not work on my fs4k's or firecubes. Tried with sofabaton, flirc, and keyboarb. Like I said the p, c, and record commands work fine in the app. I will try the adb later today when I'm at a computer and let you know. Will the adb need to be done after each reboot. Thanks

Hm, if the keys don't work at all then that's not a good sign. Could be that FireOS is ignoring those or using them or something internally.

The adb command only needs to be run once.

Never mind this is incorrect. The app has a bug causing the buttons not to work inside the app.

I tried this and it doesn't look like it is going to work. FireOS uses its own accessibility service which doesn't support extensions.

Does this mean that the shortcuts/buttons will work within the Channels app, but not globally throughout FireOS (meaning, when Channels is not the active app)?

Correct, once the bug preventing the former is fixed. The latter seems to not be possible on FireOS.

In the latest beta you should be able to use F1-F4 while inside the channels app.

They work until you go into the player (live tv or recording) then do not work until you exit the player. Thanks for the fast work.

I noticed that was watching LiveTV wanted to go to the Guide on my FireTV but it does not work.... They work while not watching LiveTV.

Fixed in new build now uploading

1 Like

Working thanks.

Working great thanks