Shake to mute issue?


#1

I’ve been noticing an issue with the shake to mute feature and I wondered if it was a bug or if it’s something I’m doing wrong.

I have two ATVs (one 4K, one 4G–both on 11.4.x) that are now exhibiting the same issue. It will usually happen when content is time shifted and I’ll either mute on purpose, or by an accidental shake of the remote. I will be able to shake the remote to unmute and the sound won’t return. Another shake will mute (on screen indicator) and yet another shake will unmute (indicator will disappear), but no sound can be heard. At some point, the shaking will not unmute (on screen indicator remains) and I will have to close the app and restart it.

At this point, I will just turn down the volume to be able to time shift content and still be able to hear it. Does anyone know if this is a known feature? Is there something that I can do (reinstall, power cycle, etc.) to avoid it from happening? Thanks!


#2

Seriously? I’M the only one that has this issue? I find that really hard to believe when I see it on different ATVs.


#3

I’ve seen this too. Will take a look this week.


#4

As a workaround you can swipe down and manually select the audio track to re-enable it.

I did some testing and wasn’t able to reproduce while watching a recording, so need to test some more to figure out exactly when it happens.


#5

Actually it’s not happening for me for a recording–I don’t have your DVR. This is for LIVE TV that is being time shifted.


#6

Okay I will test with live TV, maybe it’s specific to something there.

Does it happen every single time you shake to mute, or is it random?


#7

Seems pretty random, but it’s been happening more and more of late. I’ll try to pinpoint the behavior to help you find the root cause.

As I recall though, it usually happens when I have close to 30 minutes or more of shifted content. When I mute–either on purpose or accident–the behavior detailed above happens.


#8

Okay, good to know. Also try that workaround next time. It will be useful to know if that works or not.


#9

Still happening. Any progress on a root cause?


#10

Does selecting the audio track from the language settings (swipe down in player) fix the issue?


#11

I have not been successful with that workaround. Like I mentioned before, at one point the on-screen indicator will freeze as muted and the app doesn’t respond to remote interactions after that.


#12

Update: I was recently able to correct the issue on one of my ATVs by selecting the voice track in the language settings from the dropdown. However I haven’t been able to recreate the app lockup yet to try that method. I’m thinking that, unless the issue was somehow corrected in recent updates, that workaround won’t work because the app becomes unresponsive.

Hope this helps.


#13

Can anyone provide a status update on a bug fix for this issue? It's still happening. I haven't had the app crash on me in awhile, but this is still annoying as hell to have to select and then reselect an audio track multiple times while watching a program.


#14

Could you please go to the bottom of the Settings tab and click Submit Diagnostics the next time this happens?


#15

Update: it continues to happen occasionally. When it does and it's not in the middle of something we're watching, I submitted diagnostics--about three times as I recall.

I've found that selecting the English audio track now consistently fixes the issue. I just wish it would stop happening. The app lockup hasn't happened since the last time I posted.


#16

What is your hdhomerun device id?


#17

Mute shaking does not work for me either. Apple TV 4K


#18

Shake to mute has to be enabled on the settings tab of the app.