Small but persistent bugs


#1

My family and I love the DVR and use the remote functionality a good bit, the server is setup at a vacation house (only place we had a fiber option) with my house and my parents accessing remotely. For about 6 months now, ever since the home and away from home sign in was implemented we have had persistent "no tuner available" errors.

These are false errors, they actually occur because the client (apple tv) has lost its connection to the remote dvr. Before the change the app wouldn't show any channels if the connection was lost, and there was a "reconnect" option under the settings tab. The previous version worked great, and the only time I recall having any issues was when a local tuner was also present (in that case it would occasionally grab the local tuner first and not attempt to connect to the remote dvr). The way things are done now we experience this error on a day to day basis, even when the local tuner is removed from the equation.

I have tried switching each Apple TV to the Channels DVR app which seems to fix the false "no tuner" error but also introduces problems of its own. The DVR app seems to either establish a connection or it doesn't. What I mean by this is that if the app is forced closed or closed by the system as a background process it will bring up the white connection screen, from there it will either connect and kick over to the settings page or it will ask to "try again".

There are a few issues here, first I would like to see the app have a loading page for a second or two while establishing a connection instead of bringing up the sign in screen. The app should also default to on now or guide when it has been re-launched, instead it defaults to settings because it is coming from the sign-in page. Another issue is that on occasion is doesn't establish a connection and the "try again" option doesn't work, in this case I will force close and re-open which almost always works (but most of the family have to be reminded to try this when an error occurs).

One last thing I would like to mention when it comes to the initial sign in page is the highlight color. Everyone is my family agrees that the purple color is intuitively the highlighted item, having the white icon on a white page be the highlight color is very confusing. I understand the white color is the highlight color throughout the app, but the rest of the app also has a purple background, in this case it should be reversed.

Hopefully this can be easily fixed and a loading screen can be implemented to make launching the app a seamless experience. A setting for default launch page would be a welcome addition as well for when the app has been closed as a background process by the system or user.


#2

Should I submit diagnostics or are y'all aware of what is causing it?


#3

You have an HDHR at the remote location too, is that right? I think that's the source of most of these bugs. We have some logs from before but it wasn't 100% clear what's going on, and we need to replicate a similar setup to be able to debug.


#4

No, this is happening with remote DVR only. The older version of the app that didn't ask for home/away an included a reconnect option never gave false "tuner not available" errors, from my experience it never had an issue connecting either (unless a local tuner was involved).

Old Version:

  • No connection issues with remote dvr
  • If a local tuner was present the local channels would not populate on occasion

New Version:

  • Channels populate but sometimes a connection isn't established, there is not indication of this until you get "no tuner" error (with and without a local tuner present)
  • Briefly shows the white sign in screen and kicks to settings page on a fresh launch
  • When it does connect on launch it opens to the "on now" page, this is always blank. Populates immediately when switching to another tab.

Basically one of 3 things happens...

  • The app is in the background and reopens to the previous page and works fine
  • The app is in the background and reopens to the previous page and displays "no tuner" when a channel is selected (has lost connection)
  • The app has been stopped by the system or user as a background process, quickly shows the white connection screen then kicks to the settings tab, from there it works fine.

#5

Thanks for the summary, that very helpful.

Can you submit diagnostics after seeing the tuner not available error


#6

Submitted two logs of the same issue. I also ran into a situation where all I did was press the home button from the guide and clicked on channels again, from there it presented me with the connection screen and a "retry" option that didn't work, I couldn't submit diagnostics without getting into the settings and I had to force close to correct the issue (I assume diagnostics wouldn't help because of the force close).

Another small issue is that when the app shows the white connection screen and then kicks over to the settings page, it shows the top menu bar with "settings" highlighted, but swiping left ALWAYS moves down to the tuner selection. I have tried this multiple times making sure to swipe directly left and even slightly up and to the left and it will always go down.


#8

I've taken a sort video of the different ways the app launches, it would take too long to do a video that captures the "no tuner" issue since that requires channels to be in the background for a period of time while other apps are in use.

This video shows how Channels DVR will re-launch if the system as shut it down in the background (force close to simulate). Notice the first force close works as it should, at launch a loading screen appears then it opens to a populated guide. Every other time it either displays the connection screen and then settings with the left swipe=down bug, or it displays a loading screen and brings up "on now" with "no channels".


#9

Sent a few more logs, any sign of what's going on?

Also is there anyway to check for ip changes on the ddns more often? About once a month mine changes and channels is always about an hour behind duckdns to make the switch (which causes an issue if I'm not around to auth refresh).


#10

@tmm1 @maddox Any ideas?

And to follow up on the ddns refresh, is there a way to plug the service you use into my router the same wahy I have DuckDNS setup? I assume since duckdns is actually setup the router is able to relay to the ddns service when an IP change occurs where as channels only updates every hour or so.


#11

There's no way to do that. Channels DVR Server communicates with our service by it's own means. It doesn't use any sort of ddns standard or anything.

How often does your IP really change that it's effected that fast? Mine doesn't seem to change at months at a time.


#12

Usually mine is only once every month or so, for some reason it changed twice in the last 24 hours and took about an hour each time for the DVR to adjust. I can auth/refresh if I notice it. Maybe there is a way to get notifications from duckdns when it changes, I'll look into that.

The false "no tuner" issue is more of a concern though.


#13

Submitted a few more logs of the same issue with the "no tuner" error disconnects. Tuners are available and a force close fixes it, upon reopening the app it behaves as previously described with a brief login page kicking over to settings with a bug that forces you to go down then back up the the top menu to get to the guide (shown in previous video).


#14

Find anything? @tmm1 @maddox


#15

tenor


#16

The logs show some indication of what's happening, but we haven't been able to reproduce yet.


#17

When the "welcome" screen comes up and it gives me the option to "search again" is that only a local network search?

If I lose my network connection for a short period of time the app won't pick it back up without being force closed, which may be related.

In my mind the app should always be looking for the remote server if it was setup as "away from home". If it loses the connect because the app was put in the background or even if the wireless AP was restarted it should immediately try to re-establish the connection.

I use Channels and Plex remotely and however Plex is handling things is much more elegant. If Plex loses the remote connection it immediately goes to a loading screen until is can re-establish, and changes in the remote wan IP have never given me any issue where channels typically takes ~1hr to adjust to a new IP on its own.