Spectrum TCM TVE not working

For the past week I have been unable to play or record Spectrum TCM TVE on my Apple TV, iPhone, iPad or iMac (server).

When I go to TCM on Spectrum TVE on the Apple TV (or iDevices) the screen shows “https://turner|ive.akamaized.net/hls/Iiv…” followed by “Connection Lost”

When I go to TCM on Spectrum TVE on the Apple iMac the monitor fluctuates between “reconnecting” and “The media could not be loaded, either because the server or network failed or because the format is not supported.”

At some point on the iMac server I saw “Failed: could not start stream on channe|s=[6039]: TVE: get: https://turner|ive.akamaized.net/hls/Iive/572111-b/tcme/aes_s|ate/V|DEO_5_864000.m3u8?

I have had this sort of thing happen a couple of times before. A server update has cured it.

I have been updating everyday this week with no satisfaction.

The Spectrum App on all devices shows TCM as expected.

Channels server: 2021.01.07.0725

All recent Apple hardware with current systems


Same here. First time noticing this after a month of using ChannelsDVR. TCM is one of my 40 saved favorite channels.

TCM doesn't seem to be showing up in Stremium as it has and the TCM app live portion isn't working correctly just now. On demand movies in the app are working.

Same issue here. Both Spectrum and WOW! TVE providers are exhibiting the same.

Considering live movies in TCM's own app isn't working, I would guess it is a temporary TCM problem and not related or fixable by ChannelsDVR.

Looks like the app has been updated and it’s using a new stream. I am able to watch using the app on iOS now both live and on demand content.
Using Directv login.

I rebooted my Firestick 4K and both live movie feeds are working as expected in the TCM app. You are probably right about it being a new stream.

Does TCM work on https://www.tcm.com/watchtcm/livestream? It won't load for me.

Not for me on FiOS.

I was able to get live tv and on demand movies to work with that link. However, I had to use the menu to login. Using the first popup to put in credentials didn't work. Clicking menu and then sign in, I was able to add credentials and everything on TMC website worked including live movie feeds east and west.

Using the link posted by @tmm1 above, I got it to load and play in Safari. It took a minute or so (perhaps longer) after provider login, before it popped up with option for East or West, and I was able to watch after clicking 'East' or 'West'.

It worked in Win 10, chrome browser for me...

...I was able to click 'login' at the menu bar at top and put in my credentials once no issue.

The live stream in a chrome browser works for me, but slow and it took a few tries. If I attempt to watch it via channels I get this error. Could be a CDN issue.

2021/01/07 14:50:18.542618 [HLS] Couldn't generate stream playlist for ch6039-dANY-ip192.168.1.39: TVE: get: https://turnerlive.akamaized.net/hls/live/572111-b/tcme/aes_slate/VIDEO_5_864000.m3u8?hdntl=exp=1610077817~acl=%2Fhls%2Flive%2F*~hmac=8ae71b253176bf7bfaf0ac5a37fa7fb8aaf760e8a1939712591ddf166d2d0c44: 404 Not Found

and login works on my iMac.

now it's working for me.

Channels or TCM app?


Please try the latest pre-release

1 Like

Working great! Thanks!

Scary good.

With but a mention of an anomaly with Spectrum TCM TVE on Channels DVR, I have been rewarded with an upgrade that solves the problem.

Thank you for your excellent work.

I hope other Channels users realize just how special Channels DVR support is.

version: 2021.01.07.2339