Stirr for Channels

It's working now!
Thank you!

Awesome! The new docker container works!
Looking at the log, it appears there is still an error with one of the channels. However, the new container now posts the error and continues processing the rest of the channels.
Thanks for posting the new container with the recovery code.

sadly, it still isn't working for me on my Synology 218+

A new latest image was pushed on July 30. Make sure you're running the latest image.

  1. Download the latest image to Synology Docker.
  2. Stop the stirr-for-channels container.
  3. Reset the stirr-for-channels container.
  4. Start the stirr-for-channels container.

For about the last week or so my stirr docker from robbie has not worked. It just keeps restarting in docker on my pc. Anyone else having an issue?

I seemed to have that issue, but I chalked it up to my image as being outdated as the last pull was over a year ago. I redid the setup and it seems to work now -- although there was a bit where it did a couple restarts before it came through.

As a reminder, you could also just use Hank's links

as robbie himself had mentioned in the first post...

1 Like

Yes, there was a bug in the docker code causing it to error out when there was bad data sent from Stirr. @tmm1 posted a fix for the GO code which avoided this error, which is incorporated into the links, but I'm not sure if it's been merged into the original docker repo.

Check the link above for the 'non-docker' links, I think it's discussed there about 1-2 months ago.


My issue did resolve itself after a few days & some restarts. I dont believe both the fix & original docker was ever merged.

this is weird ... when starting a fresh install of the container i'm seeing this

After some time it may or may not go away. When opening the link in Chrome, i get the 403 forbidden but opening the link in any other browser it works fine and i see Stirr data.

Browser problem? I've only installed chrome just for channels and have never used it as a browser so everything is as default as it gets.

I had to restore my mac mini from backup and resulted in resetting up docker stuff. Got pluto going, but when I tried stirr be reexecuting the command to load it, it went through the normal messages and then ended with the following and though it appears to be running, Channels won't show channels on the Stirr source.

Error response from daemon: driver failed programming external connectivity on endpoint stirr-for-channels (long code i didn't retype here): Bind for failed: port is already allocated.

Any ideas?

Some other container is already using that port

My suggestion is that instead of the Docker approach, you consider using the Stirr links provided by @HankLloydRight at, as it’s much easier.

Thanks, I'm guessing its Docker. Any suggestion on what port I could set it to? I had all this working great for a long time so don't recall what I did and wasn't expecting all the Docker stuff to be lost.

I also have a problem that after reboot Docker is in a "Docker Engine waiting..." state.

1 Like

Thanks for the suggestion. This has been working fine for over a year with Docker, so am going to try this first. But appreciate the idea.

I figured out that I typed 8080 instead of 8181. I think I did the exact same thing and year and half ago when first set it up. How do I remove the 8080 so I can type it in correctly?

You'll have to delete and recreate. Are you using portainer? If so you just click the duplicate/edit button and make your changes and it does the delete and recreate for you.

No, I'm running Docker Desktop. But by using the command line help I was able to figure out how to delete Stirr and then type in the correct command and everything took off. This solved the other problem I had with Docker not starting.

I did realize I need another long term solution for this because Docker Desktop no longer supports my Mac. When I did this a couple years ago I upgraded to Mojave because that was the oldest Docker Desktop supported. I just upgraded to Catalina, which is why I'm going through all this stuff. But Docker Desktop doesn't go back this far any more. Ugh. But for now I'm back in business.

1 Like

It takes like 2 seconds to use the non-docker method.

I see that now, but in the past the non-docker method was pretty lacking. I would still have needed to deal with docker because I didn't want to leave it the way it was.

What method was that?