Stream Link - Amazon Prime


Got Stream Link working for every service - except Amazon Prime. Followed the same process for Prime as I did the other services. The Prime selections show up in my Library fine - same as Netflix, Hulu, etc.

But (unlike Netflix, Hulu, etc) when I hit the "Watch" button - nothing happens.

Sorry for the obvious question but you have the Amazon prime video app installed on the device, correct?

1 Like

I do. No need to apologize - still working on a steep learning curve. I'll be asking tons of "obvious" questions :blush:

1 Like

I tried my first Amazon link this morning. On the iPad IOS Channels App, the link from Channels opens Prime Video, but does not show the movie or start playback. My iTunes links work well. I believe that I created the Amazon link correctly. Will try a few more tomorrow.

1 Like

You at least got the link to work/open Prime. That's good news. I'm working from Windows 10 Nuc.

I've tested links from Hulu, HBO Max, Showtime, and Netflix. All work fine.

Still nothing for my Amazon Prime links. Nothing happens when I click the Watch button. I'll try creating new links to test

1 Like

I have the same issue on my FireTV. Links work for the other apps, like HBO MAX, but not Amazon Prime.

1 Like

My Channels DVR Amazon links on either an iPad or an Apple TV 4K (2021) open the Prime app, but do not open the movie. The same links on the Amazon Fire TV 4K fail to open Prime.

1 Like

I suppose there's (some) comfort in knowing I'm not alone. Seems to be across a variety of platforms.

I'd just switched from fire tv (Recast/Cube/Fire Stick 4k) to full Android (Nvidia Shield & Chromecast with Google TV), and Channels just over a week ago.

Not a deal breaker for me. Just a mild nuisance - at the moment.

Hopefully this will be addressed soon.

1 Like

Sounds like it is a problem with the Prime Video app not properly responding to deep links. If that is indeed the case, the onus is on Amazon to fix it, as it is their app that isn't behaving as expected.

1 Like

Excellent point. Anything associated with Amazon can be tricky. Knowing I'm not alone at least tells me I'm doing it correctly.

For my situation - an extra second or two to just open the Prime app to watch something - not a big deal.

My only regret is not pulling the trigger sooner on switching to Channels Plus. This thing is great!

1 Like

Disregard this post. My apologies.

1 Like

Jumping in here as I'm just trying out Streamlinks for the first time and I am getting a 'Playback Failed (-17)' message when trying to open an Amazon Prime video that I imported. These do bring me to the Amazon page when clicked on through the web gui and play fine so I know I have access. I also do not see anything in the logs showing a problem. Is this the same thing that you guys are seeing?

I skimmed through this thread but surprisingly did not see any dev comment?

1 Like

I'm circling back on this as I'd REALLY like to use this on my FireTV devices. Can someone tell me if this has ever worked or has it never worked on the FireTV devices?

@tmm1 Is there support for this or is it deemed experimental and our results will vary?

This would greatly simplify things for me as I can cut out countless hours downloading content with PlayOn not to mention the space savings. Thanks

Submit diagnostics after playback failed error

1 Like

Thanks @tmm1 . Log submitted from server:

Logs have been submitted as fe4d4b17-8283-460c-80b0-65dc09411ca3

Also submitted from FTV device (video player, crash, other sent)

@tmm1 Were you able to see anything in the logs I submitted?

Not really. FireOS is really bad at logging so all the interesting stuff was gone by the time you submitted.

I will dig out a FireTV device and try this sometime. It shouldn't even be loading the player if its a stream link. What URL did you put in the .strmlnk file?

1 Like

@tmm1 Just seeing your reply. Apologies for the delayed response (and for submitting a request via email).

I've tried the Survivor ones I found here:

I just tried this one (S28e01):

The error comes up immediately so it seems like it is not even trying.

I'd REALLY like to get this working. Definitely willing to experiment and troubleshoot.

1 Like

Do you know if Reelgood or JustWatch work correctly with amazon links?

I do not, but am willing to try. Are you suggesting modifying the link from what I have now to what Reelgood/JustWatch shows? I've not used either of those but will explore.