Stream Link - Amazon Prime

@tmm1 Did a quick look at both of those services:

For season 28 episode 1 the url looks like this from reelgood:

and from the github repo:

The URLS are indeed different. I made the change to the reelgood one, tried loading on Fire TV and it gave the same playback error. I'm assuming that it reads that file each time. Do I need to reimport for it to pick up the new URL?

You need to Refresh Metadata on the import to reload the URL

1 Like

@tmm1 Refreshed media, force closed app, cleared cash, opened and tried. Same error as before with the new URL .

Can someone provide a known working stream link for an Amazon Prime movie/episode so I can make sure I'm not going up against something weird?

@tmm1 Do I need to be running android beta on my Fire TV to be able to use Stream Links or is it in the release? I'm looking at old threads and it seems it might have needed beta app in the past?

The beta is not required. Clearly there is some bug. Realistically it will take me a few weeks to look into this.

1 Like

I'm thinking the same. But only based on public release notes at
Haven't read every post about it and know the Android releases lag the Apple ones.

Support added for DVR in 2021.02.02.2209 [You can add them]
new Support for Stream Links

Support added for AppleTV and iOS Version 4.4.1 (February 3rd, 2021) [You can use them]
new Stream Links - Add content from streaming services to your Channels library

Nothing about it in Android & Fire TV Release Notes, yet (unless it's hidden in the release notes).

1 Like

@tmm1 While disappointing, I do understand on the timing. My trial will be ending before then but I think I will continue and purchase a subscription. This is something that would be most beneficial so please don't be offended if I ping/pester you about this in a few weeks.

@chDVRuser I'm new to Channels. Still looking for confirmation from you or someone to say whether these have ever worked on FireTV so I don't continue trying things. I don't subscribe to any other supported services but can try Peacock free links as a test to see if this is Prime related or that Stream Links just don't work at all.

1 Like

@tmm1 Further investigation is leading me to believe that Stream Links for FireTV is not working at all. I tried a link for Peacock Free and it opened the episode fine on web GUI, but I got the same 'Playback Failed (-17)' error when trying on FireTV.

Just adding this information for when you get time to dig in.

1 Like

Is there any difference if you create only a single episode stream link and there's no other episodes for the same show?

@tmm1 Just tried 'Airwolf' S01E01 from Peacock Free links from Maddox Github repo (that's where all of these have been coming from btw). I have never recorded this series or imported any from this series into Channels before. It gives me the exact same error as with the others I've tried.

The current errors being seen are a bug in Android APK 3.5.2:

Since FireTV is built on top of Android, fair to assume it is the same thing.

Per directions in the link, it is necessary to downgrade to 3.5.1 in order to get Stream Links working again (or at all if you are new).

Just tried an Amazon movie link and while it did not play, it did not load the player and give the error either. I click watch and absolutely nothing happens.

Further, just tried a Peacock Free movie and I get 'Unsupported Browser Link' when trying to play. All TV shows I've tried give the playback error but movies have a different behavior. Again, all coming from the github repo

Per above, it looks like Amazon does not have Deep Linking set up correctly on their Prime Video app on Android (Android TV, Google TV, Fire TV, Android Phone), which is ironic. I do not have Prime so had not tested until now, but believe as well that the problem there is Amazon.

That said, the behavior is different compared to, say, Kanopy. When you click to watch Kanopy it comes up with the error "You don't have an app that can do this" which is an indication that Deep Linking is not set up in the app. When you do the same for a Prime Video, even if the app is not installed, no error pops up at all. It may be possible that some logic is built into the Channels Android APK that is specifically intercepting Amazon links. @tmm1, something for your review later.

Peacock has not set up Deep Linking in their app, either, at least as of when I last tested in February. Sounds like it is still the same.

Seems like you are just hitting bad luck picking the apps where Deep Linking does not work!

All Stream Links being broken in Android APK 3.5.2 and needing to downgrade to 3.5.1 is a separate issue.

1 Like

That is bad luck. These are the only two that I have access to so no way to test further on my end. Frankly, these are the only two I really care about for the same reason.

I do find it odd that I am the only one reporting this as nonworking best I can tell. I'd think other FireTV owners would also like to use the Prime Video stream links as I'd guess a fair number of them would have Prime accounts.

I'm uploading a new beta build now with a fix for the stream link bug.

I also removed some broken code that may have been affecting the amazon prime attempts. It should actually try those links now, so maybe you can find a format that works.

As far as I can tell, it is not possible to deep link into peacock.

1 Like

I was able to get Prime links working. New beta uploading now.

I only tested on Android TV but I'm guessing it will work on FireTV too.

I can confirm that previously working Stream Links and Prime Video Stream Links are both working in APK Beta 107.29.35 in some pretty limited tests on Android/Google TV.

For Prime Video, I didn't do anything special, just went to the page on Amazon and picked up the link. For instance: "". I didn't even remove the "smile." and it worked fine!

1 Like

Are you referring to the app beta or the server beta? I updated server last night and just tested with no change. I guess it's the app beta. How do I download the apk so that I can sideload? Is it stored in a repo somewhere that I can grab it easily?

App beta, installed via Settings > Support > Install Beta from the normal app