Stutter watching Live TV on ATV (non-4k)

I wasn't sure which thread to tack on to as there are many, but we've been regularly experiencing stuttering on our Apple TV (4th gen, not 4K) when watching live TV. Today we are sitting here trying to watch the Patriots game, and about once every 10-15 seconds we get a moment of stutter. It's quite frustrating, as you might imagine. :slight_smile:

I tried force-quitting the app on my Apple TV, but that doesn't seem to help. If I play the same thing on my web browser or iPad instead, no issue with stuttering whatsoever, so it definitely seems like an Apple TV-related issue

Logs: 7c0e7185-bff9-45c9-9bb8-ee99d5a335ae

Happy to try anything, of course. Thanks!

Edit/Addition: the video always stutters for 5-10 seconds after I skip forward, and then it settles in, after which I get the behavior I initially mentioned above.

Edit 2: I've tried using both Experimental and Default as the Audio driver, doesn't seem to make a difference.

how is the apple tv connected? if it is via wifi, then change it to wired ethernet and see if it still stutters.

Thanks for the reply! It's Ethernet connected, for sure.

May have better luck with WiFi on that AppleTV.
Also try with tuner sharing on and off.
If it only happens with tuner sharing on, may be your server or network path from server to client device.

Have you run a speed test from the Apple TV to the DVR server?

Thanks for this! I just now ran a speed test and it comes in at 57.91 Mbps, 15.47ms Latency, and 2.40ms jitter (this is over Ethernet).

Also, I don't seem to have an option for toggling tuner sharing, but perhaps I didn't clarify: I don't have a tuner, I'm using TVE for this.

Does that change anything?

TVE automatically uses tuner sharing.
My guess is it's TVE causing the issue with messed up timestamps because of the way ads are inserted.

If that were the case, wouldn't everyone be experiencing this?

Also, I don't have commercial scanning/skipping enabled for sports because I thought disabling it might help this problem. Needless to say, that didn't make a difference.

If has nothing to do with comskip. It has to do with the stream from the network website where Channels DVR gets it from and how they insert ads in the stream.

Try pausing the Live channel for about 30 seconds before you start playing it. Keeping the player about 30 seconds behind Live. If that helps it's a latency/buffering issue.

I thought about that early on, but I have this issue even if I start watching an hour after it starts recording, so I don't think that's it.

But you may be on to something with the bandwidth between Wi-Fi vs. Ethernet. I just moved to Wi-Fi and did a Speedtest and got ~250Mbps (which seems nuts since it's connecting to the access point a foot away, all the same network segment). I realize this Apple TV has a 100-BaseT ethernet port, but seems odd it would be half of that (at best).

Unfortunately, this didn't solve the stuttering issue, so that still remains for me.

What I meant was as soon as you choose to watch on the ATV, pause it for 30 seconds to let it buffer what it's playing in the device. Don't know how else to describe it, but to me when I try to play anything in H.264 at the edge (like chasing Live TV and catching up to the Live point) I always have issues. Giving the device a buffer seems to let it play smooth. With TVE using H.264 and open GOP's, it seems to have issues. Mpeg2 or closed GOP's don't experience that problem.

That is slow!
I am getting almost 500Mbps to the Onn UHD streamer over wifi.

1 Like

57 Mbps is slow for 100 Mbps Ethernet. Have you tried rebooting the network devices between the Apple TV and your DVR server, what hardware are you running the server on?

1 Like

I should also mention you can verify that the stuttering is being caused by network buffering by showing stats in the client. It will show you how many seconds of content are in the buffer.

1 Like

Yeah, I noted that in a future post. It's bizarre, because that same Apple TV connected to a wireless access point on the same switch hits 250Mbps+, so not sure what the Ethernet issue is, but have moved to Wi-Fi (for now) to continue testing this.

Thanks! I turned on the stats and am averaging ~92-seconds of buffer and still seeing stutter, even on a recording, so it's definitely not network buffering. Hmm...

1 Like

Could you submit diagnostics from the app after you notice the stutter

1 Like

I just made it stutter (by playing back a recording) and went into Support > Submit Diagnostics in the ATV app. It didn't give me a number/ID or anything, though, so I'm hoping it somehow flags it with may account? If I did something wrong, please just let me know and I'll re-try!

Thanks I got it.

Does it also happen with default video driver?

Yes. I thought my most recent test was with the default video driver, but suffice to say I’ve been seeing it with all permutations of video, audio, and deinterlacing settings.

It may be worth deleting and reinstalling the app. Some users reported that fixed problems even though we're not sure why.

1 Like

Thanks! I tried that (deleted entirely from the ATV and reinstalled the beta via TestFlight) and it was definitely better. It went back to default video driver, of course, and once a show got going it settled in and was showing less dropped output frames than before, but was still noticeably skippy.

Then I enabled the experimental video driver and it was terribleness all over the place.

Dropped input frames remain at 0 throughout.

This definitely wasn’t happening a few weeks ago when I started using things, and only seemed to creep up in the past 10 days or so.

Is it that the ATV is simply having trouble keeping up with however Channels is trying to display things? I don't have this issue with other apps, of course, if that’s any help as a data point?

Edit: I also don't have this issue running Channels on my iPhone, iPad, or Laptop over the same Wi-Fi network. I checked and the stats show 0 dropped output frames on those devices, so I think this is a specific issue with the Channels app itself (as opposed to the DVR server) and only on the Apple TV 4th Gen.