T-mobile

I've recently got rid of cox and I'm now using t-mobile internet. I've found that plugging in my archer AX50 router works better than just my t-mobile router. But now I have the problem of "Outgoing connections are coming from 172. but the external IP of the router is 192." T-mobile is using 172 ip while my archer is using the 192 ip. What do I need to do to fix this?

Remote streaming does not work with Carrier-grade NAT based providers. T-Mobile internet is engineered like cell phone internet, customers share public IP addresses while handed an internal ip address to use on their network. This is like being behind a router, with no access to its administration.

Without a real public IP or means to map ports, remote streaming can't work.

1 Like

T-Mobile uses CGNAT, which is incompatible with Channels' remote access. For more, see this existing thread:

That's a bummer. I use the dvr feature more at home on my apple tv which still works. I rarely remote in but it's nice to be able to do it when I want. Maybe in the future someone can figure out a simple work around.

You could try using Tailscale

I have vpn unlimited. Is tailscale better? Could I configure VPN unlimited to work?

They're two different things. One is an outbound VPN and the other is an inbound VPN.

I’ll look into it. Thank you very much?

That wasn’t suppose to be a question.

1 Like

Tailscale works great I use it to access my backup DVR.

I've installed tailscale on my pc and on my iphone. What would be the next step? Or is this too complicated?

you login with your acct ... it will show your server you can click on it that will copy your tailscale ip or write it down then enter that IP in channelsdVR on the home section.

Make sure tailscale is running on the server.

If you mean use the channels app on my iphone and add the tailscale ip address, I did that. tailscale is running. I'm not sure what I'm doing wrong.

Tailscale must be running on your server .....

  1. Make sure TailScale is running on your phone and active.
  2. Click on Tailscale APP on Phone where you see your server name ... it will copy IP to Clip Board.
  3. Startup Channels ... Click on Connect .. select home not away ...
  4. Long Press where you enter your ip and you can paste it there. or you can enter your TailScale server IP manually.

Remember it will connect as if you are home so it will play the original bitrate ... If it stutters adjust the Home quality in your settings as needed.

1 Like

The server is running on my computer. It's also running on my phone. I did everything you said and it says the server can not be reached. Maybe there is a problem because I have t-mobile home internet. I don't know.

Sorry maybe the developers will Chime in I posted all I could.

Thanks for your help.

  1. Choose Connect
  2. Choose At Home
  3. Enter the tailscale IP address of your server at home

You are directly connecting it via IP address like you would do at home.

I tried that. It says it can’t connect to server.

make sure you are inputting on the phone the ip of tailscale on the server not the Local IP of the server.