The New Cube fixes the interlacing issue!

My New Fire Cube arrived late this afternoon and I have just spent the evening setting it up and I can confirm the HD channels with interlaced h264 seems to be working perfeclty with hardware transcoding.

However at this point I am not 100% sure as the hardware / software option does not seem to be avaialble to the cube? Am I right to assume this means it is defaulting to hardware?

If so I can confirm the issue is not present on the cube like it is on the 4K Stick, the only issue is the black screen with sound only on the SD channels which I believe is related to the .13 build of Channels not a cube issue

Can you submit diagnostics from the app and I can see which mode is being used.

Done submitted as "other"

I have a feeling is is hardware but its difficult to tell as I am limited to only 5 channels because of the other issue and none of the prgrams on are higher framerate programs that would give the issues we had with the software decoding

Yep its using hardware mode. Glad to hear it works well!

Yeah it works very well. There is nothing wrong with the speed of the FTV4K but the Cube is just that much quicker to load everything such as Plex and Channels initial opening.

It's a shame I have had to shell out quite a bit for a big lump I dont really want infront of my living room TV but at least 1 TV can watch TV correctly now.

I am hoping there will be a fix 1 day for the stick but the longer that github thread goes on the more unlikely I think it is we will ever see a firmware fix for the interlaced h264 now, think we are more likely to see a "New" 4K Stick before the current one gets fixed!

Can you remind me what happens on your 4K Stick when you play an HD channel?

There is a fix in the 2.1.13 build that might help.

In software decoding on higher framerate content the viewing experience is really choppy.

In hardware decoding it freezes

Okay the freeze issue I believe is fixed in yesterday and today's release (v2.1.13 or v2.1.14).

What!? Wow really so the FTV4K can now use hardware decoding from 2.1.13 onwards without crashing?

Thats amazing! Means I waste the night setting up the cube and bought it for no reason but its still great news for my other TVs!

Not confirmed yet, there seem to be several bugs on the 4K stick. I fixed one of them, which may or may not be the one you were hitting.

1 of my 4K's has updated to .13 so I have just set it off playing ITV HD in hardware decoding, this would usually crash pretty quickly.

If it crashes I will send diagnostics, if it doesnt I will report back with the potentially good news! If it doesn't crash this is not just good news but very very good news it means the 4K Stick is finally the perfect device for me and I no longer need to hear my wife moaning when her programs looks "weird"


So far so good! It would definitely have crashed by this point usually!!

I need to go to bed now but so far .13 has not crashed when using hardware decoding. I don't believe interlaced h264 content has ever played for this long without crashing. I wasn't actually watching the TV but it was definitely still playing!

Whatever you clever geniuses have done certainly seems to have worked. If this is a full fix you really need to email every customer who's bought the app for the fire TV as this is huge news for us. I can't say how much I appreciate this thank you


Back home from work and been doing a bit of testing on this one as all my FTV4Ks have updated to .13 now.

I have 4 TVs ruining channels simultaneously. They are all on hardware decoding running the following channels: BBC1 HD, ITV HD, 4HD, 5HD

These 4 TVs have been running for 30 minutes each without any freezing. My wife has also watched a bit of TV today without any freezing. It's looking as though whatever you guys have done has worked as we finally have a working solution for hardware decoding in the FTV4K

As mentioned earlier if it crashes I will submit diagnostics but so far so good no issues

1 Like

No freezes for me either with h264 or mpeg2. No option to select software or hardware decoder in the menus. Can’t recall when this was removed or it it cube specific now the cube seems to have fixed the problems.